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Introduction 
Beacon Designer designs Molecular Beacons for Standard Real Time PCR and Nucleic Acid 
Sequence Based Amplification(R), TaqMan(R), LNA(TM) Substituted TaqMan, FRET probes and 
SYBR (R) Green primers for real time detection of PCR products. Beacon Designer provides the 
following major functionality:  

Beacon Design 

Automatic Tm adjustment - automatically selects staem of appropriate length for optimal beacon 
Tm. 

Optimal beacons - designs molecular beacons free of dimers, repeats, and runs for increased 
signal strength. 

Allele discrimination - designs molecular beacons for detection of both wild and mutant alleles. 

Multiplex beacons and primers - checks molecular beacons for cross homologies with all 
primers preventing competition in multiplex reactions. 

Evaluate pre-designed Beacons - allows use of previously designed beacons as a base for 
searching primers/beacons on other targets for multiplexing. 

Tm calculation - highly accurate hairpin Tmcalculation by connecting to the mfold server. 

Lightning fast - processes average cDNA sequence in under a second. 

Graphical view - displays graphical view of the designed beacon. 

TaqMan(R) probe 

TaqMan(R) probes - designs optimal TaqMan
(R)

 probes free of dimers, repeats, and runs to 
ensure signal fidelity. 

Multiplex TaqMan(R) and primers - supports multiplexing for up to four sequences, checks for 
cross homologies with all probes and primers preventing competition in multiplex reactions. 

Evaluate pre-designed TaqMan(R) probes and Primers - allows use of SYBR (R) green assay 
primers to design optimum TaqMan

(R)
 probes. 

Algorithm - calculates Tmusing highly accurate SantaLucia nearest neighbor thermodynamic 
values. 

Graphical view - displays graphical view of probe secondary structures. 

LNA(TM) Substituted TaqMan(R) Probes: 

LNA(TM) Substituted TaqMan(R) probes - designs optimal LNA(TM) Substituted TaqMan
(R)

 
probes of small length and high Tm, free of dimers, repeats, and runs to ensure signal fidelity. 

Multiplex LNA(TM) Substituted TaqMan(R) Probes and primers - supports multiplexing for up to 
four sequences, checks for cross homologies with all probes and primers preventing competition 
in multiplex reactions. 

Evaluate pre-designed LNA(TM) Substituted TaqMan(R) probes and Primers - allows use of 
SYBR (R)

 green assay primers to design optimum LNA(TM) Substituted TaqMan
(R)

 probes. 
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Algorithm - calculates Tmusing highly accurate correction values given by Dr. Raymond Peterson 
and then added to SantaLucia nearest neighbor thermodynamic values. 

Graphical view - displays graphical view of probe secondary structures. 

FRET Probes 

FRET probes - designs optimal FRET probes free of dimers, repeats, and runs to ensure signal 
fidelity. 

Multiplex FRET probes and primers - checks FRET probes for cross homologies with all 
primers preventing competition in multiplex reactions. 

Evaluate pre-designed FRET probes and Primers - allows the use of SYBR
(R)

green primers to 
design optimum FRET probes. 

Algorithm - calculates the Tm using highly accurate SantaLucia nearest neighbor 
thermodynamic values. 

Graphical view - displays graphical view of probe secondary structures. 

Primer Design 

Design primers - designs primer pairs optimized for SYBR (R)
 Green/ beacon/ TaqMan

(R)
/ FRET 

applications. 

Algorithm - calculates Primer Tmusing highly accurate SantaLucia nearest neighbor 
thermodynamic values. 

Primer rating - primers ranked as per their priming efficiency. 

Comprehensive criteria - primers are screened for their thermodynamic properties as well as 
secondary structures. 

Automatic Primer Multiplexing - pools of primers are checked for cross homologies to reduce 
primer dimer. 

Pre-designed primers - allows the use of previously designed primers for beacon, TaqMan
(R)

, 
FRET and SYBR (R)

 Green assays. 

Avoid template secondary structures - automatically avoids secondary structures in the 
template while designing primers. 

Avoid cross homology - ensures signal fidelity by automatically avoiding homologies found 
using BLAST. 

Primer amplicon and probe BLAST search - BLAST searches primers, amplicon and probes to 
verify specificity of the design. 

SNP amplification Primers for beacon, TaqMan(R) and FRET chemistries are designed to amplify 
SNPs. SYBR (R) Green primers are designed so that the nucleotide that distinguishes the alleles 
is at the 3' terminal base of one of the primers. 

Uniform conditions - all primers in a run are optimized for identical reaction conditions for PCR. 

BLAST Search 
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BLAST search - BLAST search the entire sequence, designed primers and amplicon to visualize 
specificity. 

BLAST databases - searches local custom databases using stand-alone BLAST or connects 
directly to the NCBI server for public databases. 

Repeat and low complexity regions - BLAST search parameters are optimized to detect 
repeats and low complexity regions while searching the genomic databases available at NCBI. 

BLAST result view - provides result view for BLAST searched on the sequence, primer-pair, 
amplicon and probe. 

Database and Data Management 

Design modes - Beacon and TaqMan(R) design are in different modules: Allows mode switching 
at run time. 

Projects - creates multiple projects.Data of multiple experiments can be easily managed by 
creating separate project for each experiment. 

Application Database - maintains a local database for sequence information and search results. 

Web Integration 

Web Integration - batches of sequences can be quickly retrieved from Entrez using accession 
numbers and from dbSNP using assay IDs. 

BLAST search - integrated BLAST search of any loaded sequence. Local customized databases 
can also be searched using the Standalone WWW BLAST service from NCBI.  
 
Beacon and Template Secondary Structure Search - integrated with the Quikfold server to 
view the possible secondary structures at folding temperature. These structures are avoided in 
probe and primer design. 

Input/Output 

Online sequence retrieval - automatically connects to Entrez or dbSNP and retrieves multiple 
sequences. 

File formats - supports GenBank, FASTA, and db SNP formats. GenBank and FASTA formatted 
files can contain multiple sequences. 

SNP loading - easily adds SNP(s) at a time on a single sequence or load thousands of SNPs 
using standard GenBank variation files. 

View output in spreadsheet - results can be viewed and manipulated in any spreadsheet 
program like MS Excel and Lotus123. 

Flexible output format - tab delimited format of the output file can be easily loaded into any 
database. 
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Working Environment 

Menus and Toolbar 
The Beacon Designer toolbar is displayed at the top of the main window under the menu bar. It 
provides shortcut buttons for the following menu commands. The toolbar options can also be 
accessed from pop-up menu at right click (For Macintosh, CTRL+click) over the Sequence 
Information tab and Search Status tab.  

Menus 

The main menu bar is at the top of the main window. 

 

 

Menu 

 

Toolbar Hot Keys  
(For windows)

Hot keys  
(For MAC) 

Description 

Beacon 
Designer  

      Program version and 
PREMIER Biosoft contact 
information 

About Beacon 
Designer 

        

Quit Beacon 
Designer 

        

File Menu   Alt+F      

New         

New Project 
 

Ctrl+N 
+N 

Create a new project to 
manage the data of every 
new design project. 

New Sequence 
 

Ctrl+E 
+E 

Add a text sequence from 
any other application by 
cutting and pasting the 
sequence bases or by 
manually typing the 
sequence in the 
Sequence window.  

Open         
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Project  
 

Ctrl+O 
+O 

Open to work on an 
existing project. 

Sequence:         

From File 
 

Ctrl+L 
+L 

Retrieve one Single or 
multiple more sequences 
from a local file. (must be 
in FASTA or GenBank 
format ) 

From Entrez 
 

Ctrl+G 
+G 

Retrieve one or more 
sequences from Entrez. 
Program interprets the 
SNP information in the 
header and displays it 

From dbSNP 
 

Ctrl+S 
+S 

Retrieve one or more 
sequences from dbSNP 

Save Project 
As 

   Save the existing project 
with different file name at 
specified location 

Save 
Sequence As 

   Save the existing 
sequence with different 
name within the project 

Close Project        Close and save the 
current project. 

Export       Exports the primer and 
probe search results in a 
tab delimited spread sheet 
format file type(.xls,.csv). 

Export Beacon 
Results  

Ctrl+Alt+E 
Alt+E 

Launch Export Results 
window for beacon search 
result export. 

Export 
TaqMan® 
Results 

 
Ctrl+Alt+E 

+Alt+E 
Launch Export Results 
window for TaqMan® 
search result export. 

Export 
Multiplex 
Results 

 

 

Ctrl+Alt+E 
+Alt+E 

Launch Export Results 
window for Multiplex 
Search result export 
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Export FRET 
Results  

Ctrl+Alt+E 
+Alt+E 

Launch Export Results 
window for FRET search 
result export. 

Export SYBR® 
Green Results  

Ctrl+Alt+E 
+Alt+E 

Launch Export Results 
window for SYBR® Green 
search result export. 

Report       Export the design results 
in a report format that can 
be printed. 

Generate 
Report  

    The user may select the 
data that needs to be 
included in the report by 
checking or un-checking 
the boxes of the 
corresponding fields. 

Exit       Saves active working 
project and terminates 
program. 

Edit Menu   Alt+E     

Copy         

Sense Primer   Ctrl+Shift+E 
+Shift+E 

Copy the Sense Primer of 
the selected sequence to 
the clipboard. 

Antisense 
Primer 

  Ctrl+Shift+A 
+Shift+A 

Copy the Anti-sense 
Primer of the selected 
sequence to the clipboard.

P2 Primer  
(In case of 
NASBA 
Primers) 

  Ctrl+Shift+E 
+Shift+E 

Copy the P2 Primer of the 
selected sequence to the 
clipboard. 

P1 Primer  
(In case of 
NASBA 
Primers) 

  Ctrl+Shift+E 
+Shift+A 

Copy the P1Primer along 
with Tag of the selected 
sequence to the clipboard.

Beacon 
Sequence 

  Ctrl+Shift+B 
+Shift+B 

Copy the Molecular 
Beacon probe of the 
selected sequence to the 
clipboard. 
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TaqMan®  
Sequence 

  Ctrl+Shift+T 
+Shift + T

Copy the TaqMan® probe 
of the selected sequence 
to the clipboard. 

FRET  
Sequence 

  Ctrl+Shift+F 
+Shift+F 

Copy the FRET probe of 
the selected sequence to 
the clipboard. 

Select All   Ctrl+A 
+A 

Select all sequences in 
the Sequence Information 
tab. 

Search 
Sequence  

Ctrl+F 
+F 

Search Sequences. 

Delete 
Sequence  

    Delete selected 
sequences in the 
Sequence Information tab.

View Menu   Alt+V     

Sequence 
Details  

  Ctrl+Alt+Q 
+Alt+Q 

View selected sequence 
source file.  

BLAST Details         

Complete 
Sequence 

  Ctrl+Shift+S 
+Shift+S 

View BLAST results 
information for the 
selected sequence.  

Primer Pair   Ctrl+Shift+P 
+Shift+P 

View BLAST results 
information for the Primer 
Pair. 

Amplicon   Ctrl+Shift+C 
+Shift+C 

View BLAST results 
information for the 
Amplicon. 

Probe   Ctrl+Shift+R 
+Shift+R 

View BLAST results 
information for the Probe. 

Template 
Structure 
Details 

  Ctrl+Alt+T 
+Alt+T 

View Secondary structure 
information for the 
selected sequence.  

Multiplex 
Primers  

Ctrl+Shift+I 
+Shift+I 

Launch Multiplex Primers 
result window.(More than 
one sequences should be 
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selected) 

Multiplex 
Beacon  

Ctrl+Alt+B 
+Alt+B 

Launch Multiplex Beacons 
result window in the 
Beacon Mode. 

Multiplex 
TaqMan®  

Ctrl+Alt+U 
+Alt+U 

Launch Multiplex 
TaqMan® result window 
in the TaqMan®Mode. 

Multiplex FRET 
probes  

Ctrl + Alt + F 
+ Alt + F 

Launch Multiplex FRET 
results window in the 
FRET Probes Mode. 

Cross 
Homology 

  Ctrl+Alt+H 
+Alt+H 

View Cross-Homology 
results data interpreted 
form the BLAST results 
for the selected sequence.

All         

Primer       View All primers for the 
selected sequence 
ordered by descending 
rating.  

Probe 
(Beacons / 
TaqMan®/ 
FRET probes) 

      View All alternate probes 
for the selected sequence 
ordered by descending 
rating.  

All Structures         

Primer       View graphical displays of 
primer secondary 
structures for the selected 
sequence. 

Probe 
(Beacons / 
TaqMan®/ 
FRET probes) 

      View graphical displays of 
probe secondary 
structures for the selected 
sequence. 

Sequence View   Ctrl+Alt+Z 
+Alt+Z 

Show/Hide Sequence 
View. 

Base Per Block 
 

    Shows either 3/10 bases 
per block in the sequence.
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Sequence 
Strand  

    Shows either 
Single/Double strand in 
the sequence. 

Tool bar       Show/Hide Tool bar. 

Status bar       Show/Hide Status bar. 

Analyze Menu   Alt+A     

Beacon Design 
Mode 

        

Primer Search         

NASBA 
Primers  Ctrl+M 

+M 
Launch NASBA Primers 
selected, Primer Search 
parameter window. 

 
Standard 
Primers 

 
Ctrl+L 

+L 
Launch Standard Primers 
selected, Primer Search 
parameter window. 

Evaluate 
Primers 

        

NASBA 
Primers  Ctrl+Alt+B 

+Alt+B 
Launch NASBA Primers 
selected in Evaluate 
Primers window for 
evaluating pre-designed 
primer pair. 

Standard 
Primers  

Ctrl+Alt+P 
+Alt+P 

Launch Standard Primers 
selected in Evaluate 
Primers window for 
evaluating pre-designed 
primer pair. 

Beacon Search  
 

Ctrl+R 
+R 

Launch Standard Beacon 
selected, Beacon Search 
parameter window for 
beacon search. 

Evaluate 
Beacons   

Ctrl+Alt+R 
+Alt+R 

Launch Evalaute Beacons 
window for evaluating pre-
designed molecular 
Beacon. 
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Template 
Structure 
Search 

 
Ctrl+T 

+T 
Launch Template 
Structure Search 
parameter window for 
Template secondary 
structures search. 

BLAST Search         

Complete 
Sequence...  

Ctrl+Alt+S 
+Alt+S 

Set parameters and 
launch BLAST Search for 
selected sequences. 

Primer Pair 
 

Ctrl+Alt+M 
+Alt+M 

Launch BLAST Search 
Primer Pair window to 
verify cross homology in 
the designed primer pair.  

Amplicon 
 

Ctrl+Alt+A 
+Alt+A 

Launch BLAST Search 
Amplicon window to verify 
cross homology in the 
designed Amplicon.  

Probe 
 

Ctrl+Alt+O 
+Alt+O 

Launch BLAST Search 
Probe window to verify 
cross homology in the 
designed probe.  

TaqMan® 
Design Mode 

        

TaqMan® 
Search 

        

LNA(TM)® 
Substituted  

 Ctrl+U 
+U Launch LNA(TM)® 

Substituted  
selected  
TaqMan® Search 
parameter window.  

Standard  
 

Ctrl+R 
+R 

Launch Standard  
selected  
TaqMan® Search 
parameter window.  

Multiplex 
Search 

    

Standard   

 

Ctrl+Alt+D  
+Alt+D  

Launch Standard  
selected  
Multiplex Search 
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 parameter window. 

LNA(TM)® 
Substituted   

Ctrl+Alt+L  

 
+Alt+L  Launch LNA(TM)® 

Substituted  
selected  
Multiplex Search 
parameter window. 

Evaluate 
TaqMan® 

        

LNA(TM)® 
Substituted  

 Ctrl+Alt+L 
+Alt+L Launch LNA(TM)® 

Substituted  
selected, Evaluate  
TaqMan® Search window. 

 Standard  
 

Ctrl+Alt+R 
+Alt+R 

Launch Standard  
selected, Evaluate  
TaqMan® Search window. 

FRET Probes 
Design Mode 

        

FRET probe 
Search  

Ctrl + R 
+ R 

Launch FRET Search 
parameter window for 
FRET probes search. 

Evaluate FRET 
probes  

Ctrl + Alt + R 
+ Alt + R 

Launch Evaluate FRET 
window for evaluating pre-
designed FRET probes. 

SYBR ® Green 
Primer Design 
Mode 

        

SYBR® Green 
Primer Search   

Ctrl + M 
+ M 

Launch SYBR ® Green 
Search parameter window 
for SYBR ® Green primer 
search. 

Evaluate 
SYBR®Green 
Primers 

 
Ctrl + Alt + P 

+Alt + P 
Launch Evaluate SYBR® 
Green window for 
evaluating pre-designed 
primers. 

Tools Menu   Alt+T     

Reaction       Set reaction conditions for 
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Conditions primer design. 

SNP       Add or Delete SNP 
information 

Add 
 

Ctrl+Shift+N 
+Shift+N 

Launch window for adding 
SNP information to the 
selected sequence. 

Delete 
 

Ctrl+Shift+D 
+Shift+D 

Delete SNP information. 

Online Menu   Alt+O     

Entrez Home       Launch the Entrez home 
page in default browser. 

Internet 
Settings 

      Set up Internet proxy 
server. 

Assays   Alt+N   Switch between Beacon / 
TaqMan® / FRET / 
SYBR® Green Design 
modes. 

Beacon Design       Switch to Beacon Design 
mode. 

TaqMan® 
Design 

      Switch to TaqMan® 
Design mode. 

FRET probes 
Design 

      Switch to FRET Probes 
Design mode. 

 SYBR® Green 
Primer Design  

      Switch to SYBR® Green 
Design mode. 

Help Menu   Alt+H     

Contents 
 

F1   View online help for 
Beacon Designer. 

Online  
Tutorial 

      Open an online tutorial. 

Check 
Upgrades 

      Automatically detects for 
availability of a free 
program upgrade and 
installs it on your 
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computer. 

PREMIER 
Biosoft home 
page 

      Open PREMIER Biosoft 
home page in your 
browser. 

Request 
Feature 

      Open an online form to 
request any new features 
to serve your research 
needs. 

About Beacon 
Designer 

      Program version and 
PREMIER Biosoft contact 
information. 

  

Toolbar 

Beacon Mode 

TaqMan® Mode 

FRET Probes Mode 

 SYBR® Green Mode 
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Main Window 
;  
The main window displays the Sequence Information Tab, Search Status Tab, Sequence View 
and the Search Results Tab.  

Sequence Information Tab 

The table allows you to select sequences probe and primer design, BLAST search, template 
search and multiplexing. It displays the accession number, definition, and sequence length of all 
the sequences within a project. Sequences can be sorted by accession numbers, definition, or 
sequence length by clicking the respective column headers. You can also delete the selected 
sequence(s). 

Search Status Tab 

For convenience, an overall view of the designed primer and probe quality is given in the Search 
Status Tab at the end of each search. 

The search status is displayed in their respective modes. Primer search, BLAST search, template 
search and SNP status are common to all the modes.  
For Beacon/TaqMan(R)/FRET probe search and primer search, the quality of the designed probe 
and primer is displayed as Best, Good, Poor or Not Found. The probes and primers with the 
rating greater than or equal to 75 are termed Best, those between 74 and 50 are termed Good, 
and those with the rating below 50 are termed Poor. If no probes or primers are found that meet 
the selected set of parameters "Not Found" is displayed in the search status. By clicking the 
column header you can sort sequences by their quality. (Algorithm and Formulae)        
Similarly the BLAST search status is displayed as "Complete" or "Not Found" on the basis of the 
results returned from NCBI BLAST server. The Template structure search status is also displayed 
as "Complete" or "Not Found"on the basis of the results returned from Quikfold server. The SNP 
status for the sequence can be either "Selected" or "Not selected". 

Sequence View 

The Sequence View displays the nucleotide sequence. The selected sequence can be viewed as 
3/10 bases per block. The sequence can be viewed in either as single stranded or double 
stranded. The designed primers and probes are marked on the sequence .The sense primer is 
marked in blue and the antisense primer is marked in red. The selected SNP position is also 
marked in pink. 

Result Display Tab 

The detailed search results are displayed below the Sequence Information table. The result 
display tabs include Beacon/TaqMan(R)/FRET probes/ SYBR (R) Green primers Properties tab, 
BLAST Information tab and SNP Information tab. 

Beacon Properties Tab 

You can view the beacon and primer properties for a selected sequence under this tab. 

The primer results include both sense and antisense primer rating, primer sequence, position, 
length, melting temperature, GC%, maximum hairpin dG, maximum self dimer dG, repeat and run 
length, optimum annealing temperature, maximum cross-dimer dG, product length and product 
Tm. Apart from this you can also view primer secondary structures by clicking Secondary 
Structures option from pop-up menu available at right click (For Mac, CTRL+click) over the 
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Primer Properties table or by selecting View>Secondary Structures>Primers. You can view the 
alternate primer pairs for the selected sequence by clicking the All Primers button or by selecting 
View>All>Primers. 

The beacon properties include beacon rating, beacon sequence, position, length, beacon Tm, 
probe Tm, alternate hairpin dG, self-dimer dG, cross-dimer dG, and a graphical view of the 
beacon. You can view beacon secondary structures by clicking Secondary Structures option from 
pop-up menu available at right click (For Mac, CTRL+click) over the Beacon Properties table or 
by selecting View > Secondary Structures > Beacon. You can view the alternate beacons for 
the selected sequence by clicking the All Beacons button or by selecting View > Alternate > 
Beacon. 

TaqMan(R) Properties Tab 

You can view the TaqMan
(R)

 and the primers properties for a selected sequence under this 
tab.The primer results include both sense and antisense primer rating, primer sequence, position, 
length, melting temperature, GC%, maximum hairpin dG, maximum self dimer dG, repeat and run 
length, optimum annealing temperature, maximum cross-dimer dG, product length and product 
Tm. You can view primer secondary structures by clicking All Structures option from the pop-up 
menu available at right click (For Mac, CTRL+click) over the Primer Properties table or by 
selecting View > Alternate > Primers. You can view the alternate primer pairs for the selected 
sequence by clicking the All Primers button or by selecting View > Alternate > Primers.  
 
The TaqMan(R) properties include TaqMan(R) probe rating, sequence, position, length, Tm , % GC, 
hairpin dG, self dimer dG, repeat and run length. You can view TaqMan(R) probe secondary 
structures by clicking All Structures option from pop-up menu available at right click over (For 
Macintosh, CTRL+click) the TaqMan(R) Properties table or by selecting View>All 
Structures>TaqMan(R). You can view the alternate TaqMan(R) probes for the selected sequence 
by clicking the All TaqMan(R) button or by selecting View>All>TaqMan(R).  

FRET Probes Properties Tab 

You can view the FRET probes and the primers properties for a selected sequence in this tab. 
The primer results include both sense and antisense primer rating, primer sequence, position, 
length, melting temperature, GC%, maximum hairpin dG, maximum self dimer dG, repeat and run 
length, optimum annealing temperature, maximum cross-dimer dG, product length and product 
Tm. You can view primer secondary structures by clicking the All Structures option from the 
pop-up menu available with a right click (for Mac, CTRL+click) on the Primer Properties table or 
by selecting the menuView > All > Primers. You can view the alternate primer pairs for the 
selected sequence by clicking the All Primers button or by selecting the menu 
View>All>Primers.  

The FRET probes properties include individual FRET probe rating, sequence, position, length, 
Tm , % GC, hairpin dG, self dimer dG, repeat and run length. You can view FRET probes 
secondary structures by clicking All Structures option from the pop-up menu available with a 
right click (for Macintosh, CTRL+click) on the FRET probes Properties table or by selecting the 
menu View>All Structures>FRET probes. You can view the alternate FRET probes for the 
selected sequence by clicking the All FRET probes button or by selecting the menu 
View>All>FRET probes.  

 SYBR (R) Green Primers Properties Tab 

You can view primer properties for a selected sequence in this tab. The primer results include 
sense and antisense primer ratings, primer sequences, positions, lengths, melting temperatures, 
GC%, maximum hairpin dG, maximum self dimer dG, repeat and run lengths, optimum annealing 
temperature, maximum cross-dimer dG, product length and product Tm. You can also view 
primer secondary structures by clicking All Structures button on the Primer Properties table or 
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by selecting the menu View>All>Primers. You can view the alternate primer pairs for the 
selected sequence by clicking the All Primers button or by selecting the menu 
View>All>Primers. 

BLAST Information tab 

The BLAST search information includes Genome and Database details against which BLAST 
search was performed and the Search status of the BLAST search for the sequence, primer-pair 
and amplicon. If there is any error in BLAST search or no significant cross homology is found a 
"Not Found" status is displayed. 

You can view the information about sequences showing significant cross homology with the 
selected sequence by clicking the Cross-Homology button or by selecting View>Cross 
Homology.  

The BLAST results for a sequence against a database can be viewed in the Search Status tab or 
by selecting View>BLAST Details. This will open the BLAST result page in your default browser. 
The same information is available in the BLAST properties tab. The BLAST results for the primer 
pair, the amplicon and the probe can be viewed in the search status in the BLAST properties tab. 

SNP Information tab 

You can view SNP information for the selected sequence in this tab. The SNP information 
includes the SNP base position and the mutant nucleotide for all the SNPs on the sequence. 
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Primer Search Parameters for Standard Real Time PCR 
Search Parameters;  
The Primer Search Parameters window is launched when you select Analyze >Primer  

Search>Standard or click   button from the toolbar. 

In the Beacon Design mode, the primer search parameters are defaulted to design primers 
optimized for beacon applications. In the TaqMan(R) Design mode, the primer search parameters 
are defaulted to design primers optimized for TaqMan(R) applications.  

You can set parameters for primer search in this window and launch a primer search. 

Search parameters:  

Avoid Template Structure: Default value: Checked. Template secondary structures will be 
avoided while designing primers. 

Avoid Cross Homology: Default value: Checked. Interprets BLAST search results for the 
selected sequence to avoid designing primers in the region of cross homology.  

Multiplex: Default value: Checked. Checks for cross-dimers with all primers of selected 
sequences preventing competition in multiplex reactions.  

Range Parameters 

Search Location: Default value: Anywhere. The optimum primers are searched anywhere on the 
sequence or biased towards 5' end or biased towards 3' end of the selected sequence. Search 
Location selection is disabled, when the Avoid Template Structure is checked. 

Search Range: The optimum primers are searched within the user specified search range. The 
search range can be specified as From and To sequence base numbers. Search Range 
selection is restricted to the sequence bases analyzed for template secondary structures, when 
Avoid Template Structure is checked. 

 Tm (oC): Default value = 55 +/- 5 oC Tm and the +/- tolerance. The search engine will find primers 
for all sequences as close as possible to the specified target value of Tm. For example: To specify 
a range of 60 oC to 70oC, enter 65 oC for target Tm and 5 oC for the +/- tolerance. Tm values are 
calculated using nearest neighbor thermodynamic calculation using Santa Lucia values.  

TaOpt (oC): Default value = 55 +/- 5 oC.TaOpt and the +/- tolerance. The search engine will find 
primers for all sequences as close as possible to the specified target value of TaOpt. Formula for 
calculating TaOpt. 

Primer length: Default value = 18 to 22 base pairs, the desired range for the primer length. 

Primer Pair Parameters 

Specify amplicon length: Default value = 100 - 150 base pairs. Target product length range in 
bp. The location of the amplicon will dictate the location of primers as the program tries to design 
primers within the specified location. 

Alternate Primers: Default value = 2. The number of alternate primer pairs designed per 
sequence in a single search.  
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Advanced Search Parameters: 

Hairpin maximum dG 3' End (kcal/mol): Default value = 2 -kcal/mol. The free energy of the 
most stable hairpin that is acceptable at 3' end of the primer. 

Formula for calculating free energy. - dG = dH - T * dS,  

Where dH = enthalpy, T = temperature, dS = entropy. 

Hairpin maximum dG Internal (kcal/mol): Default value = 3 -kcal/mol. The free energy of the 
most stable hairpin that is acceptable in the primer. 

3' End maximum stability dG (kcal/mol): Default = 10 -kcal/mol Primers with a 3' end stability 
greater than the specified value are not considered. Primers with stability greater than 4 and less 
than the specified value are rated lower. 

Self-dimer maximum dG 3' End (kcal/mol): Default value = 5 -kcal/mol. The free energy of the 
most stable self-dimer that is acceptable at 3' end of the primer. 

Self-dimer maximum dG Internal (kcal/mol): Default value = 6 -kcal/mol. The free energy of the 
most stable self-dimer that is acceptable in the primer. 

Run/repeat maximum length: Default value = 4 bp/dinuc. The maximum acceptable length of 
single nucleotide run (e.g. AAAA) or dinucleotide repeats (ATATATAT).  

Run/repeat maximum length: Default value = 2 base pair. Primers with less than the specified 
number of G or C' s at the 3' end will be rated lower. 

Maximum ambiguous bases in the amplicon: Default value = 0. The number of ambiguous 
bases tolerated in the amplicon. 

Maximum primer pair Tm mismatch: Default value = 3. The maximum acceptable difference 
between the Tm values of the two primers.  

Cross-dimer maximum dG 3' End (kcal/mol): Default value = 5 -kcal/mol. The free energy of 
the most stable cross-dimer that is acceptable at 3' end of the primer. 

Cross-dimer maximum dG Internal (kcal/mol): Default value = 6 -kcal/mol. The free energy of 
the most stable cross-dimer that is acceptable in the primer. 

Multiplexing maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable in a multiplex reaction. 
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Primer Search Parameters for NASBA(R) Assay 
 
The Primer Search Parameters window is launched when you select Analyze > Primer Search >  

NASBA or click    button from the toolbar. 

You can set parameters for primer search in this window and launch a primer search. 

Search parameters:  

Avoid Template Structure: Default value: Checked. Template secondary structures will be 
avoided while designing primers. 

Avoid Cross Homology: Default value: Checked. Interprets BLAST search results for the 
selected sequence to avoid designing primers in the region of cross homology.  

Multiplex: Default value: Checked. Checks for cross-dimers with all primers of selected 
sequences preventing competition in multiplex reactions.  

Range Parameters 

Search Location: Default value: Anywhere. The optimum primers are searched anywhere on the 
sequence or biased towards 5' end or biased towards 3' end of the selected sequence. Search 
location selection is disabled, when the Avoid Template Structure is checked. 

Search Range: The optimum primers are searched within the user specified search range. The 
search range can be specified as From and To sequence base numbers. Search Range 
selection is restricted to the sequence bases analyzed for template secondary structures, when 
Avoid Template Structure is checked. 

Target Tm (oC): Default value = 55 +/- 5 oC Target Tm and the +/- tolerance. The search engine 
will find primers for all sequences as close as possible to the specified target value of Tm. For 
example: To specify a range of 60 oC to 70oC, enter 65 oC for target Tm and 5 oC for the +/- 
tolerance. Tm values are calculated using nearest neighbor thermodynamic calculation using 
Santa Lucia values.  

Target TaOpt (oC): Default value = 55 +/- 5 oC. Target TaOpt and the +/- tolerance. The search 
engine will find primers for all sequences as close as possible to the specified target value of 
TaOpt. Formula for calculating TaOpt. 

Primer length: Default value = 20 to 30 base pairs, the desired range for the primer length. 

Primer Pair Parameters 

Specify amplicon length: Default value = 100 - 150 base pairs. Target product length range in 
bp. The location of the amplicon will dictate the location of primers as the program tries to design 
primers within the specified location. 

Alternate primers per sequence: Default value = 2 . The number of alternate primer pairs 
designed per sequence in a single search.  

Advanced Search Parameters: 

Hairpin maximum dG 3' End (kcal/mol): Default value = 2 -kcal/mol. The free energy of the 
most stable hairpin that is acceptable at 3' end of the primer. 

Formula for calculating free energy. - dG = dH - T * dS,  
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Where dH = enthalpy, T = temperature, dS = entropy. 

Hairpin maximum dG Internal (kcal/mol): Default value = 3 -kcal/mol. The free energy of the 
most stable hairpin that is acceptable in the primer. 

3' End maximum stability dG (kcal/mol): Default = 10 -kcal/mol Primers with a 3' end stability 
greater than the specified value are not considered. Primers with stability greater than 4 and less 
than the specified value are rated lower. 

Self-dimer maximum dG 3' End (kcal/mol): Default value = 5 -kcal/mol. The free energy of the 
most stable self-dimer that is acceptable at 3' end of the primer. 

Self-dimer maximum dG Internal (kcal/mol): Default value = 6 -kcal/mol. The free energy of the 
most stable self-dimer that is acceptable in the primer. 

Run/repeat maximum length: Default value = 3 bp/dinuc. The maximum acceptable length of 
single nucleotide run (e.g. AAA) or dinucleotide repeats (ATATAT).  

GC Clamp: Default value = 2 base pair. Primers with less than the specified number of G or C' s 
at the 3' end will be rated lower. 

Maximum ambiguous bases in the amplicon: Default value = 0. The number of ambiguous 
bases tolerated in the amplicon. 

Maximum primer pair Tm mismatch: Default value = 3. The maximum acceptable difference 
between the Tm values of the two primers.  

Cross-dimer maximum dG 3' End (kcal/mol): Default value = 5 -kcal/mol. The free energy of 
the most stable cross-dimer that is acceptable at 3' end of the primer. 

Cross-dimer maximum dG Internal (kcal/mol): Default value = 6 -kcal/mol. The free energy of 
the most stable cross-dimer that is acceptable in the primer. 

Multiplexing maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable in a multiplex reaction. 

Add Purines : Default value =AAA. Stretches of pyrimidine (C or T ) in the first 10-12 nucleotides 
of the P1 primer sequence complementary to the target RNA sequence may cause abortive 
transcription. Therefore in P1 primer Purine bases are added if they contain more than 50 %of 
pyrimides in first 10 -12 nucleotide. 
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Beacon Search Parameters 
Beacon Designer uses the highly accurate mfold algorithm for hairpin Tm calculation. You can set 

the parameters for beacons search by selecting Analyze >Beacon Search or click  from the 
toolbar. 

Beacon Search Parameters: 

Probe length: Default value = 18 to 30 bp. The desired range for the probe length. 

Tm (oC) : Default value = 9 +/- 5 oC . higher than primer pair TaOpt. The search engine will find 
probes for the sequences in the search as close as possible to the specified target value of Tm. 
The probe Tm values are calculated using nearest neighbor thermodynamic calculation using 
Santa Lucia values.  

Beacon Tm (oC): Default value = 9+/-5 oC. higher than primer pair TaOpt. The search engine will 
find beacons for sequences as close as possible to the specified target Tm value. The Tm values 
are calculated using highly accurate hairpin Tm calculation by connecting to the Quikfoldserver. 

Beacon stem sequence: Default value = For five base is CGCGA , for six base is CGCGAT and 
for seven base is CGCGATC. Stems of appropriate length are selected automatically for optimal 
beacon Tm.  

Use Primers Designed In SYBR (R) Green mode: Default: Unchecked. On checking would 
automatically select the best primer pair for the Beacon assay from the primer pair pool (including 
the alternate primers) designed in theSYBR (R)Green mode. 

Note: This feature will be available only if the primers for that sequence were designed in the 
SYBR (R)Green mode. 

E-mail address: Field for entering E-mail address. A valid E-mail address is essential for 
connecting to the Quikfoldserver. 

Output Options: 

Alternate TaqMan(R) Probes: Default = 2. The number of alternate beacons to be designed per 
sequence. You can replace the default probe by selected alternate beacon. 

Design Sense/Antisense beacon: Default = Sense. Defines the sense of the output beacon. 
This option is available for beacon design for allelic discrimination. 

 
Advanced Search Parameters: 

Hairpin maximum dG (kcal/mol): Default value = 3 -kcal/mol. The free energy of the most stable 
alternate hairpin that is acceptable. Formula for calculating free energy. 

Self-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable self-dimer that is acceptable. 

Run/repeat maximum length: Default value = 4 bp/dinuc. Probes with single (e.g. AAAAA) runs 
or dinucleotide (ATATATATAT) repeats of length greater than the specified value are discarded.  

Cross Dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable in a multiplex reaction. 
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TaqMan (R) Probe Search Parameters 

 
The TaqMan(R) Search Parameters window is launched when you select Analyze  

>TaqMan(R) search> Standard or click  button from the toolbar. 

Design parameters:  

Primer Length: Default value = 20 to 24 bp. The desired range for the primer length. 

TaqMan(R) Length: Default value = 20 to 24 bp. The desired range for the TaqMan
(R)

 length. 

Primer Tm (oC): Default value = 59 +/- 2 oC. Target Tm and the +/- tolerance. The search engine 
will find primers as close as possible to the specified target value of Tm. For example: To specify 
the range of 60 oC to 70 oC, enter 65 oC for target Tm and 50 oC for the +/- tolerance. The Tm 
values are calculated using nearest neighbor thermodynamic calculation using Santa Lucia 
values.  

TaqMan(R) Tm (oC): Default value = 10 +/- 2 oC higher than primer Tm . TaqMan Tm and the +/- 
tolerance. The search engine will find TaqMan(R) probes as close as possible to the specified 
target value of Tm. The Tm values are calculated using nearest neighbor thermodynamic 
calculation using Santa Lucia values.  

Specify amplicon length: Default value = 75 - 150. Target product length range in bp. The 
location of the amplicon will dictate the location of primers as the program tries to design primers 
within the specified location. 

Use Primers Designed In SYBR (R)Green mode: Default: Unchecked. On checking would 
automatically select the best primer pair for the TaqMan(R) assay from the primer pair pool 
(including the alternate primers) designed in the SYBR (R)Green mode. 

Note: This feature will be available only if the primers for that sequence were designed in the 
SYBR (R)Green mode. 

Avoid Template Structure: Default value: Checked. Template secondary structures will be 
avoided while designing primers. 

Avoid Cross homology: Default value: Interprets BLAST search results for the selected 
sequence to avoid designing primers in the region of cross homology.  

Sequence Length Range 

Search Range: The optimum TaqMan(R) probes and primers are searched within the user 
specified search range. The search range can be specified and From and To sequence base 
numbers. Search Selelection is restricted to the sequence bases analyzed for template 
secondary structures, when the Avoid Template Structure is checked. 

Output Options: 

Alternate TaqMan (R) Probes: Default value = 2. The number of alternate TaqMan(R) probes 
designed per sequence in a single search. You can replace the default probe by any of the 
selected alternate probe. 

Design Sense/Antisense TaqMan(R) : Default = Sense. Defines the sense of the output 
TaqMan(R). This option is available for TaqMan(R) design for allelic discrimination. 
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Advanced Search Parameters 

Advanced Design parameters: 

Hairpin maximum dG (kcal/mol): Default value = 3 -kcal/mol. The free energy of the most stable 
hairpin that is acceptable in the designed primer and TaqMan(R) probe. 

Formula for calculating free energy. - dG = dH - T * dS,  

Where dH = enthalpy, T = temperature, dS = entropy. 

Self-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable self-dimer that is acceptable in the designed primer and TaqMan(R) probe. 

Run/repeat maximum length: Default value = 4 bp/dinuc. Primers and TaqMan(R) probe with 
single (e.g. AAAAA) runs or dinucleotide (ATATATATAT) repeats of length greater than the 
specified value are discarded.  

Multiplexing maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable in a multiplex reaction. 

Maximum bases between Primer and TaqMan(R): Default value = 10. The maximum 
acceptable distance between primer and probe. According to the standard TaqMan(R) design 
guidelines, it is recommended that the probe be designed within 10 base pairs of the primer that 
anneals to the same strand as the probe, without any overlaps. 

Note: With Beacon Designer, you can relax the limit up to 25bp if required.  

TaqMan(R) must not have more G than C bases: Default value = Checked. It is an empirical 
observation is that probes with more G than C bases will often produce reduced normalized 
fluorescence values.  

Advance Primer Parameters: 

Run/repeat maximum length: Default value =2 bp. Primers with less than the specified number 
of G or C's at the 3' end will be rated lower. 

3' End maximum stability dG (kcal/mol): Default = 10 -kcal/mol Primers with a 3' end stability 
greater than the specified value are not considered. Primers with stability greater than 4 and less 
than the specified value are rated lower. 

Advance Primer Pair Parameters: 

Maximum ambiguous bases in the amplicon: Default value = 0. The number of ambiguous 
bases tolerated in the amplicon. 

Maximum primer pair Tm mismatch: Default value = 2. The acceptable maximum difference 
between the Tm of the two primers. 

Cross-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable. 
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Multiplex Search Parameters for Taqman® Assay  

  

Multiplex Taqman Search parameter window is launched when you select  

Analyze> Multiplex TaqMan >Standard or click   button from tool bar. 
You can set parameters for Multiplex Taqman Search in this window and can launch the Multiplex 
Taqman search.  
Multiplex Set Name: This field will let you select the name for multiplex set. Each set will have 
maximum of 4 sequences and minimum of 2 sequences. 
 
Primer Parameters 
Primer Search parameters: 
Avoid Template structure: Default value: Checked. Template secondary structures will be 
avoided while designing primers. 
Avoid Cross homology: Default value:Checked. Interprets BLAST search results for the 
selected sequence to avoid designing primers in the region of cross homology.  
Note: If SNP is selected on any of the sequences in a multiplexed group, then Avoid Cross 
Homology and Avoid Template structure will be disabled. 
Design Parameters  
Primer Length: Default value = 20 to 24 bp. The desired range for the primer length.  
Tm (oC): Default value = 59 +/- 2 oC. Primer Tm and the +/- tolerance. The search engine will find 
primers as close as possible to the specified target value of Tm. For example: To specify the 
range of 60 oC to 70 oC, enter 65 oC for PrimerTm and 50 oC for the +/- tolerance. The Tm values 
are calculated using nearest neighbor thermodynamic calculation using Santa Lucia values.  
Amplicon length: Default value = 100 - 150. Target product length range in bp.  
Note: For the successful multiplex reactions, you need to keep your amplicon PCR effciency at 
same level otherwise quantification of your amplicons cannot be compared. 
Sequence Length Range/ Reference Gene Selection:  
Length Range: The optimum TaqMan® probes and primers are searched within the user 
specified search range. The search range can be specified and From and To sequence base 
numbers. Search Range selection is restricted to the sequence bases analyzed for template 
secondary structures, when the Avoid Template Structure is checked. 
Reference Gene Selection: Default value: unchecked. You can perform multiplex Taqman 
design for reference gene multiplexing. For reference gene multiplexing it is necessary to select 
at least one sequence as a reference gene. Selected reference gene should have pre-designed 
primer and probes. 
a) When Avoid Template Structure is unchecked: For selected reference gene, amplicon 
length will be displayed in “Search range” column and Tm of Primer pair and probe for selected 
reference gene will be displayed in Primer Tm and Probe Tm column. 
 
b) When Avoid Template Structure is checked: Initially “Search Range” selection is restricted 
to the sequence bases analyzed for template secondary structures. But when you select a 
reference gene amplicon length will be displayed in Search range column and Tm of Primer and 
probe for selected reference gene will be displayed in Primer Tm and Probe Tm column 
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Reaction conditions  
Note: Reaction conditions used for all reference gene must be identical and will be used for 
multiplex search. 
Limit for selecting the sequence as a reference gene:3 
TaqMan Parameters:  

Probe Length: Default value = 20 to 24 bp. The desired range for the LNA(TM)™ substituted 
TaqMan® length. 

Probe Tm (oC): Default value = 10 +/- 2 oC higher than primer Tm. Probe Tm and the +/- 
tolerance. The search engine will find TaqMan® probes as close as possible to the specified 
target value of Tm. The Tm values are calculated using nearest neighbor thermodynamic 
calculation using Santa Lucia values.  

 
Advanced Design parameters 

Hairpin maximum dG (kcal/mol): Default value = 3 -kcal/mol. The free energy of the most 
stable hairpin that is acceptable in the designed primer and TaqMan® probe. 
Formula for calculating free energy. - dG = dH - T * dS,  
Where dH = enthalpy, T = temperature, dS = entropy. 
Self-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable self-dimer that is acceptable in the designed primer and TaqMan® probe. 
Run/repeat maximum length: Default value = 4 bp/dinuc. Primers and TaqMan® probe with 
single (e.g. AAAAA) runs or dinucleotide (ATATATATAT) repeats of length greater than the 
specified value are discarded.  
Multiplexing maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable in a multiplex reaction. 
Maximum bases between Primer and TaqMan®: Default value = 10. The maximum acceptable 
distance between primer and probe. According to the standard TaqMan® design guidelines, it is 
recommended that the probe be designed within 10 base pairs of the primer that anneals to the 
same strand as the probe, without any overlaps. 
Note: With Beacon Designer, you can relax the limit up to 250 bp if required.  
TaqMan® must not have more G than C bases: Default value = Checked. It is an empirical 
observation is that probes with more G than C bases will often produce reduced normalized 
fluorescence values.  
Advanced Primer Parameters:  
Run/repeat maximum length: Default value =2 bp. Primers with less than the specified number 
of G or C's at the 3' end will be rated lower. 
3' End maximum stability dG (kcal/mol): Default = 10 -kcal/mol Primers with a 3' end stability 
greater than the specified value are not considered. Primers with stability greater than 4 and less 
than the specified value are rated lower. 
G/C Clamp : Consecutives G/C's at 3' end: Default value = 2. GC clamp length at 3' end is the 
number of consecutive G or C permitted at the 3' terminus the primers. 
Advanced Primer Pair Parameters: 
Maximum ambiguous bases in the amplicon: Default value = 0. The number of ambiguous 
bases tolerated in the amplicon. 
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Maximum primer pair Tm mismatch: Default value = 2. The acceptable maximum difference 
between the Tm of the two primers. 
Multiplexing Maximum primer pairs Tm mismatch: Default value = 3. The acceptable 
maximum difference between the Tm of the two primers between two different sequences. 
Cross-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable. 
Output Options: 
Alternate Multiplex Set: Default value = 2. The number of alternate TaqMan® probes designed 
per sequence in a single search. You can replace the default probe by any of the selected 
alternate probe. 
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LNA(TM) Substituted TaqMan (R) Probe Search Parameters 

 
The LNA(TM) substituted TaqMan (R) search parameters window is launched when  

you select Analyze >TaqMan (R) search>LNA(TM). When you click     button from the 
toolbar the TaqMan search window launched will have "Standard" selected and to perform 
LNA(TM) substituted TaqMan search select "LNA(TM)". As a result parameters for the LNA(TM) 
substituted TaqMan design will be enabled under TaqMan parameters tab. 

Primer Parameters:  
 
Avoid Template Structure: Default value: Checked. Template secondary structures will be 
avoided while designing primers. 

Avoid Cross homology: Default value: Interprets BLAST search results for the selected 
sequence to avoid designing primers in the region of cross homology.  
 
Primer Length: Default value = 20 to 24 bp. The desired range for the primer length.  
 
Primer Tm (oC): Default value = 59 +/- 2 oC. Primer Tm and the +/- tolerance. The search 
engine will find primers as close as possible to the specified target value of Tm. For example: To 
specify the range of 60 oC to 70 oC, enter 65 oC for PrimerTm and 50 oC for the +/- tolerance. 
The Tm values are calculated using nearest neighbor thermodynamic calculation using Santa 
Lucia values.  

Amplicon length: Default value = 75 - 150. Target product length range in bp. The location of 
the amplicon will dictate the location of primers as the program tries to design primers within the 
specified location.  
 
Sequence Length Range:  

Search Range: The optimum TaqMan(R)probes and primers are searched within the user 
specified search range. The search range can be specified and From and To sequence base 
numbers. Search Range selection is restricted to the sequence bases analyzed for template 
secondary structures, when the Avoid Template Structure is checked. 

TaqMan Parameters:  
 
Use Primers Designed In SYBR Green mode: Default: Unchecked. On checking would 
automatically select the best primer pair for the TaqMan(R) assay from the primer pair pool 
(including the alternate primers) designed in the SYBR Green mode.  
 
Note: This feature will be available only if the primers for that sequence were designed in the 
SYBR Green mode. 

TaqMan(R) Length: Default value = 15 to 18 bp. The desired range for the LNA(TM) substituted 
TaqMan(R) length. 

TaqMan(R) Tm (oC): Default value = 10 +/- 2 oC higher than primer Tm. Target Tm and the +/- 
tolerance. The search engine will find TaqMan(R)probes as close as possible to the specified 
target value of Tm. The Tm values are calculated using nearest neighbor thermodynamic 
calculation using Santa Lucia values.  

Note: During allele discrimination assay design the default value of Target TaqMan(R) Tm (oC) is 
7 +/- 2 oC higher than primer Tm.  
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LNA(TM) substituted design: These parameters are enabled when "LNA(TM)" is selected and 
disabled when “Standard” is selected. 

Number of LNA(TM) bases: Default value: 4. Number of LNA(TM) bases to be included in the 
TaqMan(R) probes can be specified. Minimum number of LNA(TM) which can be added is 1 and 
Maximum is 10. 

LNA(TM) free region on end: Default value: 2. LNA(TM) free region on each end refer to the 
number of base which should be ignored from 5' and 3' bases before incorporating LNA(TM) in 
TaqMan probe. This is required to substitute the LNA(TM) in the central regions of the probes, as 
LNA(TM) substituted at the 3' ends may lead to mispriming which is not acceptable.  
 
LNA(TM) base every : Default value : 3. LNA(TM) base every lets you to decide, which base 
should be replaced with LNA(TM) base in oligo. A value of 3 will replace every third nucleotide 
with an LNA(TM) analog. Minimum value is 2 and maximum is 10.  
 
Note:  
 
a. Beacon Designer will start substituting the DNA bases to LNA(TM) bases based on the 
LNA(TM) free region on each end value. For Example : If LNA(TM) phase off is 4 then, 4 bases 
will be left from 5' and 3' end and 5 bases will be LNA(TM) from 5' end. Then, based on LNA(TM) 
base every and Number of LNA(TM) other bases will be substituted by LNA(TM).  
 
b. When LNA(TM) substituted TaqMan is designed for allele discrimination assay, then SNP is 
always centralized in the probes and is LNA(TM). Then based on the number of LNA(TM) and 
LNA(TM) base every the DNA bases on either side of the SNP, LNA(TM) will be substituted and 
one having the higher Tm will be given priority. 

Advanced Option  

Output Options: 

Alternate TaqMan(R )Probe: Default value = 2. The number of alternate LNA(TM) substituted 
TaqMan(R) probes designed per sequence in a single search. You can replace the default probe 
by any of the selected alternate probe. 

Design Sense/Antisense TaqMan(R): Default = Sense. Defines the sense of the output 
TaqMan(R). This option is available for TaqMan(R) design for allelic discrimination. 
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Multiplex Search Parameters for LNA(TM) substituted Taqman(R) Assay 

  
Multiplex Taqman Search parameter window is launched when you select  

Analyze> Multiplex TaqMan> LNA(TM) or click    button from tool bar. 

 
You can set parameters for Multiplex Taqman Search in this window and can launch the Multiplex 
Taqman search.  
 
Multiplex Set Name: This field will let you select a name for your multiplexed group. 
 
Primer Parameters 
Primer Search parameters: 
 
Avoid Template structure: Default value: Checked. Template secondary structures will be 
avoided while designing primers.  
Avoid Cross homology: Default value: Checked. Interprets BLAST search results for the 
selected sequence to avoid designing primers in the region of cross homology. 
 
Note: If SNP is selected for any of the sequence in a multiplexed group then “Avoid Template 
structure” and “Avoid Cross homology” will be disabled. 
 
Primer Design Parameters: 
Primer Length: Default value = 20 to 24 bp. The desired range for the primer length.  
Tm (oC): Default value = 59 +/- 2 oC. Primer Tm and the +/- tolerance. The search engine will find 
primers as close as possible to the specified target value of Tm. For example: To specify the 
range of 60 oC to 70oC, enter 65 oC for PrimerTm and 50 oC for the +/- tolerance. The Tm values 
are calculated using nearest neighbor thermodynamic calculation using Santa Lucia values.  
Amplicon length: Default value = 100 - 150. Target product length range in bp. For the 
successful multiplexing individual reactions should have similar effciency hence your amplicon 
length should be identical otherwise quantification of your amplicon cannot be compared. 
Sequence Length Range/ Reference Gene Selection:  
Length Range: The optimum TaqMan® probes and primers are searched within the user 
specified search range. The search range can be specified From and To sequence base 
numbers. Search Range selection is restricted to the sequence bases analyzed for template 
secondary structures, when the Avoid Template Structure is checked. 
Reference Gene Selection: Default value: unchecked. You can perform multiplex Taqman 
design for reference gene multiplexing. For reference gene multiplexing it is necessary to select 
at least one sequence as a reference gene. Selected reference gene should have pre-designed 
primers and probes.  
a) When Avoid Template Structure is unchecked: For selected reference gene, amplicon 
length will be displayed in “Search range” column and Tm of Primer pair and probe for selected 
reference gene will be displayed in Primer Tm and Probe Tm column. 
b) When Avoid Template Structure is checked: Initially Search Range selection is restricted to 
the sequence bases analyzed for template secondary structures. But when you select a reference 
gene amplicon length will be displayed in “Search range” and will be non editable and Tm of 
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Primer and probe for selected reference gene will be displayed in Primer Tm and Probe Tm 
column. 
Reaction conditions:  
Note: Reaction conditions used for all reference genes must be identical and will be used for 
multiplex search. 
Limit for selecting the sequence as a reference gene: 3  
Taqman Parameters 

Probe Length: Default value = 20 to 24 bp. The desired range for the LNA(TM) substituted 
TaqMan® length. 

Probe Tm (oC): Default value = 10 +/- 2 oC higher than primer Tm. Probe Tm and the +/- 
tolerance. The search engine will find TaqMan® probes as close as possible to the specified 
target value of Tm. The Tm values are calculated using nearest neighbor thermodynamic 
calculation using Santa Lucia values.  

Note: During allele discrimination assay design the default value of Probe Tm ( oC) is 7 +/- 2 oC 
higher than primer Tm.  

Number of LNA(TM) bases: Default value: 4. Number of LNA(TM) bases to be included in the 
TaqMan® probes can be specified. Minimum number of LNA(TM) which can be added is 1 and 
Maximum is 10. 

LNA(TM) free region on each end: Default value : 2.LNA(TM) free region on each end refer to 
the number of base which should be ignored from 5' and 3' bases before incorporating LNA(TM) 
in TaqMan® probe. For Example: If LNA(TM) free base on each end is 2 then, 4 bases will be left 
from 5' and 3' end. Then, based on LNA(TM) base every base and number of LNA(TM), DNA 
bases will be substituted by LNA(TM). This is required to substitute the LNA(TM) in the central 
regions of the probes, as LNA(TM) substituted at the 3' ends may lead to mispriming which is not 
acceptable.  

LNA(TM) base every: Default value: 3. LNA(TM) base every lets you to decide, which base 
should be replaced with LNA(TM) base in oligo. A value of 3 will replace every third nucleotide 
with an LNA(TM) analog. Minimum value is 2 and maximum is 10. Note: a. For allele 
discrimination studies, the probe always includes the mutant base at its center. In LNA(TM) spiked 
probes, a single LNA(TM) base is introduced at the mutation site. 

 
Advanced Design parameters 

Hairpin maximum dG (kcal/mol): Default value = 3 -kcal/mol. The free energy of the most 
stable hairpin that is acceptable in the designed primer and TaqMan® probe. 
Formula for calculating free energy. - dG = dH - T * dS,  
Where dH = enthalpy, T = temperature, dS = entropy. 
Self-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable self-dimer that is acceptable in the designed primer and TaqMan® probe. 
Run/repeat maximum length: Default value = 4 bp/dinuc. Primers and TaqMan® probe with 
single (e.g. AAAAA) runs or dinucleotide (ATATATATAT) repeats of length greater than the 
specified value are discarded. 
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Multiplexing maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable in a multiplex reaction. 
Maximum bases between Primer and TaqMan®: Default value = 10. The maximum acceptable 
distance between primer and probe. According to the standard TaqMan® design guidelines, it is 
recommended that the probe be designed within 10 base pairs of the primer that anneals to the 
same strand as the probe, without any overlaps. 
Note: With Beacon Designer, you can relax the limit up to 250 bp if required.  
TaqMan® must not have more G than C bases: Default value = Checked. It is an empirical 
observation is that probes with more G than C bases will often produce reduced normalized 
fluorescence values.  
Advanced Primer Parameters: 
Run/repeat maximum length: Default value =2 bp. Primers with less than the specified number 
of G or C's at the 3' end will be rated lower. 
3' End maximum stability dG (kcal/mol): Default = 10 -kcal/mol Primers with a 3' end stability 
greater than the specified value are not considered. Primers with stability greater than 4 and less 
than the specified value are rated lower. 
G/C Clamp : Consecutives G/C's at 3' end: Default value = 2. GC clamp length at 3' end is the 
number of consecutive G or C permitted at the 3' terminus the primers. 
 
Advanced Primer Pair Parameters: 
Maximum ambiguous bases in the amplicon: Default value = 0. The number of ambiguous 
bases tolerated in the amplicon. 
Maximum primer pair Tm mismatch: Default value = 2. The acceptable maximum difference 
between the Tm of the two primers of same sequence. 
Multiplexing Maximum primer pairs Tm mismatch: Default value = 3. The acceptable 
maximum difference between the Tm between primer pair of two different sequences. 
Cross-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable. 
 
Output Options: 
Alternate Multiplex Set: Default value = 2. The number of alternate TaqMan® probes designed 
per sequence in a single search. You can replace the default probe by any of the selected 
alternate probe. 
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FRET Probes Search Parameters 

 
The FRET Probes Search Parameters window is launched when you select  

Analyze >FRET Probes search menu or click the  button from the toolbar. 

Design parameters:  

Primer Length: Default values = 18 to 22 bp. The desired range for the primer length. 

FRET Probes Length: Default values = 25 to 35 bp. The desired range for the FRET Probes 
length. 

Distance between Probes: Default = 1 to 5 bases. The desired distance between the 3' end of 
the first probe (donor probe) from the 5' end of the second probe (acceptor probe).  

Primer Tm (oC): Default value = 55 +/- 5 oC. TPrimer Tm and the +/- tolerance. The search 
engine will find primers as close as possible to the specified target value of Tm. For example: To 
specify the range of 60 oC to 70 oC, enter 65 oC for Primer Tm and 50 oC for the +/- tolerance. 
The Tm values are calculated using nearest neighbor thermodynamic calculation using Santa 
Lucia values.  

FRET Probes Tm (oC): Default value = 8 +/- 3 oC higher than primer Tm . Target Tm and the +/- 
tolerance. The search engine will find FRET Probes as close as possible to the specified target 
value of Tm. The Tm values are calculated using nearest neighbor thermodynamic calculation 
using Santa Lucia values.  

Specify amplicon length: Default value = 100 - 250. Target product length range in bp. This 
parameter dictates the primer positions relative to each other, assuring that the distance between 
the 5' end of the upstream primer to the 3' end of the downstream primer is within the specified 
value. 

Use Primers Designed In SYBR (R)Green mode: Default: Unchecked. On checking would 
automatically select the best primer pair for the FRET Probes assay from the primer pair pool 
(including the alternate primers) designed in the SYBR (R)Green mode. 

Note: This feature will be available only if the primers for that sequence were designed in the 
SYBR (R) Green mode. 

Avoid Template Structure: Default value: Checked. Significant template secondary structures 
which may hinder the primers from annealing are identified and avoided when designing primers. 

Avoid Cross homology: Default value: Checked. Interprets BLAST search results for the 
selected sequence to avoid designing primers in the region of cross homology.  

Sequence Length Range 

Search Range: The optimum FRET Probes and primers are searched within the user specified 
search range. The search range can be specified as From and To sequence base numbers. 
Search Range selection is restricted to the sequence bases analyzed for template secondary 
structures, when the Avoid Template Structure is checked. 

Output Options: 

Alternate Probes: Default value = 2. The number of alternate FRET Probes designed per 
sequence in a single search. You can replace the default probe by any of the alternate probe. 
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Design Sense/Antisense FRET Probes: Default = Sense. Defines the sense of the output 
FRET Probes.  

Advanced Search Parameters 

Advanced Probe parameters: 

Hairpin maximum dG (kcal/mol): Default value = 3 -kcal/mol. The free energy of the most 
stable hairpin that is acceptable in the designed primer and FRET Probes probe. 

Formula for calculating free energy. - dG = dH - T * dS,  

Where dH = enthalpy, T = temperature, dS = entropy. 

Self-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable self-dimer that is acceptable in the designed primer and FRET Probes probe. 

Run/repeat maximum length: Default value = 4 bp/dinuc. Primers and FRET Probes probe with 
single (e.g. AAAAA) runs or dinucleotide (ATATATATAT) repeats of length greater than the 
specified value are discarded. 

Maximum bases between Primer and FRET Probes: Default value = 10. The maximum 
acceptable distance between primer and probe. According to the standard FRET Probes design 
guidelines, it is recommended that the probe should be designed as close as possible to the 
primer on the same strand without overlapping the primer.  

FRET Probes must not have more G than C bases: Default value = Checked. It has been 
empirically observed that probes with more G's than C's will often produce reduced normalized 
fluorescence values.  

Advanced Primer Parameters: 

Run/repeat maximum length: Default value = 2 bp. Primers with less than the specified number 
of G's or C's at the 3' end will be rated lower. 

3' End maximum stability dG (kcal/mol): Default = 10 -kcal/mol Primers with a 3' end stability 
greater than the specified value are not considered. Primers with stability greater than 4 and less 
than the specified value are rated lower. 

Advanced Primer Pair Parameters: 

Maximum ambiguous bases in the amplicon: Default value = 0. The number of ambiguous 
bases tolerated in the amplicon. 

Maximum primer pair Tm mismatch: Default value = 2. The acceptable maximum difference 
between the Tm of the two primers. 

Cross-dimer maximum dG (kcal/mol): Default value = 6 -kcal/mol. The free energy of the most 
stable cross-dimer that is acceptable. 
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SYBR (R) Green Primer Search Parameters 
SYBR Primer Green Primer Search Parameters;  
The Primer Search Parameters window is launched when you select Analyze  

>Primer Search or click  button from the toolbar. 

You can set parameters for primer search in this window and launch a primer search. 

Search parameters:  

Avoid Template Structure: Default value: Checked. Significant template secondary structures 
which may hinder the primers from annealing are identified and avoided when designing primers. 

Avoid Cross Homology: Default value: Checked. Interprets BLAST search results for the 
selected sequence to avoid designing primers in the regions of significant cross homologies.  

Range Parameters 

Search Location: Default value: Anywhere. The optimum primers are searched anywhere on the 
sequence or biased towards the 5' or the 3' end of the selected sequence. Search location 
selection is disabled, when the Avoid Template Structure is checked. 

Search Range: The optimum primers are searched within the user specified search range. The 
search range can be specified as From and To sequence base numbers. Search Range selection 
is restricted to the sequence bases analyzed for template secondary structures, when Avoid 
Template Structure is checked. 

Tm (oC): Default value = 55 +/- 5 oC Primer Tm and the +/- tolerance. The search engine will find 
primers for all sequences as close as possible to the specified value of primer Tm. For example: 
To specify a range of 60 oC to 70oC, enter 65 oC for primer Tm and 5 oC for the +/- tolerance. 
The Tm values are calculated using nearest neighbor thermodynamic calculation using Santa 
Lucia values.  

TaOpt (oC): Default value = 55 +/- 5 oC. TaOpt and the +/- tolerance. The search engine will find 
primers for all sequences as close as possible to the specified value of TaOpt. Formula for 
calculating TaOpt. 

Primer length: Default value = 18 to 22 base pairs, the desired range for the primer length. 

Primer Pair Parameters 

Specify amplicon length: Default value = 100 - 150 base pairs. Target product length range in 
bp. This parameter dictates the primer positions relative to each other, assuring that the distance 
between the 5' end of the upstream primer to the 3' end of the downstream primer is within the 
specified value. 

Alternate primers: Default value = 2 . The number of alternate primer pairs designed per 
sequence in a single search.  

Advanced Search Parameters: 

Hairpin maximum dG 3' End (kcal/mol): Default value = 2 -kcal/mol. The free energy of the 
most stable hairpin that is acceptable at 3' end of the primer. 

Formula for calculating free energy. - dG = dH - T * dS,  

Where dH = enthalpy, T = temperature, dS = entropy. 
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Hairpin maximum dG Internal (kcal/mol): Default value = 3 -kcal/mol. The free energy of the 
most stable hairpin that is acceptable in the primer. 

3' End maximum stability dG (kcal/mol): Default = 10 -kcal/mol Primers with a 3' end stability 
greater than the specified value are not considered. Primers with stability greater than 4 and less 
than the specified value are rated lower. 

Self-dimer maximum dG 3' End (kcal/mol): Default value = 5 -kcal/mol. The free energy of the 
most stable self-dimer that is acceptable at the 3' end of the primer. 

Self-dimer maximum dG Internal (kcal/mol: Default value = 6 -kcal/mol. The free energy of the 
most stable self-dimer that is acceptable in the primer. 

Run/repeat maximum length: Default value = 4 bp/dinuc. The maximum acceptable length of 
single nucleotide run (e.g. AAAA) or dinucleotide repeats (ATATATAT).  

Run/repeat maximum length: Default value = 2 base pair. Primers with less than the specified 
number of G's or C' s at the 3' end will be rated lower. 

Maximum ambiguous bases in the amplicon: Default value = 0. The number of ambiguous 
bases tolerated in the amplicon. 

Maximum primer pair Tm mismatch: Default value = 3 0C. The maximum acceptable difference 
between the Tm values of the two primers.  

Cross-dimer maximum dG 3' End (kcal/mol): Default value = 5 -kcal/mol. The free energy of 
the most stable cross-dimer that is acceptable at the 3' end of the primer. 

Cross-dimer maximum dG Internal (kcal/mol): Default value = 6 -kcal/mol. The free energy of 
the most stable cross-dimer that is acceptable in the primer. 
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BLAST Search Parameters 
Parameters;  
Beacon Designer supports BLAST search against all the genomic databases available at NCBI. 
Local customized databases can also be searched using the Standalone WWW BLAST service 
from NCBI. 

In Beacon Designer BLAST is available for Complete Sequence, amplicon, primer pairs. The 
selected sequence is BLAST searched against any of the selected genomic database, the results 
are interpreted to designing primers avoiding cross homology. The cross homology in the thus 
designed primer pair/amplicon can be verified by BLASTing the primer pair/amplicon sequence 
against the same genomic database. 

You can set parameters for BLAST search for selected sequences in the BLAST Search 
Parameter window. To launch the BLAST search parameters window  

selectAnalyze>BLAST Search or click  from the toolbar. 

To launch theBLAST Search parameters window for Primer pair/Amplicon 
selectAnalyze>BLAST Search>Primer-pair/Amplicon/Probe. 

The following parameters are available for BLAST search:  
 
Search Type 

Human Genome BLAST: Search your query sequence against the genome (all assemblies), 
genome (reference only), Ref RNA (Default), Build RNA or Ab initio RNA databases at NCBI.  
http://www.ncbi.nlm.nih.gov/genome/seq/page.cgi?F=HsBlast.html&&ORG=Hs 

Microbial Genome: Search your query sequence against the DNA databases (Default) of all the 
completed genomes at NCBI. Various organisms are listed inSearch options >Genomes under 
two basic categories:Archaeal genome andBacterial genome.  
http://www.ncbi.nlm.nih.gov/sutils/genom_table.cgi?  

Eukaryotic BLAST: Search your query sequence against the genome databases (Default) 
available under Vertebrates, Plants, Fungi, Insects, Protozoa, Nematodes and other eukaryotes.  
 
Vertebrates  

Mouse Genome: Search your query sequence against the genome (all assemblies), genome 
(reference only), Ref RNA (Default), Build RNA or Ab initio RNA databases ofmouse available at 
NCBI.  
http://www.ncbi.nlm.nih.gov/genome/seq/MmBlast.html  
 
Cat Genome BLAST: Search your sequence against RefSeq 
RNA.http://www.ncbi.nlm.nih.gov/genome/seq/FcaBlast.html 

Chicken Genome: Search your query sequence against the genome (all assemblies), genome 
(reference only), Ref RNA (Default), Build RNA or Ab initio RNA databases ofcjicken available at 
NCBI.  
http://www.ncbi.nlm.nih.gov/genome/seq/GgaBlast.html  
 
Chimpanzee Genome BLAST : Search your query sequence against the genome (all 
assemblies), Genome (reference only), RNA*(RefSeq, Ab Initio, build).  
http://www.ncbi.nlm.nih.gov/genome/seq/PtrBlast.html  
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Cow Genome BLAST : Search your query sequence against the Genome (all assemblies), 
Genome (reference only), RNA*(RefSeq, Ab Initio, build).  
http://www.ncbi.nlm.nih.gov/genome/seq/BtaBlast.html  
 
Dog Genome BLAST: Search your query sequence against the Genome (reference 
only),RNA*(RefSeq, Ab Initio, build).  
http://www.ncbi.nlm.nih.gov/genome/seq/CfaBlast.html 

PigGenome BLAST:Search your query sequence against the RefSeq (RNA).  
http://www.ncbi.nlm.nih.gov/genome/seq/SscBlast.html  
 
Rat Genome: Search your query sequence against the genomic sequence, Ref RNA (Default), 
Build RNA or Ab initio RNA databases ofrat available at 
NCBI.http://www.ncbi.nlm.nih.gov/genome/seq/RnBlast.html 

Sheep Genome BLAST : Search your query sequence against the RefSeq RNA  
http://www.ncbi.nlm.nih.gov/genome/seq/OarBlast.html 

Zebrafish Genome: Search your query sequence against the mRNAs or Reference mRNAs 
(Default) ofZebra fish available at NCBI.  
http://www.ncbi.nlm.nih.gov/genome/seq/DrBlast.html 

Puffer fish: Search your query sequence against the Genomic Sequence (Default) of Puffer fish 
available at NCBI. 
http://www.ncbi.nlm.nih.gov/blast/Genome/fugu.html 

 
Plants : Search your query sequence against DNA and mRNA (Default) database of all the 
completed genomes at NCBI. http://www.ncbi.nlm.nih.gov/BLAST/Genome/PlantBlast.shtml?10 

Fungi: Search your query sequence against the DNA (Default) of databaseof all the completed 
genomes at NCBI: 
 http://www.ncbi.nlm.nih.gov/sutils/genom_table.cgi?organism=fungi 

Protozoa: Search your query sequence against the DNA (Default) of databaseof all the 
completed genomes at NCBI: 
http://www.ncbi.nlm.nih.gov/sutils/blast_table.cgi?taxid=Protozoa 

Insects: Search your query sequence against the Genomic sequence (Default) ofall the 
completed genomes at NCBI: 
http://www.ncbi.nlm.nih.gov/sutils/genom_table.cgi?organism=insects 

Nematodes:Search your query sequence against the DNA (Default) of all the completed 
genomes at NCBI:http://www.ncbi.nlm.nih.gov/BLAST/Genome/NematodeBlast.html 
 
Other Eukaryotes: Search your query sequence against the Genomic sequence (Default) of all 
the completed genomes at 
NCBI:http://www.ncbi.nlm.nih.gov/sutils/genom_tree.cgi?organism=euk  
 
 
nr BLAST: (Available for complete sequence/ Primer Pair / Amplicon / Probe BLAST Search) 

Search your query sequence against the chosen current nucleic acid database. Select from 
among organism-specific, inclusive, or specialized set databases: 

nr: All GenBank+RefSeq Nucleotides+EMBL+DDBJ+PDB sequences (but no EST, STS, GSS, or 
phase 0, 1 or 2 HTGS sequences). No longer "non-redundant". 
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est: Database of GenBank+EMBL+DDBJ sequences from EST Divisions. 

est_human: Human subset of GenBank+EMBL+DDBJ sequences from EST Divisions. 

est_mouse: Mouse subset of GenBank+EMBL+DDBJ sequences from EST Divisions. 

est_others: Non-Mouse, non-Human sequences of GenBank+EMBL+DDBJ sequences from 
EST Divisions. 

gss: Genome Survey Sequence, includes single-pass genomic data, exon-trapped sequences, 
and Alu PCR sequences. 

htgs: Unfinished High Throughput Genomic Sequences: phases 0, 1 and 2 (finished, phase 3 
HTG sequences are in nr) 

pat: Nucleotides from the Patent division of GenBank. 

pdb: Sequences derived from the 3-dimensional structure from Brookhaven Protein Data Bank. 

month: All new or revised GenBank+EMBL+DDBJ+PDB sequences released in the last 30 days. 

alu-repeats: Select Alu repeats from REPBASE, suitable for masking Alu repeats from query 
sequences. ftp://ftp.ncbi.nih.gov/pub/jmc/alu/ 

dbsts: Database of GenBank+EMBL+DDBJ sequences from STS Divisions . 

chromosome: Searches Complete Genomes, Complete Chromosome, or contigs form the NCBI 
Reference Sequence project.. 

Local BLAST: Search any customized database set on your local server using the Standalone 
WWW BLAST service. 

Server name / IP address: Host name of the server or IP address of the machine on which the 
Standalone WWW BLAST service is installed (Linux / Mac). This address will be used to connect 
the client (Beacon Designer) to the server for local BLAST search.  
 
Genomes:Select the local database category as of Human, Microbes or Others  
 
Human: All the databases which belong to human.  
 
Microbes: All the databases which belong to microbes.  
 
Others: All the databases which belong to organisms other than human and microbes.  
 
Search Options: 

Program: Default = blastn. Standard Nucleotide-Nucleotide BLAST search. 

Database: Displays the list of available database for each search type. The databases are same 
as mentioned in search type above. 

To verify database to be used, follow this link : 
http://www.ncbi.nlm.nih.gov/genome/seq/Database.html 

Desktop BLAST: Desktop BLAST can BLAST search sequences against local custom 
databases without the need of setting up a local BLAST server. For Desktop BLAST search, you 
must have sequence files either .txt or .fa stored locally on your computer. You need to 
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guide Beacon Designer to the directory which contains .fa or .txt sequences and then BLAST 
search sequence against the sequences. 

Note: There is a limitation with the Mac OS X version of Java you cann't click on a directory to 
select it. "For Desktop BLAST", you need to guide Beacon Designer to .fa or .txt sequences 
instead of directory. When you select a single .txt or .fa sequences automatically all the 
sequences contained in that directory will be available for BLAST.  

Database location: Specify the location to locate the directory having the sequence files against 
which you need to perform the desktop BLAST 

Genomes: Select the local database category as of Human, Microbes or Others  
 
Human: All the databases which belong to human.  
 
Microbes: All the databases which belong to microbes.  
 
Others: All the databases which belong to organisms other than human and microbes. 

Note: For Desktop BLAST and the local database there is an editable text field for Expect Value, 
for which the minimum value is 0.0001 and maximum value is 1000. 

Advanced Options  

Limit by Entrez Query :( Available only for theStandard BLAST type in the Primer Pair / 
Amplicon / Probe BLAST Search)  
BLAST searches can be limited to the results of an Entrez query against the database chosen. 
This can be used to limit searches to subsets of the BLAST databases. Any terms can be entered 
that would normally be allowed in an Entrez search session. To limit to a specific organism you 
can either select using the pulldown menu, form a list of the most common organism in the 
databases. Or enter the name of the organism in the Entrez Query field with the [Organism] 
qualifier. Default = (none) 

Filter: Default = unchecked  
The Filter in the program is similar to the Choose Filter option in the Options for advanced 
blasting at NCBI BLAST. The Filter, by default, is unchecked and is only applied to the query 
sequence (or its translation products) and not to database sequences. This is because checking 
the filter will mask off segments of the query sequence that have low compositional complexity, 
as determined by SEG program and Human repeats (LINE's and SINE's) and consequently they 
will not be reported in the BLAST output. The program will then search these regions for 
designing primers and probes, which is undesirable.  

When the Filter is unchecked, the entire query sequence will be BLAST'ed against the selected 
database. As the database contains regions of Low-complexity and/or Human repeats, they will 
be reported in the BLAST output as homologies and the program will avoid these regions when 
locating primers and probes.  

Note: It is not unusual for nothing at all to be masked, so filtering should not be expected to 
always yield an effect.  

Expect: Default = 10, 0.01 for Primer Pair /Amplicon /Probe BLAST.  
The Expect value is the statistical significance threshold for reporting matches against database 
sequences; the default value is 10, meaning that 10 matches are expected to be found merely by 
chance, according to the stochastic model of Karlin and Altschul (1990). If the statistical 
significance ascribed to a match is greater than the EXPECT threshold, the match will not be 
reported. The lower EXPECT thresholds are more stringent. Fractional values are acceptable.  
The Expect value can be used as a convenient way to create a significance threshold for 
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reporting results. The E value describes the random background noise that exists for the matches 
between sequences. The Expect value (E) decreases exponentially with the Score (S) that is 
assigned to a match between two sequences. When the Expect value is set at 10, a larger list 
with more low-scoring hits can be reported. Similarly a lower Expect value can be set to avoid 
reporting of low scoring hits.  
 
Program Advanced Options  
-G Cost to open a gap [Integer] 

default = 5 

-E Cost to extend a gap [Integer] 

default = 2 

-q Penalty for a mismatch [Integer] 

default = -3 

-r reward for nucleotide match [Integer] 

default = 1 

-e Expectation value [Real] 

default = 10 

-W wordsize [Integer] 

default = 11 

-v Number of one-line descriptions [Integer] 

default = 100 

-b Number of alignments to show [Integer] 

default = 100 

Format Options  
 
NCBI-gi: Default = Checked  
Results in NCBI gi identifiers to be shown in the output, in addition to the accession and/or locus 
name.  
Descriptions: Default = 100, and 50 for Primer-pair / Amplicon /Probe BLAST Search.  
Restricts the number of short descriptions of matching sequences reported to the number 
specified.  
Alignments: Default = 100,and 50 for Primer-pair / Amplicon /Probe BLAST Search.  
Restricts database sequences to the number specified for which high-scoring segment pairs 
(HSPs) are reported. The default limit is100. If more database sequences than this happen to 
satisfy the statistical significance threshold for reporting (see EXPECT above), only the matches 
ascribed the greatest statistical significance are reported. 
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Template Structures Search 
Significant template secondary structure may hinder the primers from annealing and prevent 
complete product extension by the polymerase. Template secondary structures search can be 
performed on the sequence to avoid designing primers in the regions which form stable 
secondary structures at the PCR extension temperature. The possible secondary structures in the 
template are obtained from the Quikfoldserver. 

The Template Structures dialog is launched when you select Analyze  

>Template Structures Search or click  button from the toolbar. 

You can view the secondary structures for the selected sequence by selecting View >Template 
Structure Details. 

Search Parameters 

Sequence Range: Default value: 1- 1200 bp. The length of the sequence which is submitted to 
the Quikfold server for finding the secondary structures at the PCR extension temperatures. 
Maximum 1200 bp can be submitted for folding to Quikfoldserver.  

Folding Temperature : Default value : 55 oC. The tempearature at which sequence is submitted 
at Mfold for finding the secondary structures is settable. 

E-mail address: Field for entering E-mail address. A valid E-mail address is essential for 
connecting to the Quikfoldserver. 

The Sequence is folded at the PCR reaction conditions for most optimum folding results. 
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View Cross Homology 

 
Beacon Designer avoids cross homologies, repeats and low complexity regions while designing 
primers. It interprets BLAST search results to determine relevant cross homologies for the 
selected sequence.  
You can view the relevant cross homologies in the Cross Homology window by selecting 
View>Cross Homology or clicking Cross Homology Button from the Blast Information tab. 

The window has five columns:  
1. Check box: Checking or un-checking will select or unselect the sequences for avoiding cross 
homology while designing primers. By default all the checkboxes remain checked to ensure the 
relevant cross homologies for the sequence could be avoided.  
2. Accession number: The accession numbers of the sequences showing cross homology. This 
unique identifier can be used to access the sequence(s) and associated information from the 
database. Clicking the accession number opens the database records for the corresponding 
sequence in your default browser.  
3. Description: Description of the sequences showing cross homology.  
4. E-Value: Number of hits expected with similar or better score. It depicts the significance of 
match. E-value = 0 indicates complete homology.  
5. From - To: The region of the query sequence homologous with the database sequences is 
shown as the start and the end base number. 

The Cross Homology window launched for Microbial BLAST displays:  
1. Description: Description of the sequence showing cross homology.  
2. Alignment: Portion of the query showing alignment with the subject sequence.  
  

The Description table has four columns: 

a. Check box: Selecting a description will allow you to select or unselect alignments ranges 
(from-to) in the Alignment table for avoiding cross homology. Unselecting a description will not 
avoid the description and it's alignments as relevant cross homology, while designing primers. 
Un-checking the sequence in the Description table, automatically un-checks all the sequences 
ranges (from-to) in the Alignment table.  
b. Reference: Displays the accession numbers of sequences showing cross homology. This 
unique identifier can be used to access specific sequences and associated information from the 
database. Clicking the accession number opens the database records for the corresponding 
sequence in default browser.  
c. Description: Description of the sequences showing cross homology.  
d. E-Value: Number of hits expected with similar or better score. It depicts the significance of 
match.  

The Alignment table has three columns: 

a. Check box: Selecting an alignment (from-to) will avoid only the selected alignment as relevant 
cross homology while designing primers. The sequence copy in database is unchecked by 
default. By default, all other checkboxes remain checked to ensure the relevant cross homologies 
for the sequence are avoided.  
b. From - To: The region of the query sequence homologous with the database sequence is 
represented in terms of the start and the end base number.  
c. E-Value: It depicts the statistical significance of member of the set reported.  
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View Secondary Structures 

 
The graphical view of the primer, beacon, FRET and TaqMan

(R)
 secondary structures is displayed 

in the Secondary Structures window. You can view the primer secondary structures by clicking 
All Structures option from pop-up menu available at right click (For Mac, CTRL+click) over the 
Primer Properties table or by selecting View > Alternate > Primers. In the SYBR (R)Green mode 

view the primer secondary structures by clicking the  button on the Primer 
Properties tab. 

You can view the beacon secondary structures by clicking All Structures option from pop-up 
menu available at right click (For Mac, CTRL+click) over the Beacon Properties table or by 
selecting View > All Structures > Beacons. Similarly to view the TaqMan(R) and FRET 
secondary structures clickAll Structures option from pop-up menu available at right click (For 
Mac, CTRL+click) over the TaqMan(R)Properties and FRET Properties table respectively or select 
View > All Structures > TaqMan(R) / FRET.  

The Secondary Structures window displays the graphical view of all the possible structures for 
dimers, hairpins, cross-dimers, repeats and runs for the selected primer or probe.  
The dG values for each structure and its position as internal or 3' end is also shown. The sense 
structures are displayed in blue while the antisense structures are displayed in red. 
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Multiplex Results 

 
With Beacon Designer you can multiplex primers or primers-beacons, TaqMan(R) - TaqMan(R) 

TaqMan(R) - primers or between the two FRET Probes and primers for each of the selected 
sequences. The multiplex results are displayed in the Multiplex Results window. 

The window has four columns:  
1. Accession number: Displays the accession numbers of multiplexed sequences.  
2. Type: Displays the type of oligonucleotide being multiplexed.  
3. Graphical view: Displays the graphical view of the most stable cross dimer formed between 
the multiplexed oligonucleotides. The sense sequence is displayed in blue and the antisense in 
red.  
4. Most stable cross-dimer dG (kcal/mol): Displays the free energy of the most stable cross-
dimer formed between two primers and primers-beacons or TaqMan(R) - TaqMan(R) and 
TaqMan(R) - primer or between the two FRET Probes and primers sequences of the selected 
sequence. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Designer;  
 
Project;  
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Tutorial 
 
Create and Manage a Project 
Beacon Designer enables you to organize your work by creating separate Projects. 

You can create any number of projects using Beacon Designer. But only one project can be 
opened at a time. You can delete an existing project from Finder by deleting the project folder and 
the .bdp file. You can design beacons and TaqMan® in the same project by switching the design 
mode. 

Create a New Project 

You can start working with Beacon Designer by creating a new project. 

To create a new project: 

1. Choose File> New>Project or click  button from the toolbar. Enter the project name. 

2. By default a project is created in the BD Projects folder. You can browse in the Save File dialog 
and create a project at any other location on your local drive. 

 

Open Project 
To open an existing project:  

1. Choose File > Open > Project or click  from the toolbar. Browse and select the .bdp file of 
the project you want to open and click Open. 

2. You can also open the project by selecting a project displayed in the history list at the bottom of 
the file menu. Beacon Designer displays four most recent projects in the history list. 

3. An open project is automatically closed when you open another project. 

Note: To transfer a previously created project from original location to a new folder or to another 
drive or even to another machine, copy both the project.bdp file and the project folder and paste 
at the new destination. 
 

 

 

 

 

 

 



 Beacon Designer 5.10 Tutorial 
 

 46

Close Project 

To close a project: 

1. Choose File>Close Project.  

2. Choose File>Open>Sequence>From Entrez. This will close the project and exit the program.  
 

Save Project As 
You can save number of projects but only one can be opened at a time.  
To save a project 
1) Select File>Save Project As. 
2) Enter the project name. 
3) Select the location where you want to save the project. 
4) Beacon Designer will save the project at specified location. 
 

Save Sequence As 
You can save existing sequence as a new sequence in a project: 
To save the sequence 
1) Open the project.  
2) Select the sequence to be saved.  
3) Select File> Save Sequence As. 
4) Save Sequence As dialog will be launched. 
5) Specify the name. 
6) Selected sequence will be saved with specified name within the project.  
Note: Sequence will be saved with specified name, only feature information of the sequence will 
be copied.  
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Open Sequence 
Sequences can be opened directly from Entrez, dbSNP or from files saved on your local drive. 

Open Sequence from Entrez 

Beacon Designer provides online access to Entrez. Sequences can be directly retrieved from 
Entrez using this web integration feature.  

1. Choose File>Open>Sequence>From Entrez or click  button from the toolbar. Enter the 
accession/ GI number. 

2. You can open multiple sequences at a time. To open multiple sequences, type or paste the list 
of accession/ GI numbers separated by comma, tab or new line. 

For example you can type the following accession numbers: AJ300450, Y13051, AB036365 in 
the open sequence window and click OK. The accession or GI numbers can be separated by 
commas or tabs, or entered one number per line. The downloaded sequences will appear in the 
Sequence Information table. 

Open Sequence from dbSNP 
Beacon Designer provides online access to dbSNP. Sequences can be directly retrieved from 
dbSNP using this web integration feature and opened in the current project. 

1. Choose File>Open>Sequence>From dbSNP or click  button from the toolbar. Enter the 
Assay ID. 

2. You can open multiple sequences at a time. To open multiple sequences, type or paste the list 
of Assay ID separated by comma, tab or new line. 

Open Sequence from File 

To open a sequence from a file saved on the local drive: 

1. Choose File>Open>Sequence>From File or click  button from the toolbar. In the file open 
dialog, browse and select the sequence file you want to open and click Open. You can open 
multiple sequences by selecting multiple files using Shift / Ctrl and click Open. 

Open a different format sequence:  

Beacon Designer supports sequences in GenBank and FASTA formats. To open a sequence of 
another format first convert it to FASTA format as follows:  
Copy the sequence in a text file and type a greater than sign (>) followed by a single line 
comment before the first base. 

For example: 

Once a sequence is opened in the program it is automatically saved in the application database 
and it will remain in the program until it is explicitly deleted. The sequence in the program is 
displayed in the Sequence Information table in the main window. You can view the complete 
sequence in your default browser by selecting View>Sequence Details.  
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Add Text Sequence 
You can add a text sequence or a sequence from any other application not in supported format 
by using this option. 

1. Choose File>New>Sequence or click  button from the toolbar. 

 2. In the New Sequence window type a single line definition for the sequence in the Sequence 
Definition text field. 

3. Now Type or paste the sequence bases in Sequence window and click Add.  

You can import sequence from any other application by cutting and pasting the sequence bases 
in the Sequence window. You can also edit the sequence manually by typing the sequence in the 
editor.  

Note: In demo mode, the program does not allow you to open a sequence from your local drive 
or Entrez.  
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Load Multiple SNP 

 
In Beacon Designer you can load hundreds of SNPs for designing probes for multiplex detection. 
SNP's can be defined as Variation feature in GenBank file format.  
You can open multiple sequences from Entrez containing SNP information in the following format: 

 

Variation 1256 

  /replace="t" 

Where Variation feature represent SNP information, 1256 is SNP position as base number, and 
"t" represents the mutant base.  
Beacon Designer will automatically identify the variation feature in this format as SNP information 
and display it under the SNP Information Tab. 

You can edit the GenBank sequences to add or modify the variation feature to match the 
supported format.  
To edit a sequence:  
1. Download the sequence from Entrez. Select Online > Entrez Home to launch the Entrez 
home page in the default browser.  
2. Save the searched sequence on the local drive.  
3. Open the sequence in a text editor such as Notepad and edit it to add SNP information as 
variation feature in the supported format explained above.  
4. Save the modified file and open it in the project using Open Sequence from File option. You 
can open multiple sequences by selecting multiple files using Shift / Ctrl and clicking Open or by 
selecting the sequence file containing the multiple sequences. 

Load Unpublished SNP information 

You can even design beacon or TaqMan(R) for unpublished SNPs from your own local SNP 
database. You can load such non-GenBank SNP locations by first converting the sequence 
information into a GenBank like format with SNP information as Variation features. To convert the 
format, copy the sequence in a text file and add mandatory fields to it, as shown in the template. 
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Sample SNP information file  

 
Please refer the template to incorporate the SNP information in the non-GenBank sequences. 

 

. 
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Search Sequence 
Search Sequence;  
Sequences can be searched by their Accession number or Sequence Definition.  

1) To search a sequence choose Edit > Find or click the  button from toolbar. 

2) Select the Search Criteria and type in either an accession number or Sequence Definition 
keyword in the corresponding field. 

3) The search can be made case-sensitive by checking the Match Case option. 

Note: When searching by accession number complete accession number or the initial character 
of the accession number can be used. 

For example:  

1. Select Accession Number under Search Criteria, Type L22214 in the corresponding field and 
click Find.  

2. The corresponding sequence gets highlighted. In case only the partial accession number is 
known (L22), type the first few characters or numbers. 

3. The Find function displays all the accession numbers starting with L22, choose the appropriate 
and click Find.  

4. Similarly, a search can be conducted using a keyword that appears in the sequence definition.  

5. In case of L22214, the definition contains word "Adenosine".  

6. Select Definition under Search Criteria, key-in "Adenosine" the corresponding field and click 
Find. 

7. Sequence definition in the Search window, will display search results for all the sequences that 
include the word "Adenosine" in their sequence definition. 
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Avoid Cross Homology 
Primers can be designed avoiding regions of cross homology. Beacon Designer will BLAST your 
sequences, automatically interpret the results and will then design highly specific primers. Both 
primers and amplicons can be BLAST searched using genomic database available at NCBI or 
local customized database using the Standalone WWW BLAST server. Primers will already have 
been designed to avoid cross homology. This will allow visualizing primer specificity. 

Set Parameters for BLAST Search 

To BLAST search a Sequence: 

1. Select a sequence in the Sequence Information table .  

2. Select menu Analyze > BLAST Search > Sequence or click  button from the toolbar.  
3. In the BLAST Search Sequence window, set parameters for BLAST Search and click Search.  
4. As soon as the search is complete, the BLAST results are interpreted to identify the sequences 
showing cross homology.  
5. You can view the cross homology results by clicking the Cross Homology button in the 
BLAST Information tab .  
6. You can view BLAST result details in your default browser by selecting View>BLAST Details.  

The time required to return the results for a sequence varies dramatically, depending on the load 
on NCBI servers and the speed of your internet connection, from just a few seconds to several 
minutes per search. If a sequence is BLASTed for a second time, the new results replace the 
previous results. Thus Beacon Designer always displays the most recent BLAST results. 

Example: 

To BLAST search the sequence for avoiding cross homology: 

1. Select sequences L22214 in the Sequence Information table. 

2. Select Analyze> BLAST Search> Sequence from the menu or click from the toolbar. 

3. In the BLAST Search Sequence window, all the parameters are set to default. i.e. Search 
Type: Human genome BLAST, Genomes: Human Database: Ref RNA, Expect value is 10, 
Filter unchecked. 

4. Launch search by clicking the Search button. 

5. As soon as the search is complete, the BLAST search results are interpreted to identify the 
sequences exhibiting cross homology. 

6. You can view the cross homology results by clicking the Cross Homology button in the BLAST 
Information tab. 

7. For sequence NM_026658, choose Search Type: Eukaryotic Genome BLAST, Genomes: 
Mouse, Database: Ref RNA, Expect value 10, Filter unchecked. 

8. For sequence ECs0219, choose Search Type: Microbial genome BLAST, Genomes: 
Bacterial Genome: Escherichia coli O157:H7, Database: DNA, Expect value 10, Filter 
unchecked. 
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Set Parameters for Local BLAST Search  

1. Select menu Analyze> BLAST Search> Sequence or click button from the toolbar.  
2. In the BLAST search window, select Search Type as Local Database BLAST.  
3. Enter Server Name/ IP Address.  
4. Click Genomes.  
5. Select the local database category as of Human, Microbes or Other Genome and click OK.  
6. Select the Database for BLAST search from the dropdown menu.  
7. Click Search. As soon as the search is complete, the BLAST results are interpreted to identify 
the sequences showing cross homology.  
8. You can view the cross homology results by clicking the Cross Homology button in the 
BLAST properties tab.  
9. You can view the BLAST result details in your default browser by selecting menu 
View>BLAST Details.   

Note: The default parameters for BLAST search are optimized to report all the relevant cross 
homologies for the query sequence. We recommend not changing these default values. 

Set Parameters for Desktop BLAST Search 

Desktop BLAST can BLAST search sequences against local custom databases without the need 
of setting up a local BLAST server. For Desktop BLAST search, you must have sequence files 
either .txt or .fa stored locally on your computer. You need to guide Beacon Designer to the 
directory which contains .fa or .txt sequences and then BLAST search sequence against the 
sequences. 

The following instructions show how Array Designer can perform Desktop BLAST. 

1) Select Analyze > BLAST Search > Sequence or click the  button on the toolbar. 
2) In the BLAST search window, select Deskop BLAST search. 
3) Click on the Browse button to locate the directory having the sequence files.  
4) Click Genomes. 
5) Select the database category as of Human, Microbes or Others Genome and click OK.  
6) Select the Database for BLAST search from the drop down menu.  
7) Click Search. As soon as the search is complete, the BLAST results are interpreted to identify 
the sequences showing cross homology.  

8) You can view the homology results by clicking the  button on the toolbar. 
9) You can view the BLAST result details in your default browser by selecting menu View > 
BLAST Details.  

Note: For Desktop BLAST and the local database there is an editable text field for Expect Value, 
for which the minimum value is 0.0001 and maximum value is 1000. 

For BLAST, the search parameters are defaulted as:  

Filter: Unchecked. The program automatically avoids low complexity and sequence repeats. If 
the filter named 'Default' is checked, the query sequence will be masked and the cross homology 
for the regions will not be reported, leading to a design in low complexity or repeat regions.  

Expect = 10. It is the statistical significance threshold for reporting matches against database 
sequences. If the statistical significance ascribed to a match is greater than the EXPECT 
threshold, the match will not be reported. Lower EXPECT thresholds are more stringent, leading 
to fewer chance matches being reported. Increasing the threshold shows less stringent matches. 
In order to avoid cross homology, it is essential to select less stringent EXPECT thresholds for 
which all relevant matches are reported.  
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To BLAST Search the Primer-pair / Amplicon / Probe 

1. Select sequence in the Sequence Information table. 

2. Select menu Analyze > BLAST Search > Primer-pair / Amplicon / Probe. 

3. The Genome and database fields for BLAST search are consistent with the genome and 
database fields chosen while BLAST searching the sequence. Set other parameters for BLAST 
search and launch search. 

4. The search results are displayed in BLAST Information tab in the main window. 

5. You can view BLAST Primer-pair/Amplicon/Probe result details in your default browser by 
clicking on "Completed" in the Search Status column in the BLAST Information tab in the Main 
Window or by selecting menu View>BLAST Details > Primer-pair / Amplicon / Probe. 
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Interpreting Human BLAST Results 
Cross  
Human Ref RNA database is available for BLAST search at NCBI. It consists of ref-sequence 
records. The query sequences submitted for BLAST search will show complete homology with 
either the database copy of the mRNA sequence or its modeled transcript or with both, depending 
on the differences in two sequences.  
The database sequences showing cross homology with the query sequence are displayed in the 
Avoid Cross Homology window. In this window, all the relevant cross homologies are checked. 
The program considers the checked sequences for avoiding cross homology. You can uncheck a 
sequence if you think it is not a relevant cross homology.  

1. Select sequence L22214 in the Sequence Information table. BLAST the sequence against Ref 
RNA database of Human.  
2. Select View>Cross Homology from the menu or click the Cross-Homology button in the 
BLAST Information Tab.  
3. In the cross homology results for the sequence L22214, the first sequence shows complete 
homology with the query sequence. These hits have E-Value of 0.0.  
4. The sequences having E-Value of 0.0 remain unchecked by default. The program will not 
consider these sequences as relevant cross homologies as these are the splice variants or 
mRNA of the query sequence itself, present in the database .  
5. For example: for sequence L22214, the first sequence having E-value 0.0 is NM_000674.1,  
6. The sequence NM_000674.1 is the Homo sapiens adenosine A1 receptor (ADORA1) mRNA, 
which is the same as the query sequence.  
7. If you select this sequence for avoiding cross homology by checking the checkboxes opposite 
it, the primer search will fail to design any primers because the entire sequence will be deemed 
cross homologous.  
8. The sequences showing relevant cross homology are NM_000675.3 and NM_000677.2 which 
are mRNA for Homo sapiens adenosine A2a receptor (ADORA2A) and adenosine A3 receptor 
(ADORA3).  
9. These sequences are checked by default. The program will not design probes in the region 
where these sequences show homology with the query.  
10. The sequence L22214 shows cross homology with NM_000675.3 from bases 1134 to 1192 
and 945 to 969, with NM_000677.2 from bases 689 to 740 and 820 to 852. The program will not 
design any primers in these regions.  
11. You can save the selection by clicking the OK button and proceed with primer design. 
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Interpreting Microbial BLAST Results 

 
When the complete genome of an organism is represented in a single accession number, then 
BLASTing a sequence against such a database will result in a single description The copy of the 
query sequence in the database and all other relevant cross homologies are reported in that 
single hit. To avoid relevant cross homologies, which are reported as different alignments, 
microbial BLAST results are interpreted differently.  
The database sequences showing cross homology with the query sequence are displayed in the 
Avoid Cross Homology window. In this window, all the relevant cross homologies are checked. 
The program considers the checked sequences for avoiding cross homology. You can uncheck a 
sequence if you think it is not a relevant cross homology.  

1. Select the sequence ECs0219 in the Sequence Information table.  
2. Select View>Cross Homology from the menu or click the Cross-Homology button in the 
BLAST Information Tab.  
3. In the cross homology results for the sequence ECs0219, the alignment which shows 100% 
homology with the query sequence, remains unchecked by default. The program will consider this 
alignment as the database copy of the query sequence. For example: for the sequence ECs0219, 
the alignment showing complete homology is from 1 to 189 bases.  
4 If you select this alignment for avoiding homology, the program will fail to design any primers 
because the entire sequence will be deemed as cross homologous.  
5. Rest of the alignments from 88 to 102, 142 to 155, 83 to 96, 119 to 132, 151 to 164 and 176 to 
189 bases show cross homology with the query sequence.  
6. By default these alignments are checked. The program will not design primers in the region 
where these alignments show homology with the query sequence.  
7. You can save the selection by clicking the OK button and proceed with primer design. 

 

 

 

 

 

 

 

 

 

 

 

 



 Beacon Designer 5.10 Tutorial 
 

 57

Interpreting Cross Homology Results 
 Homology Results;  
The database sequences showing cross homology with the query sequence are displayed in the 
Avoid Cross Homology window. In this window, all the relevant cross homologies are checked. 
The program considers the checked sequences for avoiding cross homology. You can uncheck a 
sequence if it is not a relevant cross homology. 

1. Select the sequence NM_026658 in the Sequence Information table.  
2. Select View >Cross Homology from the menu or click the Cross-Homologybutton in the 
BLAST Information Tab.  
3. In the cross homology results for NM_026658, the first sequence shows complete homology 
with the query sequence. The hit has an E-Value of 0.0. This encodes for Mus musculus 
mitochondrial translation optimization 1 homolog (S.cerevisiae) (Mto1), mRNA.  
4. This sequence remains unchecked by default. The program will not consider this sequence as 
a relevant cross homology as it is the database copy of the query sequence.  
5. For example: For sequence NM_026658, the first sequence that shows 100% homology is 
NM_026658.1  
6. If you select this sequence for avoiding homology with, the program will fail to design any 
primers because the entire sequence will be deemed as cross homologous.  
7. The sequences showing relevant cross homology are NM_009483.1, NM_153106.1, 
NM_138721.1 which are Mus musculus ubiquitously transcribed tetratricopeptide repeat gene, X 
chromosome (Utx), mRNA; Mus musculus peptidyl arginine deiminase, egg and embryo 
abundant (Padi5), mRNA; and Mus musculus U7 snRNP-specific Sm-like protein LSM10 
(Lsm10), mRNA.  
8. By default these sequences are checked. The program will not design primers in the regions 
where these sequences show homology with the query sequence.  
9. You can save the selection by clicking OK and proceed with primer design. 
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Avoid Template Structures 
 
A successful real-time PCR reaction requires efficient amplification of the product. Both primers 
and target sequence affect this efficiency. Significant template secondary structure may prevent 
the primers from annealing and therefore prevents complete product extension by the 
polymerase.  

While designing primers please note the following points: 

1. Avoid designing primers in the region of template secondary structures, as at annealing 
temperature these regions will not be available for primer- template hybridization. (The kinetics 
always favors the intramolecular template secondary structure over the desired template-primer 
annealing). 

2. Avoid designing primers in the internal hairpin loop regions. 

3. Avoid designing primers flanking template secondary structures. 

4. Avoid designing primers immediately upstream of a secondary structure, the farther the primer 
is from a secondary structure, the better. 

Set Parameters for Template Secondary Structure Search 

To search a sequence for Template Secondary Structures: 

1. Select a sequence in the Sequence Information table.  

2. Select menu Analyze > Template Structure Search or click button from the toolbar.  
3. In the Template Structure Search window, set the parameters for Template Search and click 
Search.  
4. As soon as the search is complete, the Template Search results are interpreted to identify 
regions of stable secondary structures.  
5. You can view the Template Search results in your default browser by selecting View 
>Template Structure Details.  

The time required to return the results for a sequence varies dramatically, depending on the load 
on Quikfold server and the speed of your internet connection, from just a few seconds to several 
minutes per search. If a sequence is Template Searched for a second time, the new results 
replace the previous results. Thus, Beacon Designer always displays the most recent Template 
Structure Search results. Up to 1200 bp at a time can be submitted for folding to the 
Quikfoldserver. Also, a valid e-mail address is essential for connecting to the Quikfold server.  

Example:  

To search a sequence for Template Secondary Structures: 
1. Select sequences AJ300450 in the Sequence Information table.  

2. Select Analyze > Template Structure Search from the menu or click  from the toolbar.  
3. In the Template Structure Search window, set Sequence Range as 1000 to 2100. Rest of the 
parameters are set at their default values.  
4. Enter a valid e-mail Address.  
4. Launch search by clicking the Search button.  
5. As soon as the search is complete, the Template Structure search results are interpreted to 
identify regions of stable secondary structures.  
6. You can view Template Search results in your default browser by selecting View >Template 
Structure Details.  
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Beacon Design  
Design;  

Parameters for Primer Design 
Beacon for a sequence can be designed only after a primer pair has been designed. You can 
either design primers for a sequence using the software or evaluate pre-designed primer pairs. In 
Beacon Designer you can automatically design primers for multiplex reactions. The primers 
designed on multiple sequences in a single search with multiplex option selected are 
automatically checked for cross-dimer formation with the primer pairs of other sequences chosen, 
preventing competition in multiplex reactions. In Beacon Designer a maximum of five sequences 
can be multiplexed for Beacon assays.  
 
You can also check the beacons and primers designed in different search for multiplexing 

compatibility by using Multiplex Primer   . In order to design primers first set the parameters 
for primer design. 
Set Parameters for Primer Design: 

To design primers for selected sequence(s) in Beacon Designer:  
1. Open the sequence(s) in the current project.  

2. Select the sequence(s) and choose Analyze >Primer Search or click   button from the 
toolbar.  

3. Set the primer search parameters to meet your research needs. You can reset the parameters 
to default values by clicking Default. The default values of most of the range parameters are set 
loosely to ensure that the search succeeds in finding the best possible primer pair. The search 
algorithm uses the target values or the middle of the range (except for the product length and the 
primer length) to search for the best primers. If the range specified is narrow, no primers meeting 
the specifications may result. We recommend using default values for primer search. 

4. By default the Avoid Cross Homology option is checked. In this case the primers will be 
designed avoiding homologous regions. Similarly the Avoid Template Structure option is 
checked and by default, significant template secondary structures which may hinder the primers 
from annealing are identified and avoided. 

To design primers at these default values, the sequence(s) should already be BLASTed and a 
template search done. You may choose to skip these steps and design primers without avoiding 
cross-homology and/or template secondary structures. Simply uncheck these options in the 
Primer Search Window before launching a search. 

5. When multiple sequences are selected for a multiplex reaction, the primers in the pool will be 
checked for cross dimers and the primers best suited for multiplex reaction will be displayed. 

6. If the sequence(s) contain SNP information, the primers will be designed to amplify the SNP. 

7. Click Search to launch a search. 

8. Primer search parameters are saved for future searches.  

For example: 

1. Select sequence AJ300450 in the Sequence Information table.  
2. In order to design primers avoiding template secondary structures, the sequence should be 
evaluated for presence of stable secondary structures by folding it at Quikfold.  

3. To launch Template Structures dialog select Analyze> Template Structures or click  



 Beacon Designer 5.10 Tutorial 
 

 60

from the toolbar.  
4. Set template Search Range as from 1000 to 2100, for folding Human immunodeficiency virus 
type 1 Gag core protein Gene sequence for which primers are to be designed.  
5. BLAST search the sequence against a suitable database by selecting Analyze> BLAST 
Search > Sequence.  
7. Similarly select sequence Y13051 in the Sequence Information table.  
8. Analyze the sequence for presence of template secondary structures using Analyze> 
Template Structures. Set the Search Range as from 2339 to 3520 bp to fold Human T-cell 
lymphotropic virus type 2 reverse transcriptase 'pol' gene.  
9. BLAST search the sequence against suitable a database by selecting Analyze> BLAST 
Search > Sequence.  
10. Now proceed to design primers for the sequences, select Analyze >Primer Search or 

click  from the toolbar.  
11. Set the Primer Search Parameters to their default values.  
12. The Search Range for sequence AJ300450 is restricted to, 1 to 1200 bp, spanning Human 
immunodeficiency virus type 1 Gag core protein Gene and that of Y13051 is restricted to 2339 to 
3520bp spanning Human T-cell lymphotropic virus type 2 reverse transcriptase 'pol' gene.  
13. Avoid Template Structure, Avoid Cross Homology, and Multiplex options are checked.  
14. Click Search to launch a search.  
15. As soon as the primer search is complete, the properties of the designed primer are displayed 
in the Primer Properties table under the Beacon Properties tab with both, the individual and 
primer pair rating. The primer rating is given to quantify the merit of primer with reference to the 
search parameters. A primer rating of 100 indicates that the primer exactly matches the specified 
search parameters. 
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Primer Search Results 
Primer;  
As soon as the primer search is complete the search quality status is displayed in the Search 
Status Tab and the detailed result is displayed in the Primer properties table under Beacon 
Properties tab. 

1. The displayed result include both the sense and antisense primer rating, primer sequence, 
position, length, melting temperature, GC%, maximum hairpin dG, maximum self dimer dG, 
repeat and run length, optimum annealing temperature, maximum cross dimer dG, product 
length, product Tm.  
2. You can view all possible primer secondary structures in  
View Secondary Structures window.  
3. In the Sequence View, both sense and antisense primer positions are marked on the 
sequence.  
4. You can copy the primer sequence to the clipboard. Select Edit > Copy > Primer Sequence 
or select Copy Primer Sequence option from pop-up menu available at right click (For Mac, 
CTRL+click) over the primer sequence.  

Example: 

1. The primer search result for sequence AJ300450 displays sense and antisense primers along 
with the free energy values for secondary structures and product properties. The designed primer 
pair amplifies the Gag core protein gene of HIV-1 viral isolate.  
2. Similarly, the primer search result for sequence Y13051 displays sense and antisense primers 
along with the free energy values for secondary structures and product properties. The designed 
primer pair amplifies Human T-cell lymphotropic virus type 2 reverse transcriptase 'pol' gene.  
3. You can view the graphical view of all the primer secondary structures in Secondary Structures 
window by clicking Primer All Structures option from pop-up menu available at right click (For 
Mac, CTRL+click) over the Primer Properties table or by selecting View > Alternate > Primers. 

You can replace the default primer pair with an alternate primer pair to meet your research needs. 

1. Properties of the alternate primers are displayed in the All Primers window. Select any primer 
pair.  
2. Click the Replace button.  
3. The selected primer pair will replace the default primer pair in the Primer Properties table.  

Select alternate primer: 

After designing primer you can replace the default primers by selecting any other primer pair from 
the All Primers window.  

1. To view alternate beacons click  button.  
 
2. The window displays the alternate primers. The window displays both the default primer 
displayed under Primer Properties Tab and alternate primers. The primer which is displayed 
under Primer Properties tab will be highlighted in All Primer window.  
 
2. Select any primer pair in this window, it will be highlighted. 

3. Click the Replace button.  
 
Note: If Primer selected is not compatible with the Beacons displayed then a message ""  
 
4. The selected beacon replaces the default primer pair in the Primer Properties tab and now will 



 Beacon Designer 5.10 Tutorial 
 

 62

be highlighted with grey color in All Primers window. The primer sequence and properties can be 
printed and saved outside the program by using Export Beacon Results. 

Sort Primers: 

In All Primers window there will be facility to sort sense primer, antisense primer and product on 
the basis of rating, position, length, Tm , GC%, Hairpin Delta G value and Self dimer delta G 
values. Sorting is not available on sequence and S.No. 

Note: Whenever All Primers window will be launched primers are always sorted on the basis of 
Product rating. 
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Evaluate Primers 

Evaluate Primers 
In Beacon Designer, you can add pre-designed primers instead of designing primers using the 
program. This is useful when you already have primers in your lab or are working with published 
primer sequences.  
To add and evaluate a primer pair for a sequence:  
1. Select the sequence in the Sequence Information table.  
 

2. Select Analyze > Evaluate Primers or click  (In the SYBR(R) Green Primers Design mode 

click ) button from the toolbar, to launch the Evaluate Primers window.  
3. Type or paste the primer sequences in the given text field. The primers should always be 
added in the 5' to 3' direction.  
4. Beacon Designer analyzes and rates the added primers. The primers are analyzed using 
existing primer search parameters from the Primer Search Parameters window. 

For example:  
1. Select the sequence AB036365.  
2. Add the following primer sequences:  
Sense Primer: 5' TGTCTGCATGTACCTCTACC 3'.  
Antisense Primer: 5' AGTTCTTCTATTCGCTTGTAGG 3'.  
Beacon Designer analyzes and rates these primers using existing primer search parameters, 
which are currently set as default. The primer properties are displayed in Primer properties table.  
3. To verify the specificity of the evaluated primer pair, you can BLAST search the primer pair 
against the relevant database using Analyze>BLAST Search>Primer Pair/Amplicon.  
4. Detailed BLAST search results are displayed in the default browser. 
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Multiplex Results 
;  
In Beacon Designer you can design beacons and primers for multiplex reactions. By avoiding 
homologies, competition can be avoided to maximize signal strength. A pool of primers can be 
checked for cross homologies and then beacons designed that avoid cross homologies with all 
primers in the pool.  
In order to multiplex the primers:  
1. Select the sequences in Sequence Information table. You can select up to five sequences for 
multiplexing.  

2. Select Analyze > Multiplex Primers or click  from the toolbar.  
3. Beacon Designer instantly analyzes all the selected primers and displays the most stable cross 
dimers that are formed between the selected primers.  
4. The multiplex results are displayed in Multiplex Results Window.  
  

For example:  
1. Select sequences AJ300450,Y13051 and AB036365 in Sequence Information table. Each of 
these sequences has a primer pair, which you have designed or added in previous steps.  
2. Multiplex these by selecting Analyze > Multiplex Primers.  
3. Multiplex results show the most stable cross-dimer formed between two primers.  
4. The cross dimers are displayed graphically along with the cross dimer dG.  
5. By interpreting these results you can easily choose the most appropriate primers for a multiplex 
reaction.  
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Design Beacons 

Parameters for Beacon Design 
Beacon Designer supports beacon design for multiplex and allele discrimination assays. You can 
simultaneously design beacons on up to five sequences. 

To proceed with beacon design: 

1. Select the sequence for which primers are designed.  

2. Select Analyze > Beacon Search or click  button from the toolbar.  
3. If necessary set the Beacon Search Parameters to meet your experimental requirements.  
4. Beacon search parameters are saved for future search. You can reset the parameters to their 
default values by clicking Default.  
5. Launch a search by clicking Search.  
The most important point to note is that beacons are designed with stems of appropriate length 
adjusted automatically for optimal beacon Tm with reference to the primer pair TaOpt. The 
designed beacon is checked for cross dimer formation with the amplifying primer pairs, 
preventing competition in multiplex reactions. They are also checked for secondary structures, 
and cross hybridization to ensure high signal strength. 

Note: If the sequence has selected SNP, Beacon Designer will design both wild and mutant 

beacons for the sequence. To overlook the SNP information while designing beacons, click or 
the Unselect SNP button in the SNP Information tab or delete the existing SNP using Delete 
SNP. 

For Example: 

1. Select sequences AJ300450, Y13051 and AB036365 on which you have already designed 
primers.  
2. Select Analyze > Beacon Search.  
3. In the Beacon Search Parameters window set all parameters to default.  
These parameters are defined in consultation with Sanjay Tyagi. The probe length will range 
between 18 to 22 bases. The target melting temperature of output beacon is set 9 oC higher than 
TaOpt, and the tolerance is +/- 5 oC. Beacon Designer will search beacons as close as possible to 
the specified target value of Tm.  
For example: If TaOpt is 55.4 oC, then the target Tm will be 64.4 oC and the range will be 59.4 oC 
to 69.4 oC. The beacons with Tm equal to target are given the highest priority and the beacons 
having a Tm outside this range is not considered. The universal stem sequences are given as 
default. The stem of appropriate length is automatically selected and added for optimal beacon 
Tm.  
Advanced search parameters include the values for secondary structures such as self-dimers, 
alternate hairpins, repeats and runs. The default values for secondary structures are set to 
ensure high signal strength of output beacon. Beacons with value of self dimer, alternate hairpin, 
cross dimer, repeats and runs greater than the specified value are discarded.  
4. After setting parameters for beacon design, click Search.  
5. The search quality Status will be immediately displayed in the Search Status tab. The detailed 
beacon search results will be displayed in the Beacon Properties tab along with the beacon 
rating. 
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Beacon Search Results 
As soon as the beacon search is complete the search quality status is displayed in the Search 
Status tab and the detailed results are displayed in Beacon Properties Tab. 

1. Wild and mutant beacons are designed for sequences with SNP selected. Sense / antisense 
beacons are designed for all the other sequences.  
2. The displayed results include beacon rating, beacon sequence, position, length, probe melting 
temperature, beacon hairpin Tm, maximum alternate hairpin dG, maximum self-dimer dG, 
maximum cross-dimer dG, and the graphical view of the beacon hairpin structure.  
3. In the Sequence View you can view the position of the beacon on the sequence.  
4. You can view all possible beacon secondary structures in View Secondary structures 
window.  
5. You can copy the beacon sequence to the clipboard. Select Edit > Copy > Beacon Sequence 
or select Copy Beacon Sequence option from pop-up menu available at right click (For Mac, 
CTRL+click) over the Beacon Properties table. 

Select alternate beacons: 

After designing beacons you can replace the default beacon by selecting any other beacon from 
the All Beacons window.  

1. To view alternate beacons click   button . These probes are displayed in the 
order of their rating.  
2. Select any beacon in this window, it will be highlighted.  
3. Click the Replace button.  
4. The selected beacon replaces the default beacon in the Beacon Properties tab. The beacon 
sequence and properties can be printed and saved outside the program by using Export Beacon 
Results. 

Sort Beacons 

In All Beacon window there will be facility to sort Beacons probe on the basis of rating, position, 
length, Tm , GC%, Hairpin Delta G value and Self dimer delta G values. Sorting is not available 
on sequence and S.No. 

Note : Whenever All Beacons window will be launched Beacons are always sorted on the basis 
of rating. 
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Evaluate Beacon 

Evaluate Beacon 
In Beacon Designer, you can add and evaluate pre-designed beacons. Such evaluation of 
beacons would be desirable for:  
a. Analysis in a stand alone single PCR reaction.  
b. Analysis against other imported beacons.  
c. Use evaluated beacon as a base for searching primers/beacons on other targets for 
multiplexing.  
To evaluate a beacon:  
1. Select the sequence in the Sequence Information table.  

2. Select Analyze > Evaluate Beacon or click button from the toolbar.  
 
3. Type or paste the beacon sequence in the given text field. The beacon should always be 
added in the 5' to 3' direction. You are also required to specify the stem length and a valid E-mail 
address. The beacon hairpin Tm is calculated by connecting to the Quikfoldserver. A valid E-mail 
address is essential for connecting to the Quikfoldserver.  
 
4. When adding a beacon on the sequences already having a primer pair, you can either choose 
to evaluate the added beacon for the existing primer pairs or design new primers optimized for 
the added beacon.  
5. To design primers optimized for the added beacon, check the Design Optimum Primers option 
from the Evaluate Beacon window. By default the TaOpt of the designed primers will be 9 oC 
lower than the evaluated beacon Tm. You can change the target TaOpt value to meet your 
experimental requirements.  
 
6. Beacon Designer analyzes and rates the added beacon. The beacon is analyzed using existing 
beacon search parameters from the Beacon Search Parameters window. 

For Example: 

1. Select the sequence NM_026658 in the Sequence Information table.  
2. Select Analyze > Evaluate Beacon, to launch the Evaluate Beacon window.  
3. Paste the following beacon sequence in the given text field:  
     CGCGATCGGACTTAGAGTGAGGGCTTAGGGCAGATCGCG .  
4. As the selected sequence does not have a primer pair, Beacon Designer will design primer pair 
optimized for the evaluated beacon.  
5. Beacon Designer analyzes and rates the added beacon. The beacon is analyzed using existing 
beacon search parameters from the Beacon Search Parameters window. Then the search engine 
proceeds to design an optimized primer pair. The primers are searched using existing primer 
search parameters, which are set as default.  
6. The beacon properties are displayed in the Beacon Properties tab. The primer properties are 
displayed in Primer Properties table in the same tab. 
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Multiplex Beacons  
Beacon Designer can design beacons and primers for multiplex reactions. The beacons designed 
on multiple sequences in a single search are automatically checked for cross-dimer formation 
with the amplifying primer pairs, preventing competition in multiplex reactions.  

You can use the Multiplex Beacons option to check the multiplexing of beacons and primers 
designed in different searches.  
To multiplex beacons:  
1. Select the sequences in Sequence Information table. You can select up to five sequences for 
multiplexing.  

2. Select Analyze > Multiplex Beacons or click   from the toolbar.  
3. Beacon Designer instantly analyzes all the selected sequences and displays the most stable 
cross-dimers that are formed between the beacons and primers.  
4. The multiplex results are displayed instantly in the Multiplex Results Window.  
  

For example: 

To design a multiplex reaction for detection of four different pathogenic retroviruses: 

1. Select sequences AJ300450, AB036365 and Y13051 in the Sequence Information table. Each 
of these sequences has a primer pair, which were designed or added in previous steps. These 
primers amplify the conserved sequences of the gag gene of HIV-1, the env gene of HIV-2, the 
tax gene of HTLV-I, and the pol gene of HTLV-II respectively.  
2. Multiplex these by selecting Analyze > Multiplex Beacons .  
3. Multiplex results show the most stable cross dimer formed between the primers and beacons 
of the selected sequences.  
4. The cross dimers are displayed graphically along with the cross dimer dG.  
5. You are now ready to choose the most appropriate primer pairs and beacons for a multiplex 
experiment.  
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Nucleic Acid Sequence Based Amplification PCR 
 

 
Design Primers for NASBA(R)  
 
Parameters for NASBA(R) Primer Design  
 
Introduction : NASBA(R) is a transcription-based amplification method which amplifies RNA from 
either an RNA or DNA target. It is an isothermal nucleic acid amplification process involving the 
simultaneous activity of three enzymes; reverse transcriptase, RNase H and T7 RNA polymerase. 
This technique utilizes two oligonucleotide primers in which the downstream antisense primer 
contains a highly conserved 5’ promoter sequence recognized by T7 RNA polymerase. NASBA(R) 
has broad applications in the field of RNA/DNA amplification and allele specific detection.  

Parameters for NASBA(R) Primer design : Beacon for a sequence can be designed only after 
a primer pair has been designed. You can either design primers for a sequence using the 
software or evaluate pre-designed primer pairs. In Beacon Designer a maximum of five 
sequences can be multiplexed for NASBA(R) assays.  
 
Set Parameters for NASBA(R) Primer Design : 

To design NASBA(R) primers for selected sequence(s) in Beacon Designer:  
 
1. Select the sequence(s) and choose Analyze >Primer Search>NASBA(R) or click  button 
from the toolbar. When you click button from the toolbar the search window launched will have 
“Standard” selected and to perform NASBA(R) Primers search select “NASBA(R)”.  
 
2. Set the primer search parameters to meet your research needs. You can reset the parameters 
to default values by clicking Default. The default values of most of the range parameters are set 
loosely to ensure that the search succeeds in finding the best possible primer pair. The search 
algorithm uses the target values or the middle of the range (except for the product length and the 
primer length) to search for the best primers. If the range specified is narrow, no primers meeting 
the specifications may result. We recommend using default values for primer search. 

4. By default the Avoid Cross Homology option is checked. In this case the primers will be 
designed avoiding homologous regions. Similarly the Avoid Template Structure option is 
checked and by default, significant template secondary structures which may hinder the primers 
from annealing are identified and avoided. 

To design primers at these default values, the sequence(s) should already be BLASTed and a 
template search done. You may choose to skip these steps and design primers without avoiding 
cross-homology and/or template secondary structures. Simply uncheck these options in the 
Primer Search Window before launching a search. 

5. When multiple sequences are selected for a multiplex reaction, the primers in the pool will be 
checked for cross dimers and the primers best suited for multiplex reaction will be displayed. 

6. If the sequence(s) contain SNP information, the primers will be designed to amplify the SNP. 

7. Click Search to launch a search. 

8. Primer search parameters are saved for future searches.  

For example: 
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1. Select sequence M95491 in the Sequence Information tableSelect sequence .  
2. In order to design primers avoiding template secondary structures, the sequence should be 
evaluated for presence of stable secondary structures by folding it at Quikfold.  

3. To launch Template Structures dialog select Analyze> Template Structures or click  
from the toolbar.  
4. Set template Search Range as from 1 to 1200, for folding.  
5. BLAST search the sequence against aT omato.fa in local database by selecting 
Analyze>BLAST Search>Sequence.  
6. Now proceed to design primers for the sequences, select Analyze >Primer 
Search>NASBA(R) or click   from the toolbar.  
11. Set the Primer Search Parameters to their default values.  
12. Avoid Template Structure, Avoid Cross Homology options are checked.  
14. Click Search to launch a search.  
15. As soon as the primer search is complete, the properties of the designed primer are displayed 
in the Primer Properties table under the Beacon Properties tab with both, the individual and 
primer pair rating. The primer rating is given to quantify the merit of primer with reference to the 
search parameters. A primer rating of 100 indicates that the primer exactly matches the specified 
search parameters. 
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NASBA(R) Primers Search Result 
 

As soon as the NASBA(R) primer search is complete the search quality status is displayed in the 
Search Status Tab and the detailed result is displayed in the Primer properties table under 
Beacon Properties tab. 

1. Primer P1 is displayed with tag and purine bases (if added). Tag sequence is represented in 
italics and are green in color. Purine bases are also in italics but black in color.  
 
For example : AATTCTAATACGACTCACTATAGGGAAATTCACTGGGAGGCTCTAAG  
 
AATTCTAATACGACTCACTATAGGG - Tag sequence  
 
AAA – Extra purine bases  
 
TTTCACTGGGAGGCTCTAAG – Primer P1 sequence  
 
2. The displayed result of P2 primer include rating, primer sequence, melting temperature, 
position, length, GC%, maximum hairpin dG, maximum self dimer dG, repeat and run length, 
optimum annealing temperature, maximum cross dimer dG, product length, product Tm.  
 
The displayed results for primer P1 include melting temperature considering both tag and without 
tag, GC%, maximum hairpin dG, maximum self dimer dG, maximum cross dimer dG considering 
tag while repeat and run length, optimum annealing temperature, product length, product Tm 
without considering tag.  
 
Note: The rating of the Primer P1 includes the Tm value without tag.  
 
2. You can view all possible primer secondary structures from View>All Structures> Primers or 
select option from pop-up menu available at right click over the primer sequencePrimer All 
Structure.  
 
3. In the Sequence View, both P1 and P2 primer positions are marked on the sequence.  
 
4. You can copy the primer sequence to the clipboard. Select Edit > Copy > P1 Primer or P2 
Primer respectively or select Copy P1 Primer or P2 Primer Sequence option from pop-up menu 
available at right click (For Mac, CTRL+click) over the primer sequence.  
 
Example: 

1. The primer search result for sequence M95491 displays P1 and P2 primers along with the free 
energy values for secondary structures and product properties.  
 
2. You can view the graphical view of all the primer secondary structures in Secondary Structures 
window by clicking All Structures option from pop-up menu available at right click over the 
Primer Properties table or by selectingView > Alternate > Primers.  
 
You can replace the default primer pair with an alternate primer pair to meet your research needs. 

1. Properties of the alternate primers along with the primer displayed under Beacon properties tab 
are displayed in the All Primers window. Primer pair displayed under Beacon properties tab is 
marked with grey color in All Primers window.  
 
2. Select any primer pair.  
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2. Click the Replace button.  
 
3. The selected primer pair will replace the default primer pair in the Primer Properties table and 
will now be marked in grey color in All Primers window. 

Select alternate primer: 

After designing primer you can replace the default primers by selecting any other primer pair from 
the All Primers window.  

1. To view alternate beacons click  button.  
 
2. The window displays the alternate primers. The window displays both the default primer 
displayed under Primer Properties Tab and alternate primers. The primer which is displayed 
under Primer Properties tab will be highlighted in All Primer window.  
 
2. Select any primer pair in this window, it will be highlighted. 

3. Click the Replace button.  
 
4. The selected beacon replaces the default primer pair in the Primer Properties tab and now will 
be highlighted with grey color in All Primers window. The primer sequence and properties can be 
printed and saved outside the program by using Export Beacon Results. 

Sort Primers: 

In All Primers window there will be facility to sort P1 primer, P2 primer and product on the basis of 
rating, position, length, Tm , GC%, Hairpin Delta G value and Self dimer delta G values. Sorting is 
not available on sequence and S.No. 

Note : Whenever All Primers window will be launched primers are always sorted on the basis of 
Product rating. 
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Evaluate Primers 

Evaluate NASBA(R) Primers 
 

In Beacon Designer, you can add pre-designed NASBA(R) primers instead of designing primers 
using the program. This is useful when you already have primers in your lab or are working with 
published primer sequences.  

1. Select the sequence in the Sequence Information table.  
 
2. Select Analyze>Evaluate Primers>NASBA(R) or click button from the toolbar, to launch 
the Evaluate Primers window. When Evaluate Primer dialog is launched from toolbar then select 
NASBA(R).  
 
3. Type or paste the primer sequences in the given text field. The primers should always be 
added in the 5' to 3' direction and without Taq sequence.  
 
Note : Do not add primer sequence with tag. During process of evaluation program itself will add 
the tag to P1 Primer.  
 
4. Beacon designer also allow you to use the pre-designed SYBR Green primers on sequence by 
checking Import SYBR Green primers option. Program will display the SYBR Green primers in 
P1 and P2 primers text field.  
 
5. Beacon Designer analyzes and rates the added primers. The primers are analyzed using 
existing NASBA(R) primer search parameters from the Primer Search Parameters window. 

For example:  
 
1. Select the sequence AF209198.  
 
2. Add the following primer sequences:  
P2 Primer: GGTTCTCCATCTGTGCCTTG  
P1 Primer: ACATCAGCTATGACAATCTTATGC 

Beacon Designer analyzes and rates these primers using existing primer search parameters, 
which are currently set as default. The primer properties are displayed in Primer properties table.  
 
3. To verify the specificity of the evaluated primer pair, you can BLAST search the primer pair 
against the relevant database using Analyze>BLAST Search>Primer Pair/Amplicon.  
 
4. Detailed BLAST search results are displayed in the default browser. 
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Multiplex NASBA(R) Primers 
 

In Beacon Designer you can design beacons and primers for multiplex NASBA(R) reactions. By 
avoiding homologies, competition can be avoided to maximize signal strength. A pool of primers 
can be checked for cross homologies and then beacons designed that avoid cross homologies 
with all primers in the pool. 

In order to multiplex the primers:  
1. Select the sequences in Sequence Information table. You can select up to five sequences for 
multiplexing on which Primers for NASBA(R) assay is designed. 

Note: Sequence having different types of Primers i.e. Standard and NASBA(R) cannot be used for 
multiplexing.  

2. Select Analyze>Multiplex Primers or click  from the toolbar.  
3. Beacon Designer instantly analyzes all the selected primers and displays the most stable cross 
dimers that are formed between the selected primers.  
4. The multiplex results are displayed in Multiplex Results Window.  

For example:  
1. Select sequences AF506281, AB031207, M95491 in Sequence Information table. Each of 
these sequences has a NASBA(R) primer pair, which you have designed or added in previous 
steps.  
2. Multiplex these by selecting Analyze>Multiplex Primers.  
3. Multiplex results show the most stable cross-dimer formed between two primers.  
4. The cross dimers are displayed graphically along with the cross dimer dG.  
5. By interpreting these results you can easily choose the most appropriate primers for a multiplex 
reaction.  
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Design Beacons For NASBA(R) 
 
Parameters for NASBA(R) Beacon Design 
 
Beacon Designer supports NASBA(R) beacon design for multiplex and allele discrimination 
assays. You can simultaneously design beacons on up to five sequences. In NASBA(R) assay 
always sense beacons are designed and MFold tends is used predict the secondary structure 
and melting temperature of molecular baecons. The parameters which are used to calculate 
molecular beacon Tm at Mfold for NASBA(R) assay are:  
  

Nucleic Acid concentration 0.25nM 

Monovalent Ion concentration 100mM 

Free Mg Ion concentration 12mM 

Total Na Equivalent 538.18mM 

Temperature for beacon Energy calculation 41ºC 

 
To proceed with beacon design:  
 
1. Select the sequence for which primers are designed.  
 

2. Select Analyze > Beacon Search > NASBA(R) or click button from the toolbar.  
 
3. If necessary set the Beacon Search Parameters to meet your experimental requirements.  

4. Beacon search parameters are saved for future search. You can reset the parameters to their 
default values by clicking Default.  
 
5. Launch a search by clicking Search. The most important point to note is that beacons are 
designed with stems of appropriate length adjusted automatically for optimal beacon Tm with 
reference to the primer pair TaOpt. The designed beacon is checked for cross dimer formation 
with the amplifying primer pairs, preventing competition in multiplex reactions. They are also 
checked for secondary structures, and cross hybridization to ensure high signal strength.  
 
Note: If the sequence has selected SNP, Beacon Designer will design both wild and mutant 
beacons for the sequence. To overlook the SNP information while designing beacons, click or the 
Unselect SNP button in theSNP Information tab or delete the existing SNP using Delete SNP. 

For Example: 

1. Select sequence M95491 which you have already designed primers.  
2. Select Analyze>Beacon Search>NASBA(R). 
3. In the Beacon Search Parameters window set all parameters to default.  
4. After setting parameters for beacon design, click Search.  
5. The search quality Status will be immediately displayed in the Search Status tab. The detailed 
beacon search results will be displayed in the Beacon Properties tab along with the beacon 
rating. 
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NASBA(R) Beacon Search Results 
 

As soon as the NASBA(R) Beacon search is complete the search quality status is displayed in the 
Search Status tab and the detailed results are displayed in Beacon Properties Tab. 

1. Wild and mutant beacons are designed for sequences with SNP selected. Sense / antisense 
beacons are designed for all the other sequences.  
2. The displayed results include beacon rating, beacon sequence, position, length, probe melting 
temperature, beacon hairpin Tm, maximum alternate hairpin dG, maximum self-dimer dG, 
maximum cross-dimer dG, and the graphical view of the beacon hairpin structure.  
3. In the Sequence View you can view the position of the beacon on the sequence.  
4. You can view all possible beacon secondary structures in View Secondary structures 
window.  
5. You can copy the beacon sequence to the clipboard. Select Edit > Copy > Beacon Sequence 
or select Copy Beacon Sequence option from pop-up menu available at right click (For Mac, 
CTRL+click) over the Beacon Properties table.  
 
Note : For NASBA(R) assay only sense beacons are designed. 

Select alternate beacons: 

After designing beacons you can replace the default beacon by selecting any other beacon from 
the All Beacons window.  

1. To view alternate beacons click button.  
 
2. The window displays the alternate Beacons the window displays both the default beacon 
displayed under Beacon Properties Tab and alternate Beacon The probe which is displayed 
under Beacon Properties tab will be highlighted in All Beacon window. The probes are displayed 
in the order of their rating.  
 
2. Select any beacon in this window, it will be highlighted. 

3. Click the Replace button.  
 
4. The selected beacon replaces the default beacon in the Beacon Properties tab and now will be 
highlighted with grey color in All Beacons window. The beacon sequence and properties can be 
printed and saved outside the program by using Export Beacon Results. 

Sort Beacons 

In All Beacon window there will be facility to sort Beacons probe on the basis of rating, position, 
length, Tm , GC%, Hairpin Delta G value and Self dimer delta G values. Sorting is not available 
on sequence and S.No. 

Note: Whenever All Beacons window will be launched Beacons are always sorted on the basis of 
rating. 
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 Evaluate Beacons For NASBA(R) 
 

 
Evaluate Beacons For NASBA(R)  
 
In Beacon Designer, you can add and evaluate pre-designed beacons for NASBA(R) assay. Such 
evaluation of beacons would be desirable for:  
a. Analysis in a stand alone single PCR reaction.  
b. Analysis against other imported beacons.  
c. Use evaluated beacon as a base for searching primers/beacons on other targets for 
multiplexing.  
 
To evaluate a beacon:  
 
1. Select the sequence in the Sequence Information table.  
 

2. Select Analyze > Evaluate Beacon or click  button from the toolbar.  
 
Note : If primers are designed for NASBA(R) assay then you can evaluate beacons for this assay 
only.  
 
3. Type or paste the beacon sequence in the given text field. The beacon should always be 
added in the 5' to 3' direction.  
 
Note: Only sense beacons can be evaluated for NASBA(R) assay. 

You are also required to specify the stem length and a valid E-mail address. The beacon hairpin 
Tm is calculated by connecting to the Quikfoldserver. A valid E-mail address is essential for 
connecting to the Quikfoldserver.  
 
4. When adding a beacon on the sequences already having a primer pair, you can either choose 
to evaluate the added beacon for the existing primer pairs or design new primers optimized for 
the added beacon.  
 
5. To design primers optimized for the added beacon, check the Design Optimum Primers option 
from the Evaluate Beacon window. By default the TaOpt of the designed primers will be 9 oC 
lower than the evaluated beacon Tm. You can change the target TaOpt value to meet your 
experimental requirements.  
 
Note: On checking Design optimum primer pair option you also have the facility to select the 
type of assay either Standard or NASBA(R).  
 
6. Beacon Designer Analyzes and rates the added beacon. The beacon is Analyzed using 
existing beacon search parameters from the Beacon Search Parameters window. 

For Example:  
 
1. Select the sequence L22214 in the Sequence Information table.  
 
2. SelectAnalyze > Evaluate Beacon, to launch the Evaluate Beacon window. 

3. Paste the following beacon sequence in the given text field:  
CGCGACTCTAACCATGACTCGGACCTGATCGCG  
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4. As the selected sequence does not have a primer pair, Beacon Designer will design primer pair 
optimized for the evaluated beacon.  
 
5. Beacon Designer analyzes and rates the added beacon. The beacon is analyzed using existing 
beacon search parameters from the Beacon Search Parameters window. Then the search engine 
proceeds to design an optimized primer pair. The primers are searched using existing primer 
search parameters, which are set as default.  
 
6. The beacon properties are displayed in the Beacon Properties tab. The primer properties are 
displayed in Primer Properties table in the same tab. 
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Multiplex Beacons For NASBA(R) 
 

Beacon Designer can design beacons and primers for NASBA(R) multiplex reactions. The 
beacons designed on multiple sequences in a single search are automatically checked for cross-
dimer formation with the amplifying primer pairs, preventing competition in multiplex reactions.  

You can use the Multiplex Beacons option to check the multiplexing of beacons and primers 
designed in different searches.  
To multiplex beacons:  
1. Select the sequences in Sequence Information table. You can select up to five sequences for 
multiplexing on which Beacons for NASBA(R) assay are designed 

Note: Sequence having different types of Beacons probes i.e. Standard and NASBA(R) cannot be 
used for multiplexing.  
 

2. Select Analyze > Multiplex Beacons or click from the toolbar.  
3. Beacon Designer instantly analyzes all the selected sequences and displays the most stable 
cross-dimers that are formed between the beacons and primers.  
4. The multiplex results are displayed instantly in the Multiplex Results Window.  
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TaqMan(R) Design  
Parameter for T(R) Probe Design;  
 

Parameters for TaqMan(R) Probe Design 
Beacon Designer supports TaqMan(R) probe design for multiplex and allele discrimination assays. 
You can automatically design TaqMan(R) probes checked for multiplexing, on up to four 
sequences The probes designed on multiple sequences in a single search are automatically 
checked for cross-dimer formation with the primer pairs of other sequences, preventing 
competition in multiplex reactions. You can also use the Multiplex TaqMan(R) option to check the 
multiplexing of TaqMan(R) and primers designed in different search. The TaqMan(R) probe and the 
primers are designed simultaneously. To design an assay, first set parameters for TaqMan(R) 
design. 

Steps for TaqMan(R) probe design: 

1. Select the sequence in the Sequence Information table.  

2. Select Analyze > TaqMan(R) Search > Standard or click  button from the toolbar.  
3. If necessary set the TaqMan(R) Search Parameters to meet your experimental requirements. 
You can reset the parameters to default values by clicking Default. The default values of most of 
the range parameters are set loosely to ensure that the search succeeds in finding the best 
possible primer pair. These values do NOT affect the quality of the resulting primers, they only 
serve as the minimum and maximum acceptable limits. The search algorithm uses the target 
values or the middle of the range (except for the product length and the primer length) to optimize 
the primers. If the range specified is narrow, no TaqMan(R) meeting the specifications may result. 
We recommend the use of default values for TaqMan(R) search.  
4. By default, the Avoid Cross Homology option is checked. In this case the primers will be 
designed avoiding homologous regions.  
By default, the Avoid Template Structure option is checked. The regions of template with 
secondary structure will be avoided while designing primers.  
If you would like to design primers at these default values, the sequence(s) should already be 
BLASTed and a template search done. Otherwise these options should be unchecked before 
launching a TaqMan(R) search.  
5. When multiple sequences are selected for a multiplex reaction, the primers designed will be 
checked for cross dimers and the best primers with respect to multiplexing will be displayed.  
6. If the sequences contain SNP information, the primers will be designed to amplify the SNP.  
7. Launch search by clicking the Search.  
8. Primer search parameters are saved for future searches. You can reset the parameters to their 
default by clicking Default.  
The most important point to note is that the optimal primers are designed as close as possible to 
the TaqMan(R) probes without overlapping it. The TaqMan(R) probes of sequences selected for 
multiplexing are checked for cross dimers with each other and with all the designed primers, 
preventing competition in multiplex reactions. They are also checked for secondary structures, 
and cross hybridization to ensure high signal fidelity. 

Note: If the sequence has selected SNP, Beacon Designer will design both wild and mutant 
TaqMan(R) probes for the sequence. To overlook the SNP information while designing TaqMan(R) 
probe, click the Unselect SNP button in the SNP Information tab or delete the existing SNP using 
Delete SNP.  

For Example: 

To design a multiplex reaction for detection of four different pathogenic retroviruses:  
1. Select sequences Y13051 and AJ300450 in the Sequence Information table.  
2. Select Analyze > TaqMan(R) Search > Standard.  
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3. In the TaqMan(R) Search Parameters window set all parameters to default. These parameters 
are defined according to TaqMan(R) design guidelines.  
4. Avoid Template Structure, Avoid Cross Homology, and Multiplex options are checked. 
Note, to design primers at these default values, the sequence(s) should already be BLASTed and 
a template search done.  
5. The Search Range for Y13051 is restricted to 2339 to 3520 bp to design primer pair to amplify 
Human T-cell lymphotropic virus type 2 reverse transcriptase 'pol' gene.  
6. Similarly the Search Range for sequenceAJ300450 is restricted to 1 to 1079 band for 
AF185802 is 1 to 464 bp. To amplify conserved sequences of HTLV-I tax gene, Human 
immunodeficiency virus type 1 Gag core protein gene and the env gene of HIV-2 respectively.  
7. By default the Multiplexing option is checked, i.e the program will check the TaqMan(R) probes 
of selected sequences for cross dimers with each other and with all the designed primers. Each 
designed TaqMan(R) probe is always checked for cross dimers with the amplifying primer pair. 

The probe and primer length will range between 20 to 24 bases. The target melting temperature 
of the designed TaqMan(R) probe is set 10 oC higher than the primer melting temperature with a 
tolerance of +/- 2 oC. Beacon Designer will search TaqMan(R) probes as close as possible to the 
specified target value of Tm.  
For example: If primer Tm is 59.0 oC, then the target TaqMan(R) Tm will be 69.0 oC and the range 
will be 67.0 oC to 71.0 oC. The TaqMan(R) having Tm equal to target will be given highest priority 
and the TaqMan(R) having a Tm outside this range will not be considered. The optimal primer for 
the same strand as the TaqMan(R) will be designed, such that the 3' end of the primer is within 10 
bases of the probe without overlapping the probe sequence.  
The Advanced search parameters include the maximum acceptable values for secondary 
structures such as self-dimers, hairpins, cross-dimers, repeats, and runs in primers and 
TaqMan(R) probes. The default values for secondary structures are set to ensure high signal 
strength of the designed TaqMan(R). TaqMan(R) probes and primers having values for self-dimer, 
hairpin, cross-dimer, repeats and runs greater than the specified value are discarded.  
Additional parameters such as GC clamp, 3'end stability and maximum difference between primer 
pair Tm are considered for the designed optimum primers. 

8. After setting the parameters for TaqMan(R) design, launch search by clicking Search.  
9. The search quality status will be immediately displayed in the Search Status tab. The detailed 
TaqMan(R) search results will be displayed in the TaqMan(R) Properties tab and the primer search 
results will be displayed in the Primer Properties table along with the primer rating. 

 

 

 

 

 

 
 
Search Results;  
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TaqMan(R) Probe Search Results 

) Probe 
As soon as the TaqMan(R) search is complete the search quality status is displayed in the Search 
Status Tab, the detailed results are displayed in TaqMan(R) Properties Tab and the location of 
TaqMan(R) on the sequence is displayed in the Sequence view. 

1. Wild and mutant TaqMan(R) probes are designed for sequences with a SNP selected. The best 
TaqMan(R) whether sense or antisense, is designed for sequences without a SNP selected.  
2. The displayed results include TaqMan(R) rating, sequence, position, length, probe Tm, GC%, 
maximum hairpin dG, maximum self-dimer dG, maximum cross-dimer dG.  
3. You can view all possible TaqMan(R) secondary structures in View Secondary Structures 
window.  
4. In the Sequence View, you can view the location of the TaqMan(R) on the sequence .  
5. You can copy the TaqMan(R) sequence to the clipboard. Select Edit > Copy > TaqMan(R) 
Sequence or select Copy TaqMan(R) sequence option from pop-up menu available at right click 
(For Mac, CTRL+click) over the TaqMan(R) sequence. 

Select Alternate TaqMan(R) Probe: 

After designing TaqMan(R) you can replace the default TaqMan(R)probe by selecting any other 
TaqMan(R) that meets your research needs better. Other TaqMan(R) probes are available in the All 
TaqMan(R) window.  
 

1. To view alternate TaqMan(R) probes click the  button.  
 
2. The window displays both the alternate TaqMan(R) and the associated primer pair.The window 
displays both the best and alternate TaqMan(R) with their associated primer pair. The probe which 
is displayed under TaqMan Properties tab will be highlighted in All TaqMan window. The probes 
are displayed in the order of their rating in the upper half of the window.  
 
3. Select any TaqMan(R) in this window. The optimum primer pairs associated with the selected 
TaqMan(R) probe are displayed in the All Primers window.  
   
4. By default the best primer pair will be selected. You can select any other primer pair by 
highlighting it.  
 
5. Click the Replace button.  
 
6. The selected TaqMan(R) probe replaces the default TaqMan(R) probe in the TaqMan(R) 
Properties tab and the selected primer pair will replace the default primer pair. The probe that 
replaces the default probe set will be highlighted by the grey background in the All TaqMan 
window. 

 

Sort TaqMan and Primers: 

In All TaqMan window there will be facility to sort TaqMan probe sense primer, antisense primer 
and product on the basis of rating, position, length, Tm , GC%, Hairpin Delta G value and Self 
dimer delta G values. Sorting is not available on sequence and S.No. 

Note: Whenever All TaqMan and All primers window will be launched, TaqMan and primers are 
always sorted on the basis of Product rating. 
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Evaluate TaqMan (R) Probes 
);  

Evaluate TaqMan (R) probes 
In Beacon Designer, you can add and evaluate pre-designed TaqMan(R) and Primer pairs. Such 
evaluation would be desirable for:  
a. Adapting SYBR (R) green results to TaqMan(R) assays.  
b. Analysis against other imported TaqMans(R) probes.  
c. Use evaluated TaqMan(R) or Primers as a base for searching primers/TaqMan(R) on other 
targets for multiplexing. 

To evaluate a primer pair and designing optimum TaqMan(R) probes:  
1. Select the sequence in the Sequence Information table.  
 

2. Select Analyze > Evaluate TaqMan(R) > Standard or click  from the toolbar.  
3. Select Evaluate Primer Pairs from the drop-down menu, to evaluate the added primer pair and 
design optimized TaqMan(R) probe.  
4. Type or paste the primer sequences in the given text field. The primers should always be 
added in the 5' to 3' direction.  
5. The default values for TaqMan(R) Search parameters are set to ensure that the search 
succeeds in finding the most optimum TaqMan(R) probe for the evaluated primer pair. You can 
change these default values to suit your experimental requirements.  
6. Beacon Designer anlyzes and rates the added Primer pair. The Primer pair is analyzed using 
existing Primer search parameters from the TaqMan Parameters Search window. 

For example:  
1. Select the sequence L22214 in the Sequence Information table.  
2. Select Analyze > Evaluate TaqMan(R) > Standard, to launch Evaluate TaqMan(R) window.  
3. Select Evaluate Primer Pairs from the drop-down menu, to evaluate the added primer pair and 
design optimized TaqMan(R) probe.  
3. Paste the following primer sequences:  
Sense Primer: 5' GCCCAGCATCCTTACCTACATT 3'.  
Antisense Primer: 5' AAGGTGACGCGGAACTTCTG 3'.  
4. Set the TaqMan(R) Search Parameters to Default.  
5. Click OK to evaluate the added primer pairs and design optimum TaqMan(R) probe.  
Beacon Designer analyzes and rates these primers using existing primer search parameters, 
which are currently set as default. The primer properties are displayed in Primer Properties table 
and the designed TaqMan(R) Properties are displayed in the TaqMan(R) Properties Tab.  
6. To verify the specificity of the evaluated primer pair, you can BLAST search the primer pair 
against the relevant database using Analyze > BLAST >Primer Pair option.  
7. Detailed BLAST search results are displayed in the default browser. 
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Multiplex TaqMan(R) 
In Beacon Designer you can design TaqMan(R) probes and primers for multiplex reactions. The 
TaqMan(R) designed on multiple sequences in a single search at default values are automatically 
checked for cross-dimers with each other and with all the designed primers, preventing 
competition in multiplex reactions.  
You can also use the Multiplex TaqMan(R) option to check the multiplexing of TaqMan(R) probes 
and primers designed in different search runs.  
In order to multiplex TaqMan(R):  
1. Select the sequences in Sequence Information table. You can select up to four sequences for 
multiplexing having Standard TaqMan design.  
 
Note : Sequence having different types of TaqMan probes i.e. Standard and LNA(TM) Substitued 
cannot be used for multiplexing.  

2. Select View > Multiplex TaqMan(R) or click  from the toolbar.  
3. Beacon Designer instantly anlyzes all the selected sequences and displays the cross-dimers 
that are formed between the TaqMan(R) and primers.  
4. The multiplex results are displayed instantly in the Multiplex Results Window.  
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Multiplex Taqman® Assay 
 

Design TaqMan probes and primers for multiplex assay 

  
Multiplex PCR is an essential cost saving technique for an endless list of applications including 
large scale genotyping, gene expression, whole genome sequencing, forensic analysis and also 
facilitate the diagnosis of infectious disease.  
 
Multiplex PCR primer design and optimization is a greater challenge than designing singleplex 
PCR primer design. The aim of multiplex is to find sets of primer that can be used in a single PCR 
reaction to amplify many sequences simultaneously. Beacon Designer finds the multiplex set that 
matches these criterion by first finding all the acceptable primer pair for each of the targets, then 
testing every combination and giving back those sets that meet the criterion.  
 
Here is how to design Multiplex set for Taqman probes and primers for Multiplex assay: 
 
1) Select more than one sequence. 

2) Select Analyze> Multiplex TaqMan® > Standard or click  button on tool bar. 
3) Set “Multiplex Taqman Search parameters ” to meet your experimental need. You can reset 
the parameters to the default values by clicking Default button.  
4) Specify the Reaction conditions. 
5) Click Search button to launch the search. 
6) After the search is complete results will be displayed under Multiplexing results tab. 
For Example:  
1) Select Sequences  NM_026658 and L22214 from sequence information table. 

2) Select Analyze> Multiplex TaqMan® > Standard or click  button on tool bar. 
3) Specify the “Multiplex Set Name” Set 2.  
4) Check Avoid Template Structure, Avoid Cross homology. 
5) Set “Multiplex Taqman Search parameters ” to meet your experimental need. You can reset 
the parameters to the default values by clicking the Default button. 
6) Set the Reaction conditions to the default values by clicking the Default button. 
7)  The Search Range for NM_026658 is restricted to 1-1200bp, for sequence L22214 is 
restricted to1-1200 bp BP to design primer pair. 
8) After setting the parameters for TaqMan® design, launch search by clicking Search. 
9) As soon as search is complete results will be displayed under multiplexing results tab. Under 
this tab, left pane displays multiplexed group and right pane displays sequences corresponding to 
multiplexed group. The best multiplex set for selected multiplexed group is shown under the 
TaqMan properties tab. 
 
Following steps are followed while performing TaqMan Multiplexing: 

A) Select Sequences "a" and "b" 
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B) First of all TaqMans and Primers are searched on the selected Sequences. 

C) For example: Say there is one taqman and 3 primer pair for each of the sequences a and b 

Taqman for sequence a - Ta  

Sense Primer for Sequence a – Sa1, Sa2, Sa3 

Antisense Primer for sequence a – Aa1, Aa2, Aa3 

Taqman for sequence b - Tb  

Sense Primer for Sequence b – Sb1, Sb2, Sb3 

Antisense Primer for sequence b – Ab1, Ab2, Ab3 

D) Firstly TaqMan-TaqMan Multiplexing is carried out between the Taqmans of different 
sequences for forming the individual TaqMan-Group. They are checked for cross dimer and Tm 
difference. While Taqman- Taqman multiplexing following combinations will be checked for cross 
dimer dG and Tm difference.  

Ta : Tb 

E) Then Taqman-Primer Multiplexing is carried out. In this step each TaqMan group from the set 
of TaqMan Groups is taken and all the TaqMan's of this TaqMan Group are Multiplexed with the 
associated primers for all the other sequence's. 

Say we consider the taqman group ( Ta : Tb) then following combinations will be checked while 
the Taqman- Primer multiplexing- 

Taqman of sequence “a” will be checked with 3 primer pair of sequence "b" 

Ta : Sb1, Ta : Ab1, Ta : Sb2, Ta : Ab2, Ta : Sb3, Ta: Ab3,  

Taqman of sequence “b” will be checked with 3 primer pair of sequence "a". 

Tb : Sa1, Tb: Aa1, Tb : Sa2, Tb : Aa2, Tb : Sa3, Tb : Aa3 

Primers which gets failed in TaqMans-Primers multiplexing(Cross Dimer dG values and Tm 
difference) are rejected. 

F) Then Primer-Primer multiplexing is carried out. In this step, the primers associated with the 
TaqMans of a TaqMan Group are Multiplexed with the associated Primers of TaqMan's of all 
other sequences.  

Say we consider Ta : Sb1 and Ta : Ab1 group, Ta : Sb3 , Ta: Ab3 group and Tb : Sa2, Tb : Aa2 
group then the following combination will be checked for Primer-Primer Multiplexing. 

Sb1 : Sa2 , Ab1 : Sa2 

Sb1 : Aa2 , Ab1 : Aa2 

Sb3 : Sa2, Ab3 : Sa2 

Sb3 : Aa2, Ab3 : Aa2 

Again the group that fails in Cross Dimer dG values are rejected. 
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G) As soon as any of the Primer Pair multiplexing for any combination is passed, then again it is 
returned to the D step again. Say we consider Sb1 : Sa2 , Ab1 : Sa2 and Sb1 : Aa2 , Ab1 : Aa2 
combination is passed. 

H) Finally this first passed TaqMan Group is reported as the Best Multiplexed TaqMan Group for 
the selected Sequences.  

Here the multiplex set reported would be Ta : Sa2 : Aa2 for sequence “a” and Tb: Sb1: Ab1 
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Multiplex TaqMan(R) and Primer for Reference gene multiplexing 

 
Multiplex RT-PCR using reference genes as a reference against the gene of interest is one of the 
most widely accepted technique used now a days. This involves concurrent amplification of the 
target gene and reference gene.  

Beacon Designer designs Multiplex sets for Taqman probes and primers for reference gene 
multiplexing. Beacon Designer finds the multiplex set that matches these criterion by first finding 
all the acceptable primer pair for each of the targets, then testing every combination and giving 
back those sets that meet the criterion.  

Here is how to design Multiplex sets for Taqman probes and primers for reference gene 
multiplexing- 

1) Select more than one sequence. 

2) Select Analyze> Multiplex TaqMan® > Standard or click    button on tool bar. 
3) Specify “Multiplex set name”. 
4) Set “Multiplex Taqman Design parameters ” to meet your experimental need. You can reset 
the parameters to the default values by clicking the Default button.  
5) You can select a reference gene under the “Sequence length range/ reference gene 
selection” segment. Maximum three sequences can be selected as a reference gene. To select 
a sequence as a reference gene it should have pre-designed primers and probes. 
 
Note: Sequences having SNP can be selected as a reference gene. When you select a SNP 
sequence as a reference gene, you need to select either wild probe or mutant probe and selected 
probe will be used for multiplexing.  
Sequences not having the pre-designed primers and probes cannot be selected as a reference 
gene and will be grayed out. Evaluate Primers and probe to use as a reference gene. 
For selected reference gene amplicon length will be displayed in “Search Range” column and Tm 
of Pre-designed Primer and probe will be displayed in Primer Tm and Probe Tm column. 
6) Specify Reaction conditions. 
Note: When you select a reference gene, reaction conditions for the selected reference gene will 
displayed in reaction condition dialog and will be used for multiplexing. 
If you select more than one sequence as a reference gene, then the reaction condition for the all 
the selected reference gene must be identical. 
7) Click Search button to launch the search. 
8) After the search is complete results will be displayed under Multiplexing Results Tab. 
 
 
For Example  
 
1) Select Sequences L22214, M95491 and Y13051 from Sequence Information table. 

2) Select Analyze> Multiplex TaqMan® > Standard or click  button on tool bar. 
3) Specify “Multiplex Set Name Set5. 
4) Uncheck Avoid Template Structure, Avoid Cross Homology.  
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5) Set “Multiplex Taqman Search parameters ” to meet your experimental need. You can reset 
the parameters to the default values by clicking the Default button. 
6) Select the M95491 as a reference gene. “length range” for reference gene is 3467-3554”. Tm 
of Probe for selected reference gene is 68.5oC and Tm of sense primer and antisense Primer for 
selected reference gene are 59.0oC and 59.4oC. displayed under primer Tm and probe Tm 
column. 
7) Reaction condition of M95491 will be displayed in reaction condition dialog. 
7) Click Search button to launch the search. 
8) As soon as search is complete results will be displayed under multiplexing results tab. Under 
this tab, left Pane displays multiplexed group and right Pane displays sequences corresponding 
to multiplexed group. The best multiplex set for multiplexed group is shown under TaqMan 
properties tab. 
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Multiplex Taqman Set Search results 

 

As soon as Multiplex Taqman Set search is complete, it will automatically switched to Multiplexing 
Results Tab which displays multiplexed group and the corresponding sequences. Under 
multiplexing tab left pane displays Multiplexed group with group status and set rating and right 
pane displays corresponding sequences of the multiplexed group along with their individual 
Taqman and Primer search status. 

 
1) Multiplex sets are displayed under TaqMan properties Tab. 
2) Each multiplex set will display Taqman probe and primers of the individual sequence 
considered while multiplexing. The displayed result include both the sense and antisense primer 
rating, primer sequence, TaqMan® rating, Taqman sequence position, length, melting 
temperature, GC%, maximum hairpin dG, maximum self dimer dG, repeat and run length, 
optimum annealing temperature, maximum cross dimer dG, product length, product Tm., probe 
Tm. 
3) The graphical view of the primer and TaqMan secondary structures is displayed in the 
Secondary Structures window. You can view the primer secondary structures and Taqman 
secondary structure by clicking All Structures option from pop-up menu available at right click 
(For Mac, CTRL+click) on sequence displayed in Taqman Properties tab or by selecting View>All 
Structure > Primers or Taqman. 
4) The Secondary Structures window displays the graphical view of all the possible structures for 
dimers, hairpins, cross-dimers, repeats and runs for the selected primer or probe. 
5) You can copy the primer and Taqman sequence to the clipboard. Select Edit> Copy> Sense 
primer,antisense primer, Taqman Sequence or select Copy Primer Sequence or Taqman 
sequence option from pop-up menu available at right click (For Mac, CTRL+click) on sequence in 
Taqman Properties tab. 
Select Alternate Multiplex Set 
You can replace the default multiplex set with an alternate multiplex set to meet your research 
needs. 
 
1) To view alternate multiplex set select View > All Multiplex set button or click 

 button. 
2) The window displays both the default multiplex set displayed under Taqman Properties Tab 
and alternate multiplex set. The multiplex set which is displayed under Taqman Properties tab will 
be highlighted in All multiplex sets window.  
3) Select any Multiplex Set.  
4) Click the Replace button.  

5) The selected Multiplex set will replace the default multiplex set in the Taqman Properties tab. 
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LNA(TM) Substituted TaqMan(R) Assay  
 

Design LNA(TM) Substituted TaqMan  

Paramters for LNA(TM) Substituted TaqMan Design  
 
Introduction: Beacon Designer designs LNA(TM) substituted TaqMan(R) probes for allele 
discrimination and multiplex assays. LNA(TM) (Locked Nucleic Acid) is a novel class of nucleic 
acid analogues, which are bi cyclic compounds and structurally similar to RNA nucleotides. 
LNA(TM)/DNA or LNA(TM)/RNA duplexes increases thermal stability compared with similar 
duplexes formed by DNA or RNA. In general, the thermal stability of a LNA(TM)/DNA duplex is 
increased by 3/40C to 8/90C per modified base in the oligonucleotide. Beacon Designer designs 
LNA(TM) substituted TaqMan(R) of shorter length and high Tm. 

Parameters for LNA(TM) substitution : Beacon Designer lets you to specify the number of 
bases to be excluded from 5' and 3' end in order to centralize the LNA(TM) in a probe, number of 
LNA(TM) bases to be included in the TaqMan(R) probes and frequency of LNA(TM) substitution 
i.e. distance between two LNA(TM) bases. You can design LNA(TM) substituted TaqMan(R) 
probes for multiplexing, on upto four sequences. The LNA(TM) are substituted as per the values 
of LNA(TM) frequency, LNA(TM) phase off and number of LNA(TM)'s. The probes designed by 
LNA(TM) substitution are shorter in length as compare to standard TaqMan(R) probes and have 
higher Tm values.  

Steps for LNA(TM) substituted TaqMan(R) probe design :  

1. Select the sequence in the Sequence Information table.  
 

2. Select Analyze > TaqMan(R) Search > LNA(TM) or click  button from the toolbar. If 
TaqMan search is launched from toolbar then, select LNA(TM) option. 

3. In TaqMan search dialog there are Primer Parameters tab and TaqMan Parameters Tab. 
Primer design parameters are displayed below the Primer Parameters tab and TaqMan design 
parameters are displayed under TaqMan Parameters Tab.  
 
4. Set the LNA(TM) TaqMan(R) search parameters to meet your experimental requirements.  
 
5. By default, the Avoid Cross Homology option is checked. In this case the primers will be 
designed avoiding homologous regions.  
 
6. By default, the Avoid Template Structure option is checked. The regions of template with 
secondary structure will be avoided while designing primers. If you would like to design primers at 
these default values, the sequence(s) should already be BLASTed and a template search done. 
Otherwise these options should be unchecked before launching a TaqMan(R)search. 

7. When multiple sequences are selected for a multiplex reaction, the primers designed will be 
checked for cross dimers and the best primers with respect to multiplexing will be displayed.  
 
7. If the sequences contain SNP information, the probes will be designed to identify the SNP.  

8. Launch search by clicking the Search.  
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For Example: 

To design a multiplex reaction for detection of four different pathogenic retroviruses:  
1. Select sequences M95491 and AF209198 in the Sequence Information table.  
2. Select Analyze > TaqMan(R) Search > LNA(TM).  
3. In the TaqMan(R) Search Parameters window set all parameters to default. These parameters 
are defined according to TaqMan(R) design guidelines.  
4. Avoid Template Structure, Avoid Cross Homology, and Multiplex options are checked. 
Note, to design primers at these default values, the sequence(s) should already be BLASTed and 
a template search done.  
5. The Search Range for M95491 is restricted to 1 to 1200 bp to design primer pair.  
6. Similarly the Search Range for sequence AF209198 is restricted to 1 to 1048 BP.  
7. By default the Multiplexing option is checked, i.e the program will check the TaqMan(R) probes 
of selected sequences for cross dimers with each other and with all the designed primers. Each 
designed TaqMan(R) probe is always checked for cross dimers with the amplifying primer pair. 

The probe and primer length will range between 14 to 17bases. The target melting temperature of 
the designed TaqMan(R) probe is set 10 oC higher than the primer melting temperature with a 
tolerance of +/- 2 oC. Beacon Designer will search TaqMan(R) probes as close as possible to the 
specified target value of Tm.  
For example: If primer Tm is 59.0 oC, then the target TaqMan(R) Tm will be 69.0 oC and the range 
will be 67.0 oC to 71.0 oC. The TaqMan(R) having Tm equal to target will be given highest priority 
and the TaqMan(R) having a Tm outside this range will not be considered. The optimal primer for 
the same strand as the TaqMan(R) will be designed, such that the 3' end of the primer is within 10 
bases of the probe without overlapping the probe sequence.  
The Advanced search parameters include the maximum acceptable values for secondary 
structures such as self-dimers, hairpins, cross-dimers, repeats, and runs in primers and 
TaqMan(R) probes. The default values for secondary structures are set to ensure high signal 
strength of the designed TaqMan(R). TaqMan(R) probes and primers having values for self-dimer, 
hairpin, cross-dimer, repeats and runs greater than the specified value are discarded.  
Additional parameters such as GC clamp, 3'end stability and maximum difference between primer 
pair Tm are considered for the designed optimum primers. 

8. After setting the parameters for TaqMan(R) design, launch search by clicking Search.  
9. The search quality status will be immediately displayed in the Search Status tab. The detailed 
TaqMan(R) search results will be displayed in the TaqMan(R) Properties tab and the primer search 
results will be displayed in the Primer Properties table along with the primer rating. 
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LNA(TM) Substituted TaqMan(R) Search Results  

As soon as the LNA(TM) substituted TaqMan(R) search is complete the search quality status is 
displayed in the Search Status Tab, followed by the type of assay i.e. “Good – LNA(TM)”. The 
detailed results are displayed in TaqMan(R) Properties Tab and the location of TaqMan(R)on the 
sequence is displayed in the Sequence view. 

1. The displayed results include LNA(TM) substituted TaqMan(R) rating, sequence, position, 
length, probe Tm, GC%, maximum hairpin dG, maximum self-dimer dG, maximum cross-dimer 
dG. In LNA(TM) substituted TaqMan(R) LNA(TM) bases are represented by upper case and DNA 
bases are in lower case, for discrimination between LNA(TM) and DNA bases.  
 
For example :  
In probe sequence ,  
tctGctGgaCgcCctac G and C are LNA(TM) bases. 

2. In the Sequence View, you can view the location of the LNA(TM) substituted TaqMan(R) on the 
sequence but that is not case sensitive. 

3.You can view all possible LNA(TM) substituted TaqMan(R) secondary structures in TaqMan All 
Structure window. 

4. Wild and mutant LNA(TM) substituted TaqMan(R) probes are designed for sequences with a 
SNP selected. The SNP base will be centralized in the probe and will always be a LNA(TM). Other 
bases which will be LNA(TM), depends on the value of number of LNA(TM) base.  
 
Select Alternate TaqMan(R) probe : 

After designing TaqMan(R) you can replace the default TaqMan(R) probe by selecting any other 
TaqMan(R) that meets your research needs better. Other TaqMan(R)probes are available in the All 
TaqMan(R) window.  

1. To view alternate TaqMan(R) probes click the  button.  
 
2. The window displays both the best and alternate TaqMan(R) with their associated primer pair. 
The probe which is displayed under TaqMan Properties tab will be highlighted in All TaqMan 
window.  
 
3. Select any TaqMan(R) in this window. The optimum primer pairs associated with the selected 
TaqMan(R)probe are displayed in the All Primers table. By default the best primer pair will be 
selected. You can select any other primer pair by highlighting it.  
 
4. Click the Replace button.  
 
5. The selected TaqMan(R) probe replaces the default TaqMan(R) probe in the TaqMan(R) 
Properties tab and the selected primer pair will replace the default primer pair. The probe that 
replaces the default probe set will be highlighted by the grey background in the All TaqMan 
window.  
 
Sort TaqMan and Primers: 

In All TaqMan window there will be facility to sort TaqMan probe sense primer, antisense primer 
and product on the basis of rating, position, length, Tm , GC%, Hairpin Delta G value and Self 
dimer delta G values. Sorting is not available on sequence and S.No. 
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Note: Whenever All TaqMan and All primers window will be launched, TaqMan and primers are 
always sorted on the basis of Product rating. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 



 Beacon Designer 5.10 Tutorial 
 

 95

Evaluate LNA(TM) Substituted TaqMan (R)  

Evaluate LNA(TM) Substitued TaqMan (R) 

 

In Beacon Designer, you can add and evaluate pre-designed LNA(TM) substituted TaqMan(R) and 
Primer pairs. Such evaluation would be desirable for:  
a. Adapting SYBR green results to TaqMan(R) assays.  
b. Analysis against other imported TaqMans(R) probes.  
c. Use evaluated TaqMan(R) or Primers as a base for searching primers/TaqMan(R) on other 
targets for multiplexing. 

To evaluate a TaqMan(R) probes and designing optimum primer pair:  
 
1. Select the sequence in the Sequence Information table.  

2. Select Analyze > Evaluate TaqMan(R) > LNA(TM) or click  from the toolbar. The dialog 
launched from the toolbar will have both Standard and LNA(TM) enabled, but Standard selected. 
To evaluate LNA(TM) substituted TaqMan or primer select LNA(TM) option.  
 
3. Select Evaluate TaqMan from the drop-down menu, to evaluate the TaqMan probe and design 
optimized primer pair.  
 
4. Type or paste the TaqMan sequences in the given text field. The primers should always be 
added in the 5' to 3' direction.  
 
Note :  
a. The TaqMan added for evaluation should not have 2 bases from 5' and 3' end as LNA(TM).  

b. Adjacent LNA(TM) substitution is not acceptable during evaluation.  
 
c. LNA(TM) substituted TaqMan evaluation is case sensitive i.e. bases (A,T, G, C) written in upper 
case are considered as LNA(TM) and those written in lower case are normal DNA bases.  
 
5. The default values for Primer Search parameters are set to ensure that the search succeeds in 
finding the most optimum TaqMan(R) probe for the evaluated primer pair. You can change these 
default values to suit your experimental requirements.  

6. Beacon Designer analyzes and rates the added TaqMan Probe. The TaqMan probe is 
analyzed using existing TaqMan search parameters from the TaqMan(R) Search Parameters 
window. 

For example:  

1. Select the sequence AB036365 in the Sequence Information table.  
 
2. Select Analyze > Evaluate TaqMan(R) > LNA(TM) , to launch Evaluate TaqMan(R) window.  
 
3. Select Evaluate TaqMan from the drop-down menu, to evaluate the added probe and design 
optimized primer pair.  
 
4. Paste the following TaqMan sequences:  
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TaqMan : ttgCccAccAccCttt 

5. Set the Primer Search Parameters to Default.  
 
6. Click OK to evaluate the added TaqMan(R) probe.  
 
7. The TaqMan properties are displayed in TaqMan Properties table and the designed primers 
are displayed in the Primer Properties table.  
 
8. To verify the specificity of the evaluated TaqMan, you can BLAST search the primer pair 
against the relevant database using Analyze > BLAST Search > TaqMan option.  
 
7. Detailed BLAST search results are displayed in the default browser. 
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Multiplex LNA(TM) Substituted TaqMan (R) Probes 
 

In Beacon Designer you can design LNA(TM) Substituted TaqMan(R) probes and primers for 
multiplex reactions. The LNA(TM) Substituted TaqMan(R) designed on multiple sequences in a 
single search at default values are automatically checked for cross-dimers with each other and 
with all the designed primers, preventing competition in multiplex reactions.  
 
You can also use the Multiplex TaqMan(R) option to check the multiplexing of LNA(TM) 
Substituted TaqMan(R) probes and primers designed in different search runs.  
In order to multiplex LNA(TM) Substituted TaqMan(R):  
 
1. Select the sequences in Sequence Information table. You can select up to four sequences for 
multiplexing on which LNA(TM) Substituted TaqMan are designed. 

Note : Sequence having different types of TaqMan probes i.e. Standard and LNA(TM) Substitued 
cannot be used for multiplexing.  
 

2. Select View > Multiplex TaqMan(R) or click  from the toolbar.  

3. Beacon Designer instantly anlayzes all the selected sequences and displays the cross-dimers 
that are formed between the LNA(TM) Substituted TaqMan(R) and primers.  
 
4. The multiplex results are displayed instantly in the Multiplex Results Window. 
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Multiplex LNA(TM) Substituted Taqman Assay 
 

Design LNA(TM) Substituted TaqMan probes and primers for multiplex assay 

  

Multiplex PCR is an essential cost saving technique for an endless list of applications including 
large scale genotyping, gene expression, whole genome sequencing, forensic analysis and also 
facilitate the diagnosis of infectious disease.  

 
Multiplex PCR primer design and optimization is a greater challenge than designing singleplex 
PCR primer design. The aim of multiplex is to find many sets of primer that can be used in the 
same PCR reaction to amplify many different sequences simultaneously. Beacon Designer finds 
the multiplex set that matches these criterion by first finding all the acceptable primer pair for 
each of the targets, then testing every combination and giving back those sets that meet the 
criterion.  
 
Here is how to design Multiplex set for Taqman probes and primers for Multiplex assay: 
 
1) Select more than one sequence. 

2) Select Analyze> Multiplex TaqMan® > LNA(TM) or click  button on tool bar. 
3) Set “Multiplex Taqman Search parameters ” to meet your experimental need. You can reset 
the parameters to the default values by clicking Default button.  
4) Specify the Reaction conditions . 
5) Click Search button to launch the search. 
6) After the search is complete results will be displayed in Multiplexing results tab. 
 
For Example:  
1) Select Sequences AB036365 and L22214 from sequence information table. 

2) Select Analyze> Multiplex TaqMan® > LNA(TM) or click  button on tool bar. 
3) Specify the “Multiplex Set Name” BF123.  
4) Check Avoid Template Structure, Avoid Cross homology. 
5) Set “Multiplex Taqman Search parameters ” to meet your experimental need. You can and 
reset the parameters to the default values by clicking the Default button. 
6) The Search Range for AB036365 is restricted to 1-1079 bp, or sequence L22214 is restricted 
to.1-1200 bp to design primer pair. 
7) Set the Reaction conditions to the default values by clicking the Default button. 
8) After setting the parameters for TaqMan® design, launch search by clicking Search. 
9) As soon as search is complete results will be displayed under multiplexing results tab. Under 
this tab, left pane displays multiplexed group and right pane displays sequences corresponding to 
multiplexed group. The best multiplex set for multiplexed group is shown under the TaqMan 
properties tab. 
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Design LNA(TM) Substituted TaqMan probes and primers for Reference Gene 
Multiplexing 

  

Multiplex RT-PCR using reference genes as a positive control against the gene of interest is one 
of the most widely accepted technique used now a days. This involves concurrent amplification of 
the target gene and reference gene.  

Beacon Designer designs Multiplex sets for Taqman probes and primers for reference gene 
multiplexing. Beacon Designer finds the multiplex set that matches these criterion by first finding 
all the acceptable primer pair for each of the targets, then testing every combination and giving 
back those sets that meet the criterion.  

 
Here is how to design Multiplex sets for Taqman probes and primers for reference gene 
multiplexing- 

 
1) Select more than one sequence. 

2) Select Analyze> Multiplex TaqMan® > LNA(TM) or click  button on tool bar. 

3) Specify “Multiplex set name”. 
4) Set “Multiplex Taqman Design parameters ” to meet your experimental need. You can reset 
the parameters to the default values by clicking the Default button.  
5) You can select a reference gene under the “Sequence length range/ reference gene 
selection” segment. Maximum three sequences can be selected as a reference gene. To select 
a sequence as a reference gene it should have pre-designed primers and probes. 
 
Note: Sequences having SNP can be selected as a reference gene. When you select a SNP 
sequence as a reference gene, you need to select either wild probe or mutant probe and selected 
probe will be used for multiplexing.   
Sequences without pre-designed primers and probes cannot be selected as a reference gene 
and will be grayed out. Evaluate Primers and probe to use as a reference gene. 
For selected reference gene amplicon length will be displayed in “Search Range” column and Tm 
of Pre-designed Primer and probe will be displayed in Primer Tm and Probe Tm column. 
6) Specify Reaction conditions. 
Note: When you select a reference gene, reaction conditions for the selected reference gene will 
displayed in reaction condition dialog and will used for multiplexing. 
If you select more than one sequence as a reference gene, then the reaction condition for the all 
the selected reference gene must be identical. 
7) Click Search button to launch the search. 
8) After the search is complete results will be displayed under Multiplexing Results Tab. 
 
For Example  
1) Select Sequences NM_026658, AF209198, AB036365 and L22214 from Sequence 
Information table. 

2) Select Analyze> Multiplex TaqMan® > LNA(TM) or click  button on tool bar. 
3) Specify Multiplex Set NameSet6. 
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4) Check Avoid Template Structure, Avoid Cross Homology.  
5) Set “Multiplex Taqman Search parameters ” to meet your experimental need. You can reset 
the parameters to the default values by clicking the Default button. 
6) Select the NM_026658 sequence as a reference gene. “Length range” for reference gene is 
2220-2346”. Tm of Probe for selected reference gene is 66.9oC and Tm of sense primer and 
antisense primer for selected reference gene is 59.2oC and 59.4oC. displayed under primer Tm 
and probe Tm column. 
7) Reaction condition of NM_026658 will be displayed in reaction condition dialog. 
8) Click Search button to launch the search. 
9) As soon as search is complete results will be displayed under multiplexing results tab. Under 
this tab, left panel displays multiplexed group and right panel displays sequences corresponding 
to multiplexed group. The best multiplex set for multiplexed group is shown under TaqMan 
properties tab. 
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Multiplex Taqman Set Search results 
As soon as Multiplex Taqman Set search is complete, it will automatically switched to Multiplexing 
Results Tab which displays multiplexed group and the corresponding sequences. Under 
multiplexing tab left pane displays Multiplexed group with group status and set rating and right 
pane displays corresponding sequences of the multiplexed group along with their individual 
Taqman and Primer search status. 

 
1) Multiplex sets are displayed under TaqMan properties Tab. 
2) Each multiplex set will display Taqman probe and primers of the individual sequence 
considered while multiplexing. The displayed result include both the sense and antisense primer 
rating, primer sequence, TaqMan® rating, Taqman sequence position, length, melting 
temperature, GC%, maximum hairpin dG, maximum self dimer dG, repeat and run length, 
optimum annealing temperature, maximum cross dimer dG, product length, product Tm., probe 
Tm. 
3) The graphical view of the primer and TaqMan secondary structures is displayed in the 
Secondary Structures window. You can view the primer secondary structures and Taqman 
secondary structure by clicking All Structures option from pop-up menu available at right click 
(For Mac, CTRL+click) on sequence displayed in Taqman Properties tab or by selecting View>All 
Structure > Primers or Taqman. 
 
4) The Secondary Structures window displays the graphical view of all the possible structures for 
dimers, hairpins, cross-dimers, repeats and runs for the selected primer or probe. 
 
5) You can copy the primer and Taqman sequence to the clipboard. Select Edit> Copy> Sense 
primer,antisense primer, Taqman Sequence or select Copy Primer Sequence or Taqman 
sequence option from pop-up menu available at right click (For Mac, CTRL+click) on sequence in 
Taqman Properties tab. 
 
Select Alternate Multiplex Set 
You can replace the default multiplex set with an alternate multiplex set to meet your research 
needs. 

1) To view alternate multiplex set select View > All Multiplex set or click 
 button.  
2) The window displays both the default multiplex set displayed under Taqman Properties Tab 
and alternate multiplex set. The multiplex set which is displayed under Taqman Properties tab will 
be highlighted in All multiplex sets window.  
3) Select any Multiplex Set.  
4) Click the Replace button.  
5) The selected Multiplex set will replace the default multiplex set in the Taqman Properties tab. 
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FRET Probe Design  
Parameter for FRET Probe  

Design FRET Probes  
 
Parameters for FRET Probe Design 
Beacon Designer supports FRET probe design for allele discrimination assays. You can design 
FRET probes for one sequences at a time. You can use the Multiplex FRET Probes option to 
view cross dimerization of FRET Probes and primers designed in different searches. In order to 
design primers first set parameters for FRET Probes design. (The FRET probe and the primers 
are designed simultaneously. In order to design an assay, first set parameters for FRET design.) 

Steps for FRET probe design : 

1. Select the sequence in the Sequence Information table.  

2. Select Analyze >FRET Probes search or click  button from the toolbar.  
3. If necessary set the FRET Probes Search Parameters to meet your experimental 
requirements. You can reset the parameters to default values by clicking the Default button. The 
default values of most of the range parameters are set loosely to ensure that the search 
succeeds in finding the best possible probes and primer pair. These values do NOT affect the 
quality of the resulting primers, they only serve as the minimum and maximum acceptable limits. 
The search algorithm uses the target values or the middle of the range (except for the product 
length and the primer length) to optimize the primers. If the range specified is too narrow, no 
FRET Probes meeting the specifications may result. We recommend the use of default values for 
FRET Probes search.  
4. By default, the Avoid Cross Homology option is checked. In this case, the primers will be 
designed by avoiding regions of significant homologies. By default, the Avoid Template Structure 
option is checked. The regions of template with secondary structure will be avoided while 
designing primers. If you would like to design primers at these default values, the sequence(s) 
should already be BLASTed and a template search completed. Otherwise, these options should 
be unchecked before launching a FRET Probes search.  
5. If the sequences contain SNP information, the primers will be designed to amplify the SNP.  
6. Launch search by clicking the Search button.  
7. The search parameters are saved for future searches. You can reset the parameters to their 
default values by clicking the Default button. The most important point to note is that the FRET 
probes are designed near the 5’ end of the target strand (i.e., as far as possible from the 5’ 
primer-binding site on the same strand), but not overlapping the primer-binding site on the 
opposite strand. They are also checked for secondary structures, and cross hybridization to 
ensure high signal fidelity. 

Note: If the sequence has an SNP that has been selected, Beacon Designer will design both wild 
and mutant Sensor probes for the sequence. To overlook the SNP information while designing 
FRET probes, click the Unselect SNP button in the SNP Information tab or delete the existing 
SNP using Delete SNP.  

For Example: 

1. Select a sequence Y13051 in the Sequence Information table.  
2. Select Analyze >FRET Probes search.  
3. In the FRET Probes Search Parameters window set all parameters to default. These 
parameters are defined according to FRET Probes design guidelines.  
4. Avoid Template Structure and Avoid Cross Homology options are checked.  
Note: to design primers at these default values, the sequence should already be BLASTed and a 
template search completed.  
5. The Search Range for Y13051 is restricted to 2339 to 3520 bp to design primer pair to amplify 
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Human T-cell psychotropic virus type 2 reverse transcripts 'pol' gene  
6. Each designed FRET probe is always checked for cross dimers with the amplifying primer pair.  
7. The probe and primer length will range between 18 to 22 bases. The target melting 
temperature of the designed FRET probes is set 8 oC higher than the primer melting temperature 
with a tolerance of +/- 3 oC. Beacon Designer will search FRET probes with Tim compatible as 
closely as possible to the specified target value of primer Tm. For example: If primer Tm is 55.0 

oC, the target FRET Probes Tm will be 63.0 oC and the range will be 61.0 oC to 65.0 oC. The 
FRET Probes with Tm equal to the target value will be given highest rating and the FRET Probes 
with Tm's outside this range will not be considered. The optimal primer for the strand with FRET 
Probes will be designed, so that the FRET probes are designed near the 5’ end of the target 
strand (i.e., as far as possible from the 5’primer-binding site on the same strand), but not 
overlapping the primer-binding site on the opposite strand. The 3' end of the primer is within 10 
bases of the probe without overlapping the probe sequence. The Advanced search parameters 
include the maximum acceptable values for secondary structures such as self-dimers, hairpins, 
cross-dimers, repeats, and runs in primers and FRET probes. The default values for secondary 
structures are set to ensure high signal strength. FRET Probes and primers with values for self-
dimer, hairpin, cross-dimer, repeats and runs greater than the specified value are discarded. 
Additional parameters such as GC clamp, 3'end stability and maximum difference between primer 
pair Tm are considered when designing primers.  
8. After setting the parameters for FRET Probes design, launch search by clicking the Search 
button.  
9. The search quality status will be instantly displayed in the Search Status tab. The detailed 
FRET Probes and primer search results will be displayed in their respective Properties tabs. 
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FRET Probe Search Results 
As soon as the FRET Probe search is complete the search quality status is displayed in the 
Search Status Tab, the detailed results are displayed in FRET Probe Properties Tab and the 
location of FRET Probe on the sequence is displayed in the Sequence view. 

1. Wild and mutant FRET Probes are designed for sequences with a SNP selected. The best 
FRET Probe whether sense or antisense, is designed for sequences without a SNP selected.  
2. The displayed results include FRET Probe rating, sequence, position, length, probe Tm, GC%, 
maximum hairpin dG, maximum self-dimer dG, maximum cross-dimer dG.  
3. You can view all possible FRET Probe secondary structures in  
View Secondary Structures window.  
4. In the Sequence View, you can view the location of the FRET Probe on the sequence .  
5. You can copy the FRET Probe sequences to the clipboard. Select Edit > Copy > FRET Probe 
Sequences or select Copy FRET Probe sequences option from pop-up menu available at right 
click (For Mac, CTRL+click) over the FRET Probe sequence. 

Select Alternate FRET Probes: 

After designing FRET Probe you can replace the default FRET Probes by selecting any other 
FRET Probe set that meets your research needs better. Other FRET Probes are available in the 
All FRET Probe window. 

1. To view alternate FRET Probe probes click the  button.  
2. The window displays both the alternate FRET Probes and the associated primer pair. The 
probes are displayed in the order of their rating in the upper half of the window.  
3. Select any FRET Probe in this window. The optimum primer pairs associated with the selected 
FRET Probes are displayed in the All Primers table.  
4. By default the best primer pair will be selected. You can select any other primer pair by 
highlighting it.  
5. Click the Replace button.  
6. The selected FRET Probes replace the default FRET Probe in the FRET Probe Properties tab 
and the selected primer pair will replace the default primer pair. 

Sort FRET Probes:  

In All FRET window there will be facility to sort FRET probe on the basis of rating, position, 
length, Tm , GC%, Hairpin Delta G value and Self dimer delta G values of Probe 1 and Probe 2. 
Sorting is not available on sequence and S.No. 

Note: Whenever All FRET window will be launched FRET Probes are always sorted on the basis 
of Probe 1 rating. 
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Evaluate FRET Probes 
 

Evaluate FRET Probes 
 
In Beacon Designer, you can add and evaluate pre-designed FRET Probes and Primer pair. Such 
evaluation would be desirable for:  
a. Adapting SYBR(R) green results to FRET probe assays.  
b. Analysis against other imported FRET probes.  

To evaluate a FRET probes and designing optimum primer pair:  

1. Select the sequence in the Sequence Information table.  
 

2. Select Analyze > Evaluate FRET or click  from the toolbar.  
3. Select Evaluate FRET Probe Pair from the drop-down menu, to evaluate the added FRET 
probe pair and design optimized primers.  
4. Type or paste the FRET probe sequences in the given text field. The probes should always be 
added in the 5' to 3' direction.  
5. The default values for Primer Search parameters are set to ensure that the search succeeds in 
finding the most optimum primer pair for the evaluated FRET probes. You can change these 
default values to suit your experimental requirements.  
6. Beacon Designer analyzes and rates the added FRET probe pair. The probe pair is analyzed 
using existing probe search parameters from the FRET Probe Search Parameters window. 

Note: To evaluate the primers designed in the SYBR (R) Green mode check the Use SYBR(R) 
Green Primers Option with the Primer pair selected from the drop-down menu in the Evaluate 
box. The primer pair in the primer properties tab of the SYBR (R)

 Green would be evaluated. 

For example:  

1.Select the sequence AB031207 in the Sequence Information table.  
2. Select Analyze > Evaluate FRET, to launch Evaluate FRET window.  
3. Select Evaluate FRET Probe Pairs from the drop-down menu, to evaluate the added FRET 
probe pair and design optimized primer pair.  
4. Paste the following probe sequences: Probe 1: 5'AGGCTTAACCATTATCCACCATGCTTAGA 
3', Probe 2: 5'CCAACTCTAACCATGACTCGGACCTG 3'.  

5. Set the Primer Search Parameters to Default.  
6. Click OK to evaluate the added FRET probe pairs and design optimum primers. Beacon 
Designer analyzes and rates these probes using existing probe search parameters, which are 
currently set as default. The probe properties are displayed in FRET Properties table and the 
designed Primer pair Properties are displayed in the Primer Properties Tab.  

7. To verify the specificity of the evaluated probe pair, you can BLAST search the probe pair 
against the relevant database using Analyze > BLAST Search > Probe, option.  
8. Detailed BLAST search results are displayed in the default browser. 

. 
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Multiplex FRET Probes 
Evaluate Probes;  
You can also use theMultiplex FRET Probesoption to check the multiplexing of FRET probes 
and primers designed on a sequence.  
In order to multiplex FRET:  
1. Select the sequence in Sequence Informationtable. You can select one sequence for 
multiplexing.  

2. Select View > Multiplex FRET Probes or click  from the toolbar.  
3. Beacon Designer instantly analyzes the selected sequence and displays the cross-dimers that 
are formed between its FRET Probes and primers.  
4. The multiplex results are displayed instantly in the Multiplex Results Window. 
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SYBR (R) Green Primers Design 
SYBR Green  

Parameters for Primer Design 
Beacon Designer supports primer design for SYBR(R)) Green assays. You can either design 
primers for a sequence or evaluate pre-designed primer pairs. The primers designed are 
automatically checked for cross-dimer formation, preventing competition and mispriming. In 
SYBR(R)) Green Primer design mode you can design primers on more than one sequences at a 
time for a given set of design parameters. The primers designed simultaneously on more than 
one sequences are not intended for multiplex reactions. 

Set Parameters for Primer Design: 

To design primers for selected sequence(s) in Beacon Designer:  

1. Open the sequence(s) in the current project.  

2. Select the sequence(s) and choose Analyze >Primer Search or click  button from the 
toolbar.  
3. Set the primer search parameters to meet your research needs. You can reset the parameters 
to default values by clicking Default. The default values of most of the range parameters are set 
loosely to ensure that the search succeeds in finding the best possible primer pair. The search 
algorithm uses the target values or the middle of the range (except for the product length and the 
primer length) to search for the best primers. If the range specified is too narrow, no primers 
meeting the specifications may result. We recommend using default values for primer search.  
4.By default the Avoid Cross Homology option is checked. The primers will then be designed 
avoiding regions of significant homologies. Similarly, the Avoid Template Structure option is 
checked and by default, significant template secondary structures which may hinder the primers 
from annealing are identified and avoided.  
To design primers at these default values, the sequence(s) should already be BLASTed and a 
template search completed. You may choose to skip these steps and design primers without 
avoiding cross-homology and/or template secondary structures. Simply uncheck these options in 
the Primer Search window before launching a search. 

5.When multiple sequences are selected, the primers in the pool will be designed simultanuously 
on all the sequences but without multiplexin and the primers best suited will be displayed.  
6.If the sequence(s) contain SNP information, the primers will be designed to amplify the SNP.  
7.Click Search to launch a search.  
8.Primer search parameters are saved for future searches.  

For example: 

1.Select sequence L22214 in the Sequence Information table. 

2.In order to design primers avoiding template secondary structures, the sequence should be 
evaluated for presence of stable secondary structures by folding it by connecting to the Quikfold 
server.  

3. To launch Template Structures dialog select Analyze> Template Structures or click  from 
the toolbar.  

4. Set template Search Range as from 1000 to 2100, for the sequence for which primers are to 
be designed.  

5. BLAST search the sequence against a suitable database by selecting Analyze> BLAST 
Search > Sequence.  
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6. Now proceed to design primers for the sequence, select Analyze >Primer Search or click  
from the toolbar.  

7. Set the Primer Search Parameters to their default values.  

8. The Search Range for sequence L22214 is restricted to, 1000 to 2100 bp, spanning Human 
adenosine A1 receptor (ADORA1) mRNA exons 1-6 complete cds. 

9. Avoid Template Structure, and Avoid Cross Homology.  

10. Click Search to launch a search.  

11. As soon as the primer search is complete, the properties of the designed primer are displayed 
in the table under the Primer Properties tab with both, the individual and primer pair rating. The 
primer rating quantifies the merit of primer with reference to the search parameters. A primer 
rating of 100 indicates that the primer exactly matches the specified search parameters. 

Note: You can select multiple sequences and design primer. The primers designed are not 
intended for multiplex reactions. 
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Primer Search Results 
 
As soon as the primer search is complete the search quality status is displayed in the Search 
Status Tab and the detailed result is displayed in the Primer properties table under Primer 
Properties tab. 

1. The displayed result include both the sense and antisense primer rating, primer sequence, 
position, length, melting temperature, GC%, maximum hairpin dG, maximum self dimer dG, 
repeat and run length, optimum annealing temperature, maximum cross dimer dG, product 
length, product Tm.  
2. You can view all possible primer secondary structures in View Secondary Structures window.  
3. In the Sequence View, both sense and antisense primer positions are marked on the 
sequence.  
4. You can copy the primer sequence to the clipboard. Select Edit>Copy>Primer Sequence or 
select Copy Primer Sequence option from pop-up menu available by right clicking (for Mac, 
CTRL+click) the primer sequence.  

Example: 

1. The primer search result for sequence L22214 displays sense and antisense primers along 
with the free energy values for secondary structures and product properties.  
2.You can view the graphical view of all the primer secondary structures in Secondary Structures 
window by clicking All Structures option from pop-up menu available by right clicking (for Mac, 
CTRL+click) the Primer Properties table or by selecting View>Alternate>Primers. 

You can replace the default primer pair with an alternate primer pair to meet your research needs.  

1. Properties of the alternate primers and primer displayed under Primer Properties Tab are 
displayed in the All Primers window. The window displays both the default primer pair displayed 
under Primer Properties tab. The primer pair which is displayed under Primer Properties tab will 
be highlighted in All Primer window.  
2. Select any primer pair.  
3. Click the Replace button.  
4. The selected Primer replaces the default primer pair in the Primer Properties tab The primer 
pair that replaces the default primer set will be highlighted by the grey background in the All 
Primer window. 

Sort Primers: 

In All Primers window there will be facility to sort sense primer, antisense primer and product on 
the basis of rating, position, length, Tm , GC%, Hairpin Delta G value and Self dimer delta G 
values. Sorting is not available on sequence and S.No. 

Note: Whenever All Primers window will be launched primers are always sorted on the basis of 
Product rating. 
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Evaluate Primers 

Evaluate Primers 
In Beacon Designer, you can add pre-designed primers instead of designing primers using the 
program. This is useful when you already have primers in your lab or are working with published 
primer sequences.  
To add and evaluate a primer pair for a sequence:  
1. Select the sequence in the Sequence Information table.  

2. Select Analyze > Evaluate Primers or click  (In the SYBR(R) Green Primers Design mode 

click ) button from the toolbar, to launch the Evaluate Primers window.  
3. Type or paste the primer sequences in the given text field. The primers should always be 
added in the 5' to 3' direction.  
4. Beacon Designer analyzes and rates the added primers. The primers are analyzed using 
existing primer search parameters from the Primer Search Parameters window. 

For example:  
1. Select the sequence AB036365.  
2. Add the following primer sequences:  
Sense Primer: 5' TGTCTGCATGTACCTCTACC 3'.  
Antisense Primer: 5' AGTTCTTCTATTCGCTTGTAGG 3'.  
Beacon Designer analyzes and rates these primers using existing primer search parameters, 
which are currently set as default. The primer properties are displayed in Primer properties table.  
3. To verify the specificity of the evaluated primer pair, you can BLAST search the primer pair 
against the relevant database using Analyze>BLAST Search>Primer Pair/Amplicon.  
4. Detailed BLAST search results are displayed in the default browser. 
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Generate Report 
Report;  

Generate Report 
Beacon Designer can export the design results in a report format that can be printed. The report 
includes the results, the design parameters used and a graphical view of sequence with positions 
of all the primers and probes marked apart from the amplicon, sequence, primer and probe 
properties. The user may select the data that needs to be included in the report by checking or 
un-checking the boxes of the corresponding fields. 

The Print Preferences window is launched when you select File>Generate Report or click  

Icon   on tool bar  

Probe:  

Properties: This include the Quality, Rating, Position, Length, Tm, Probe Tm, Self Dimer dG, 
Hairpin dG, Run/Repeat Length, Cross Dimer multiplex dG. A user may select the fields to be 
included in the report with the help of check boxes of the corresponding fields. 

Primer Pair: 

Properties: There are two. In the Primer tab a user can specify the primer pair properties and in 
the Product tab the amplicon properties to be included in the report. 

Search Parameters: 

Select Corresponding parameters: Default: unselected. When selected, only the parameters 
corresponding to the selected properties used for designing the assay  will be included in the 
report. 

Select all Parameters: Default: Unselected. When selected, all the parameters  used for 
designing the assay, will be included in the report. 

None: Default: Selected. None of the parameters used for designing the assay, will be included in 
the report. 

Include BLAST Parameters: Default: Unchecked. If the sequence is BLAST searched the 
search parameter details will be included in the report. 

Sequence Information: Information pertaining to the sequence such as Accession no., 
Definition, Length and SNP. 

Advanced Project Information: 

Project Information: 

Author: You may specify a name to be included in the report. 

Comments: To add notes, observation or comments about the experiment. 

Note: You can generate the report for multiplex Set  

Here is how you can generate the report for multiplex set 

1) Select Multiplexed group for which report is to be generated. 
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2) Select File> Generate report  

3) Generate report dialog will be launched. 

4) Select the parameters which needs to be included in the report. 

5) Click Ok. 

Formated Report will be launched.  
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Print Preview 

 To preview the appearance of the generated report 

You can click Print Preview to see how a printed Web page will look. 

1.Select File>Generate Report or click   icon from tool bar  

2.Report Preference dialogis launched. 

3.Click Print Preview Button. 

4. Choose from the following commands:  

Click This Tool Bar To Do This 

Save  
Saves the generated report. Report can be saved as either.bdr or 
.html file format. 

Print  Set printing options and print the page. 

Page Setup  
Change paper, headers and footers, orientation, and margins for 
this page. 

First page  Display the first page to be printed. 

Previous 
page  Display the previous page to be printed. 

Next  Display the next page to be printed. 

Last  Display the last page to be printed. 

Zoom in  Increase the magnification.  

Zoom out  Decrease the magnification.  

Default Size   Display the default size of the page. 

Help  Display the help for print preview. 

Close   Close the Print Preview window.  
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Export Results 

Export Beacon Search Results 
Beacon Designer can save the beacon and associated primer search results outside the program 
by selecting the Export Beacon Results option.  
The results are exported in a Tab delimited file that can be loaded into any spreadsheet such as 
MS Excel and Lotus 123 for printing or further processing. 

 To Export the Beacon Search Results:  
1. Select one or more sequences in the Sequence Information table.  

2. Choose File > Export Beacon Results or click  button from the toolbar. Beacon Designer 
saves the output file with a .xls extension registered to Microsoft Excel and with .csv extension for 
opening in any other spreadsheet program.  
 
3. Beacon Designer has three option for exporting Beacons and Primers : 

a. Best Beacon and Primer - At default this will be selected. Selecting this option wil let you 
export Beacon and associated primer displayed under Beacon Properties tab.  
b. Best Beacon and All Primers - Selecting this option will let you export Beacon displayed 
under Beacon Properties tab and all the primer pair associated with this Beacon.  
c. All Beacons and All Primers - Selecting this option will let you export All Beacon designed on 
sequence and all primer pair associated with the Beacons.  
 
4. At default, Beacon Designer creates the output file in the Beacon Designer installation folder. 
You can select the output file name and location in the Export Result window.  
 
5. At default, the Beacon search results include beacon quality, rating, position, length, beacon 
Tm probe Tm, free energy values of most stable beacon secondary structures and complementary 
beacon sequence.  
 
The primer search results include pair quality, pair rating, product length, product Tm, TaOpt and 
primer location, primer sequence and free energy values of the most stable secondary structures 
for both the sense and the antisense primers. Sequence definition and length can also be 
exported.  
 
The Export Result window allows you to select any or all of the available data using the 
appropriate check boxes. 
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Export TaqMan(R) Probes Result  

 

Beacon Designer can save the TaqMan(R) probe and associated primer search results outside the 
program by selecting the Export TaqMan(R) Results option.  
The results are exported in a Tab delimited file that can be loaded into any spreadsheet such as 
MS Excel and Lotus 123 for printing or further processing. 

 To Export the TaqMan(R) Probe Search Results:  
1. Select one or more sequences in the Sequence Information table.  

2. Choose File > Export TaqMan(R) Results or click  button from the toolbar. Beacon 
Designer saves the output file with a .xls extension registered to Microsoft Excel and with .csv 
extension for opening in any other spreadsheet program.  
 
3. Beacon Designer has three option for exporting TaqMan probes and Primers : 

a. Best TaqMan(R) and Primer - At default this will be selected. Selecting this option wil let you 
export TaqMan(R) probe and associated primer displayed under TaqMan(R) Properties tab.  
b. Best TaqMan(R) and All Primers - Selecting this option will let you export TaqMan(R) 

displayed under TaqMan(R )Properties tab and all the primer pair associated with this TaqMan(R).  
c. All TaqMan(R) and All Primers - Selecting this option will let you export All TaqMan(R) 

designed on sequence and all primer pair associated with the TaqMan(R).  
 
4. At default Beacon Designer creates the output file in the Beacon Designer installation folder. 
You can select the output file name and location in the Export Result window.  
 
5. At default the TaqMan(R) search results include TaqMan(R) quality, rating, position, length, 
TaqMan(R) Tm, %GC, free energy values of most stable TaqMan(R) secondary structures.  
 
The primer search results include pair quality, pair rating, product length, product Tm, TaOpt and 
primer location, primer sequence and free energy values of the most stable secondary structures 
for both the sense and the antisense primers. Sequence definition and length can also be 
exported.  
 
The Export Result window allows you to select any or all of the available data using the 
appropriate check boxes. 
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FRET Probes Result Export 

 
Beacon Designer can save the FRET probes and associated primer search results outside the 
program by selecting the Export FRET probes Results option. The results are exported in a Tab 
delimited file, ready for loading into any spreadsheet such as MS Excel and Lotus 123 for printing 
or further processing. 

To Export the FRET probes Search Results:  

1. Select one or more sequences in the Sequence Information table.  

2. Choose File > Export FRET probes Results or click  button from the toolbar. Beacon 
Designer saves the output file with .xls extension registered to Microsoft Excel and with .csv 
extension for opening in any other spreadsheet program.  

3. Beacon Designer has three option for exporting FRET probes and Primers : 

a. Best FRET and Primer - At default this will be selected. Selecting this option wil let you export 
FRET probe and associated primer displayed under FRET Properties tab.  
b. Best FRET and All Primers - Selecting this option will let you export FRET displayed under 
FRET Properties tab and all the primer pair associated with this FRET .  
c. All FRET and All Primers - Selecting this option will let you export All FRET designed on 
sequence and all primer pair associated with the FRET.  

4.At default Beacon Designer creates the output file in the Beacon Designer installation folder. 
You can select the output file name and location in the Export Result window.  

5.At default the FRET probes search results include FRET probes quality, rating, position, length, 
FRET probes Tm, %GC, free energy values of most stable FRET probes secondary structures. 
The primer search results include pair quality, pair rating, product length, product Tm, TaOpt and 
primer location, primer sequence and free energy values of the most stable secondary structures 
for both the sense and the antisense primers. Sequence definition and length can also be 
exported.  
 
The Export Result window allows you to select any or all of the available data using the 
appropriate check boxes. 
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SYBR (R) Green primers Result Export 

 

Beacon Designer can save the SYBR (R) Green primers search results outside the program by 
selecting the Export SYBR (R) Green primers Results option. The results are exported in a Tab 
delimited file that can be loaded into any spreadsheet such as MS Excel and Lotus 123 for 
printing or further processing. 

 To Export the SYBR(R) Green Primer Search Results:  

1. Select one or more sequences in the Sequence Information table.  
 

2. Choose Export the SYBR(R) Green Primer Results or click  button from the toolbar. 
Beacon Designer saves the output file with a .xls extension registered to Microsoft Excel and with 
.csv extension for opening in any other spreadsheet program.  
 
3. Beacon Designer has three option for exporting FRET probes and Primers : 

a. Best SYBR(R) Green Primer - At default this will be selected. Selecting this option wil let you 
export primers pair displayed under Primer Properties tab.  
b. All SYBR(R) Green Primer Primers - Selecting this option will let you export primers pair 
designed on sequence.  
 
4.At default Beacon Designer creates the output file in the Beacon Designer installation folder. 
You can select the output file name and location in the Export Result window.  
   
5.At default the SYBR(R) Green primers search results include primer sequence, quality, rating, 
position, length, primer Tm, %GC, free energy values of the most stable secondary structures for 
both the sense and the antisense primers.  
 
The primer pair search results include pair quality, pair rating, product length, product Tm, TaOpt 
and primer location. Sequence definition and length can also be exported. The Export Result 
window allows you to select any or all of the available data using the appropriate check boxes. 
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Export Multiplex Set 
 
Beacon Designer can save Multiplex Taqman set search results outside the program by selecting 
the Export Multiplex Set Results option. The results are exported in a Tab delimited file that can 
be loaded but into any spreadsheet such as MS Excel and Lotus 123 for printing or further 
processing.  

To Export the Multiplex Taqman Set results: 
1) Select one or more than one multiplexed group. 

2) Select File> Export > Multiplex Set or click  button from tool bar. 
3) Select either Best or All option. 
4) Select a format to export of multiplex sets. 
5) Select Browse. 
6) Select the location and specify the name of the file. 
7) Click Save action. 
8) Click Ok action.  
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Preferences 
 

Reaction Conditions 
Beacon Designer designs optimal primers based on standard reaction conditions. You can view 
and change the reaction conditions by selecting Tools>Reaction Conditions. 

The following are the default reaction conditions: 

Nucleic acid concentration: Default value = 0.25 nM. The concentration of nucleic acid needed 
for this calculation is neither the template concentration nor the primer concentration. Rather, it is 
based on the fluctuating concentration of the PCR product. The authors of the original paper, 
Rychlik et al., also experienced the same difficulty, "Knowing what concentration to use for c in 
the case of a PCR experiment, however, is problematical: the concentration of template changes 
dramatically during the course of the PCR." In the original paper, a concentration of c = 0.250 nM 
was used. We have experimentally confirmed (unpublished results) that this works well in a wider 
range of primer applications. The program is set to this default concentration. 

Monovalent concentration: Default value = 50 mM. This value is the concentration of all the 
monovalent ions present in the reaction mixture.  

Note: Whitehead/ MIT Center for Genome Research uses the nucleic acid concentration of 50 
nM along with salt concentration of 50 mM, which result in very similar Tm values. 

Free Mg++ ion concentration: Default value = 3.0 mM for beacon, and 5.0 mM for TaqMan® 
design. This is the concentration of Mg++ ions, used as binders, in a reaction mixture.  

The program computes total Na[+] equivalent concentration and displays it. The value with 
default settings is 269.09 mM for beacon and 332.84 mM for TaqMan® design. 

Temperature for free energy calculation: Default value = 25 oC. This is the value of 
temperature that will be used to calculate the dG values. It is calculated using the formula dG = 
dH - T * dS. 

Temperature for Beacon free energy calculation: Default value = 55 oC. This is the value of 
temperature that will be used to calculate the dG values.  
 
 

 
Setting;  
Internet  
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Technical Information 

Internet Setting 
Beacon Designer has strong web integration. The program connects to NCBI Entrez and dbSNP 
for retrieving sequences online. It uses Quikfoldserver for calculating beacon Tm and determining 
the template secondary structures and BLAST search the selected sequences by connecting to 
NCBI BLAST server. 

Beacon Designer supports both direct Internet connection and Internet connection through a 
proxy server. If your organization has a firewall, Beacon Designer may need to go through a 
proxy server before connecting you to the Internet. The proxy server acts as an intermediary 
between your internal network (Intranet) and the Internet for retrieving files from remote web 
servers. 

To set Beacon Designer to work with a proxy Internet connection: 

1. From the Online menu, choose Internet Settings. 

2. In the Proxy Server section check the 'Use a Proxy Server' option. 

3. Add the proxy server's host name or IP address under "Address". 

4. Add the proxy server's port number under "Port". 

5. Click OK to save the settings. 

Verify Proxy Internet Settings 

Beacon Designer allows you to verify your Internet connection and proxy settings. 

To verify proxy Internet settings: 

1. Set Beacon Designer to work with a proxy Internet connection (as discussed above). 

2. Click "OK". The program will prompt you to verify proxy Internet settings. 

3. Click "Yes" to verify connection. For Internet connection setting verification, program will 
attempt to connect to NCBI server. 

4. If the proxy server is password protected, the program will automatically detect the proxy 
server setting and ask you to authenticate the connection by specifying a User Name and 
Password.  
 
Note: If the proxy server uses a domain name for authentication as well, the domain name must 
be entered in the user name text field in domain-name\user-name or user-name@domain-name 
format. 

5. In the Authenticate Proxy window, specifyUser Name and Password. The fields are case 
sensitive. 

6. If Beacon Designer fails to establish a connection with the NCBI server, a warning message is 
displayed and the program prompts you to correct proxy Internet setting information. 

If you proceed without verifying the proxy Internet setting the Internet settings will be verified the 
first time you try to load sequence from Entrez. 

Note: The Internet setting is similar to the Proxy server setting used in Internet Explorer.  
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Automatic Product Upgrade 
Product Upgrade;  
We frequently publish new versions of our products which contain fixes for reported problems and 
contain improvements over previous versions. These are available free of charge to our 
customers and may be downloaded from our web site.  

Beacon Designer's intelligent updater automatically detects the availability of a free upgrade and 
installs it on your computer. 

Whenever you launch the program, an upgrade message will pop-up if a free upgrade is available 
on our web site. This message includes a brief description of the upgrade, a link for its detailed 
description, and its size in MB. 

You may choose to upgrade according to your convenience. Click Now to start updating the 
version currently installed or click Later to upgrade at some convenient time. Check option Do 
not remind me again to stop checking for automatic upgrades.  

Once your program is upgraded please relaunch the program .  

If you have stopped the automatic checking of free upgrades, select Help>Check Upgrade menu 
option to check for a free upgrade manually.  

To confirm the build number of the program installed on your own computer:  

Select Help> About Beacon Designer menu option if you use Windows.  
Select Beacon Designer> About Beacon Designer menu option if you use Mac. 
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Standalone WWW BLAST for Linux 
 
Standalone WWW BLAST Server is available for UNIX/Mac OS X web servers. The following 
steps are necessary to set up a Standalone WWW BLAST server on Linux: 

Install RedHat Linux Server 

Setup Firewall 

Setup Apache webserver 

Download BLAST Binaries 

Install Standalone WWW BLAST Server 

Setup Standalone WWW BLAST Server 

Format databases 

Update Standalone WWW BLAST Server configuration files 

System Requirements 

Troubleshooting  
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Install RedHat Linux Server 
Local  
You can skip this step, if you have a RedHat Linux Server already installed.  
Beacon Designer and Standalone WWW BLAST server are tested with RedHat Linux webserver 
successfully.  
Beacon Designer and Standalone WWW BLAST server may work with other UNIX Apache 
webservers also.  
RedHat Linux server is downloadable from the RedHat Linux Homepage.  
Please download RedHat Linux 7.1 from  
ftp://ftp.redhat.com/pub/redhat/linux/7.1/en/  
For Firewall setup for RedHat Linux 7.1, please refer the Setup Firewall section.  
Please download RedHat Linux 7.2 from  
ftp://ftp.redhat.com/pub/redhat/linux/7.2/en/  
For Firewall setup for RedHat Linux 7.2, please consult your System administrator.  
 
For further information, please refer http://www.redhat.com/software/linux/ 
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Setup Firewall 
Firewall set up for RedHat Linux ver 6.2, 7.0 or 7.1  
 
1. Check Firewall setup  
Run the following command (at the command prompt)  
ipchains -L  
If you find  
input Policy REJECT  
output Policy REJECT  
forward Policy REJECT  
The result shows that the Firewall is working and your server will not listen to any client. You 
should set the Firewall rules so that the server will respond to clients.  
2. Disable Firewall  
If you want to give access to your Linux server and do not have any security risks then you can 
disable the ipchains service using the following command at command prompt:  
ntsysv  
Look for the ipchains service in the services scroll box and remove " * " against it by pressing the 
"spacebar".  
3. Set up restricted Firewall  
If you want to give restricted access of your Linux server then update the ipchains file with the 
help of your system administrator.  
ipchains file is available at "/etc/sysconfig/ipchains"  
 
After the Firewall setup, set up the Apache server. Apache is basically a webserver, which is 
required for accessing any web page like Standalone WWW BLAST. 
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Setup Apache webserver 

Local  
Apache is open source HTTP server for UNIX, OS/2, Windows and other platforms . It is available 
as a built-in server in all the versions of the RedHat Linux server. Apache is a well known internet 
webserver. It listens and forwards the client request to the Server. For e.g., Apache enables client 
applications (such as Beacon Designer) to execute Local BLAST at the server. The inbuilt 
Apache version for RedHat Linux 7.1 is 1.3.19. To set up the Apache webserver, it requires a 
change in the httpd.conf file. The default location of httpd.conf file is "/etc/httpd/conf/httpd.conf".  
 
Following are the directives to be setup in the httpd.conf file  
1. ServerName  
2. Port information  
3. Listen ports  
4. DocumentRoot  
5. Start and stop commands for Apache  
# indicates comment lines. These lines are provided for easy location of the command lines. 

1. ServerName  
#  
# ServerName: It allows you to set a host name which is sent back to clients for your  
# server if it's different than the one the program would get (i.e., use "www" instead of  
# the host's real name).  
#  
# You will have to access it by its address (e.g., http://192.168.30.3) anyway.  
#  
ServerName <your machine IP address>  
Example:  
Servername 192.168.30.3  
Server / Client machine IP address troubleshooting  
To find your machine IP address please type 'ifconfig' at the command prompt. Please refer to the 
troubleshooting section for complete details.  
 
2. Port information  
#  
# Port: The port to which the standalone server listens. For ports < 1023, you will need  
# httpd to be run as root initially.  
# Change this port, if this port is being used by other application.  
Port 80  
 
3. Listen port  
#  
# Listen: Allows you to bind Apache to specific IP addresses and/or ports, in addition  
# to the default. See also the <VirtualHost> directive. If you have changed port number  
# in step no. 2 then add this port to Listen directive also.  
# Listen 3000  
Listen <IP address:Port>  
Example:  
Listen 192.168.30.3:80  
 
4.DocumentRoot  
#  
# DocumentRoot: The directory out of which you will serve your documents. By default,  
# all requests are taken from this directory, but symbolic links and aliases may be  
# used to point to other locations.  
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#  
DocumentRoot <"Path of your document root directory">  
Example:  
DocumentRoot "/home/administrator/document"  
Find directory directive for DocumentRoot. This starts as  
#  
# This should be changed to whatever you set DocumentRoot to.  
#  
<Directory "Path of your document root directory end with/">  
Example  
<Directory "/home/administrator/document/">  
 
5. Start and stop command for Apache webserver  
Save the httpd.conf file with all those changes in above steps.  
Use following commands for start, stop and restart the Apache webserver  
Start Apache webserver : /etc/rc.d/init.d/httpd start  
Stop Apache webserver : /etc/rc.d/init.d/httpd stop  
Restart Apache webserver : /etc/rc.d/init.d/httpd restart  
Note : If httpd.conf is modified, then only use restart command instead of start.  
 
Test Apache webserver setup  
To check Apache webserver,create a testapache.html file in your DocumentRoot directory (e.g. 
"/home/administrator/document") and paste or enter following html in it :  
<html>  
<title> Apache setup testing </title>  
<body>  
Hello from Apache Webserver  
</body>  
</html>  
Now access this file with your default web browser by writing following address in browser  
http://Your Linux Machine Server IP Address/testapache.html  
Example  
http://192.168.30.3/testapache.html  
The page should show the following content "Hello from Apache Server". If you face difficulties in 
setting up the Apache webserver please refer to Apache Webserver set up troubleshooting. 

Download BLAST Binaries 
Local Binaries;  
Connect to the NCBI server as an anonymous user via ftp link 
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/ Download the wwwblast-xxx-xxx-Your_platform.tar.gz 
from "LATEST_WWWBLAST" folder. For example for Linux platform, download "wwwblast-xxx-
xxx-Linux.tar.gz" file.  
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Install Standalone WWW BLAST Server for Linux,  
 
After downloading the file "wwwblast-xxx-xxx-Your_platform.tar.gz", place it in the document 
directory of HTTPD server. (Document root directory set up at the time of Apache config file 
httpd.conf ) and uncompress it by :  

gzip -d wwwblast-xxx-xxx-Your_platform.tar.gz  
tar -xvpf wwwblast-xxx-xxx-Your_platform.tar  
 
Note : Access options stored in the distribution that parameter "p" in tar options is significant. It 
will preserve file access options stored in the distribution.  
 
For Linux platform, the commands are:  
gzip -d wwwblast-xxx-xxx-Linux.tar.gz  
tar -xvpf wwwblast-xxx-xxx-Linux.tar  
If the distribution file is uncompressed successfully, a 'blast' directory will be created in the 
DocumentRoot directory (e.g. "/home/administrator/document" directory). 

Download Format db  
 
Extract BLAST server troubleshooting 
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Setup Standalone WWW BLAST Server for Linux 
Setup Standalone WWW BLAST Server;  
To set up Standalone WWW BLAST, make some more changes in httpd.conf file. The default 
location of httpd.conf file is "/etc/httpd/conf/httpd.conf".  
 
Following directives are to be setup in the httpd.conf file  
1. ScriptAlias  
2. Add Handler  

1. ScriptAlias  
#  
# ScriptAlias: This controls which directories contain server scripts. ScriptAliases are  
# essentially the same as Aliases, except that documents in the reaLNA(TM)me directory  
# are treated as applications and run by the server when requested rather than as  
# documents sent to the client. The same rules about trailing "/" apply to ScriptAlias  
# directives as to Alias.  
#  
ScriptAlias /cgi-bin/ "your DocumentRoot Directory/blast/"  
Example  
ScriptAlias /cgi-bin/ "/home/administrator/document/blast/"  
#  
# "/home/httpd/cgi-bin" should be changed to your ScriptAliased CGI  
# directory exists, if you have configured.  
#  
<Directory "your DocumentRoot directory/blast/"  
       AllowOverride None  
       Options ExecCGI  
       Order allow,deny  
       Allow from all  
</Directory  
Example  
<Directory "/home/administrator/document/blast/"  
       AllowOverride None  
       Options ExecCGI  
       Order allow,deny  
       Allow from all  
</Directory  
 
2. Add Handler  
#  
# AddHandler: It allows you to map certain file extensions to "handlers", actions  
# unrelated to file type. These can be either built into other server or added with the  
# Action command (see below)  
#  
# If you want to use server side includes, or CGI outside ScriptAliased directories,  
# uncomment the following lines, by removing # from its start.  
AddHandler cgi-script .cgi  
 
Test Standalone WWW BLAST Server  
 
Now access the main BLAST page by your default web browser by  
http://your Linux machine server IP address/blast/blast.html  
Example  
http://192.168.30.3/blast/blast.html  
It launches the main BLAST search page.  
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Refer to the Main BLAST page troubleshooting if you can not access it.  
 
Enter the sequence of interest and BLAST search against test_na_db. If the search results are 
displayed it means that local BLAST is set up correctly. If you are not able to generate the results, 
refer to BLAST search troubleshooting  
 
Download Databases 

1. Connect to the NCBI server as anonymous user via ftp link ftp://ftp.ncbi.nlm.nih.gov/blast/db/ 
Databases can be downloaded from any standard source.  
2. Download the databases.  
3. Extract the database in /blast/db directory.  
4. Format the database. 
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Format Databases 
Local;  
Database Formatting Tool  
 
1. For BLAST Server released before Jan 2002, formatdb program exists in /blast/db directory.  
2. For BLAST Server released in Jan 2002, formatdb, makemat and copymat binaries are 
removed from the archive - those should be taken from the ftp site 
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/release/. This connects to NCBI server as anonymous 
user. For Linux, download the archive blast-x.x.x-ia32-linux.tar.gz Copy the blast-x.x.x-ia32-
linux.tar.gz file to the blast/db directory. Uncompress it using the following commands  
gzip -d blast-x.x.x-ia32-linux.tar.gz  
tar -xvpf blast-x.x.x-ia32-linux.tar  
It will extract the formatdb file. 

Format Databases  
 
Formatdb must be used in order to format nucleotide source databases before these databases 
can be searched by blastall, blastpgp or MegaBLAST.  
Requirement:  
The source database may be in FASTA format. Copy the db file to your db directory of installed 
blast, also place formatdb in this directory, if it not present here.  
Unzip/uncompress compressed databases  
Default command line:  
formatdb -i filename -p F -o T  
Example : alu.n is input db file  
formatdb -i alu.n -p F -o T  
This will generate some supporting file that is used by BLAST algorithm for BLAST search.  
 
Additional command line options for formatdb:  
 -t Title for database file [String]  
Optional  
 -i Input file for formatting (this parameter must be set)  
[File In]  
-l Logfile name: [File Out]  
Optional  
default = formatdb.log  
 -p Type of file  
T - protein  
F - nucleotide [T/F] Optional  
default = T  
-o Parse options  
T - True: Parse SeqId and create indexes.  
F - False: Do not parse SeqId. Do not create indexes.  
[T/F] Optional default = F  
If the "-o" option is TRUE (and the source database is in FASTA format), then the database 
identifiers in the FASTA definition line must follow the convention of the FASTA Definition line 
Format.  
-a Input file is database in ASN.1 format (otherwise FASTA is expected)  
    T - True  
    F - False  
    [T/F] Optional default = F  
 -b ASN.1 database in binary mode  
    T - binary  
    F - text mode  
    [T/F] Optional default = F  
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A source ASN.1 database may be represented in two formats - ascii text and binary. The "-b" 
option, if TRUE, specifies that input ASN.1 database is in binary format. The option is ignored in 
case of FASTA input database.  
-e Input is a Seq-entry [T/F]  
Optional  
default = F  
-n Base name for BLAST files [String]  
Optional  
-v Number of sequence bases to be created in the volume [Integer]  
Optional  
default = 0  
-s Create indexes limited only to accessions - sparse [T/F]  
Optional  
default = F  
-A Create ASN.1 structured deflines [T/F]  
Optional  
default = F  
-L Create an alias file with this name use the gifile arg (below) if set to calculate db size use the 
BLAST db specified with -i (above) [File Out] Optional  
-F Gifile (file containing list of gi's) [File In] Optional  
-B Binary Gifile produced from the Gifile specified above [File Out] Optional 

  

Test the added database through Beacon Designer  

1. Launch BLAST search dialog.  
2. Select the Local BLAST search option.  
3. Select the "added database" in the Database dropdown menu.  
4. If "added database" is not visible in Database dropdown menu, refer to Server configuration file 
syntax.  
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Configuration Files 
Local  
Server configuration file and log file  
 
Default configuration file is "blast.rc" and logfile "wwwblast.log" located at installed blast directory. 
Setting tag WWW_BLAST_TYPE to specific value may change these names. Here is a sample 
configuration file comes with this distribution:  
# Number of CPUs to use for a single request  
NumCpuToUse 4  
#  
# Here is list of combination program db1 db2 db3..., that are allowed by BLAST  
# service. Format: ...  
#  
blastn test_na_db  
blastp test_aa_db  
blastx test_aa_db  
tblastn test_na_db  
tblastx test_na_db  
To add your newly formatted db in local BLAST server, append your db input file name at the end 
of its corresponding program separated by a space.  
For example, if you format file alu.n then append "alu.n" at the end of line  
blastn test_na_db. Now the database alu.n is associated with blastn program.  
Changed program/database (s) combination looks as follows:  
blastn test_na_db alu.n  
blastp test_aa_db  
blastx test_aa_db  
tblastn test_na_db  
tblastx test_na_db  
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System Requirements 
System Requirements;  
RedHat Linux 7.2 Server requirements:  

For RedHat Linux 7.2  Required  Recommended 

CPU 486DX processor  Pentium 

RAM  32 MB 64 MB 

Hard Disk Drive Space 1.0 GB  2.0 GB 

Local BLAST Server Space 50 MB 50 MB 

Space for Local Databases - Depends on number of 
databases for Local BLAST 

 
Note : If the input FASTA file is about 500 MB then it needs around 170-200 MB additional hard 
disk space for translated BLAST database. At least another 100-200 MB should be allowed for 
memory consumption by the actual BLAST program.  
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Troubleshooting 
 

 

1. Network connection  
Make sure the client and server computers are connected through a network.  
Use ping command at the command prompt  
ping IP address/Server name  
If sever and clients aren't connected, the following messages are generated  
Request timed out (on Windows)  
Destination Host Unreachable (on UNIX)  
Please consult System administrator.  
 
2. Apache Webserver  
a) Check if the Apache webserver is running  
Use the following command to verify that Apache webserver is running  
ps -A | grep "httpd"  
Output line(s) with "httpd" string indicate Apache webserver is running.  
If not, please Restart Apache webserver  
b) Check "testapache.html" is in the DocumentRoot directory.  
c) Check directory directive corresponding to DocumentRoot. It gives access to pages in the 
DocumentRoot directory. Please refer to DocumentRoot  
If server does not accepts requests from your system, access to testapache.html file is denied. It 
may be due to Firewall being implemented by RedHat Linux Server. Please consult System 
administrator.  
 
3. Extract BLAST server  
During untar, if a message appears "UnExpected End of file", it indicates that the downloaded file 
is either corrupted or incompletely downloaded. Please download it again.  
 
4.Main BLAST page  
Check the URL used.  
a) Proper Server IP address.  
b) Make sure "DocumentRoot" directory is the parent directory of blast directory or BLAST server 
has been extracted in the directory which is being used as DocumentRoot.  
c) Address should consists of 3 parts ("http://Server name/blast/blast.html")  
http protocol  
Server name or Server IP address  
main page location in the blast directory  
 
5.BLAST Search  
Request method POST is not allowed for the URL  
While BLASTing, if the message "Request method POST is not allowed for the URL 
blast/blast.cgi" is generated,  
a) "AddHandler cgi-script .cgi" is not uncommented. Find the command and uncomment it in the 
httpd.conf file. Please refer AddHandler  
b) CGI executables scripts of BLAST server does not have executable permissions. Please refer 
to ScriptAlias 

6. Server / Client machine IP address  
Use the following commands at the command prompt to get the IP address of your server / client 
machine:  
1. ipconfig (on Windows 98/ME/2000/XP)  
2. ifconfig (on RedHat Linux server)  
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1. IP address on Windows machine  
ipconfig [press Enter] on Windows gives  
IP Address. . . . . . . . . . . . . . : 192.168.30.18  
Subnet Mask . . . . . . . . . . . . : 255.255.255.0  
Default Gateway . . . . . . . . .. : 192.168.30.1  
192.168.30.18 is client machine's IP address.  
 
2. IP address on RedHat Linux machine  
ifconfig [press Enter] on RedHat Linux gives  
eth0 Link encap:Ethernet HWaddr 00:10:B5:F8:DC:0A  
          inet addr:192.168.30.4 Bcast:192.168.30.255 Mask:255.255.255.0  
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
          RX packets:992240 errors:0 dropped:0 overruns:0 frame:0  
          TX packets:1464662 errors:0 dropped:0 overruns:0 carrier:0  
          collisions:0 txqueuelen:100  
          Interrupt:11 Base address:0xc000  
lo Link encap:Local Loopback  
          inet addr:127.0.0.1 Mask:255.0.0.0  
          UP LOOPBACK RUNNING MTU:3924 Metric:1  
          RX packets:130 errors:0 dropped:0 overruns:0 frame:0  
          TX packets:130 errors:0 dropped:0 overruns:0 carrier:0  
          collisions:0 txqueuelen:0  
192.168.30.4 is server machine's IP address.  

7.Uncompress the compressed database  
If database archive ends with ".Z" then uncompress "blast.linux.tar.Z" with gunzip command.  
For example : gunzip -d blast.linux.tar.Z  
If database archive ends with ".gz" then uncompress "blast.linux.tar.gz" with following commands.  
For example :  
gzip -d blast.linux.tar.gz  
tar -xvpf blast.linux.tar 

8. Specify valid Server name/IP address  
Please specify valid Server name/IP address.  
1. If main BLAST page is not accessible through browser. Refer to Main BLAST page 
troubleshooting  
2. If main BLAST page is accessible through browser and Beacon Designer generates an error, It 
may be due to one of the following reasons:  
a) When you specify the IP address, please exclude "http://" from it.  
b) The BLAST page name is included in the IP address. Please refer to BLAST server path and 
IP address troubleshooting.  
c) Given IP address/server name does not exist. Please refer to Server / Client machine IP 
address troubleshooting.  
d) Given server IP address or server name is incorrect. Please refer to Server / Client machine IP 
address troubleshooting.  
e) Client and server are not connected through local network. Please refer to Network connection 
troubleshooting.  
f) BLAST server may not exist in the server's DocumentRoot directory. Please refer to  
BLAST server path and IP address troubleshooting. 

9. BLAST server path and IP address  
Suppose your server IP address or host name is "MyServer".  
1. Default BLAST server path  
If BLAST server is installed in the DocumentRoot directory, then main BLAST page should be 
accessible by the following URL  
http://MyServer/blast/blast.html  
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Beacon Designer expects "MyServer" as Server IP address.  
2. User defined server path  
If BLAST server is not installed in the DocumentRoot directory and main BLAST page is 
accessible by the following URL  
http://MyServer/../blastparent/blast/blast.html  
Beacon Designer expects "MyServer/../blastparent" as Server IP address.  
For example  
If main BLAST page is accessible by the following URL  
http://MyServer/blastparent/blast/blast.html  
Beacon Designer expects "MyServer/blastparent" as the Server IP address.  
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Standalone WWW BLAST for Mac 
 
Standalone WWW BLAST Server is available for UNIX/Mac OS X web servers. The following 
steps are necessary to set up a Standalone WWW BLAST server on Mac. 

Download BLAST Binaries 

Install Standalone WWW BLAST Server 

Setup Standalone WWW BLAST Server 

Format databases 

Update Standalone WWW BLAST Server configuration files 

System Requirements 

Troubleshooting 
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Download Blast Binaries for Mac 

 
Connect to the NCBI server as an anonymous user via ftp link 
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/ 

Download the wwwblast-xxx-xxx-Your_platform.tar.gz from "LATEST_WWWBLAST" folder. For 
example for Mac platform, download "wwwblast-xxx-powerpc-macosx.tar.gz" file.  
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Install Standalone WWW BLAST Server for Mac 

 
After downloading the file "wwwblast-xxx-xxx-Your_platform.tar.gz", place it in the document 
directory of HTTPD server. This is the DocumentRoot directory (e.g. 
“/Library/WebServer/Documents”) specified in the Apache config file httpd.conf and uncompress it 
with the commands :  
gzip -d wwwblast-xxx-xxx -Your_platform.tar.gz  
tar -xvpf wwwblast-xxx-xxx -Your_platform.tar  

Note : The parameter "p" in tar options is significant. It will preserve file access options stored in 
the distribution.  

For Mac platform, the commands are:  
gzip -d wwwblast-xxx-powerpc-macosx.tar.gz  
tar -xvpf wwwblast-xxx-powerpc-macosx.tar  

If the distribution file is uncompressed successfully, a 'blast' directory will be created in the 
DocumentRoot directory (e.g. "/Library/WebServer/Documents" directory). 

Download Format db  

Extract BLAST server troubleshooting 
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Setup Standalone WWW BLAST Server for Mac 
 
To set up Standalone WWW BLAST, we need to make some more changes in httpd.conf file. The 
default location of httpd.conf file is "/etc/httpd/httpd.conf".  
 
Note: Only root or super user can modify this file.  
 
Following directives need to be setup in the httpd.conf file  
1. ScriptAlias  
2. Add Handler  

ScriptAlias  
#  
# ScriptAlias: This controls which directories contain server scripts. ScriptAliases are  
# essentially the same as Aliases, except that documents in the reaLNA(TM)me directory  
# are treated as applications and run by the server when requested rather than as  
# documents sent to the client. The same rules about trailing "/" apply to ScriptAlias  
# directives as to Alias.  
# 

add following lines after </Directory> and before </ifModule> existed in ScriptAlias 

ScriptAlias /cgi-bin/ "your DocumentRoot Directory/blast/" 

<Directory "your DocumentRoot directory/blast/">  

Options +ExecCGI  

</Directory> 

Example : 

ScriptAlias /cgi-bin/ "/Library/WebServer/Documents/blast/" 

<Directory "/Library/WebServer/Documents/blast/">  

Options +ExecCGI  

</Directory> 

2. Add Handler  
#  
# AddHandler: It allows you to map certain file extensions to "handlers", actions  
# unrelated to file type. These can be either built into other server or added with the  
# Action command (see below)  
#  
# If you want to use server side includes, or CGI outside ScriptAliased directories,  
# uncomment the following lines, by removing # from its start.  
AddHandler cgi-script .cgi  
 
 
Test Standalone WWW BLAST Server  
 
Now access the main BLAST page using your web browser by entering the address:  
http://your Mac machine server IP address/blast/blast.html 
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Example :  
http://192.168.30.3/blast/blast.html  
It launches the main BLAST search page.  
Refer to the Main BLAST page troubleshooting if you can not access it.  
 
Enter a sequence and BLAST search against the test database test_na_db. If search results are 
displayed, the local BLAST is set up correctly. If not, refer to BLAST search troubleshooting  
 
 
Download Databases 

The following steps are required to obtain databases for local BLAST search: 

1. Connect to the NCBI server as anonymous user via ftp link ftp://ftp.ncbi.nlm.nih.gov/blast/db/. 
Databases can be downloaded from any standard source.  
2. Download the databases.  
3. Extract the database in /blast/db directory.  
4. Format the database.  
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Format Databases for Mac 

 

Database Formatting Tool  

1. For BLAST Server released before Jan 2002, the formatdb program exists in the /blast/db 
directory.  
2. For BLAST Server released in Jan 2002, formatdb, makemat and copymat binaries have been 
removed from the archive - they should be downloaded from the ftp site 
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/release/ . This connects to the NCBI server as an 
anonymous user. For Mac, download the archive blast-x.x.x-powerpc-macosx.tar.gz. Copy the 
blast-x.x.x-powerpc-macosx.tar.gz file to the blast/db directory. Uncompress it using the following 
commands  
gzip -d blast-x.x.x-powerpc-macosx.tar.gz  
tar -xvpf blast-x.x.x-powerpc-macosx.tar  
It will extract the formatdb file. 

Format Databases  

Formatdb must be used to format nucleotide source databases before they can be searched by 
blastall, blastpgp or MegaBLAST.  

The source database may be in FASTA format. Copy the db file to your db directory of installed 
blast, also place formatdb in this directory,  

Unzip/uncompress compressed databases  

with the command :  

./formatdb -i filename -p F -o T  

Example : alu.n is input db file  

./formatdb -i alu.n -p F -o T  

This will generate some supporting files that are used by the BLAST algorithm for BLAST search.  

  

Additional command line options for formatdb:  

-t Title for database file [String]  

Optional  

-i Input file for formatting (this parameter must be set)  

[File In]  

-l Logfile name: [File Out]  

Optional  

default = formatdb.log  

-p Type of file  
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T - protein  

F - nucleotide [T/F] Optional  

default = T  

-o Parse options  

T - True: Parse SeqId and create indexes.  

F - False: Do not parse SeqId. Do not create indexes.  

[T/F] Optional default = F  

If the "-o" option is TRUE (and the source database is in FASTA format), then the database 
identifiers in the FASTA definition line must follow the convention of the FASTA Definition line 
Format.  

-a Input file is database in ASN.1 format (otherwise FASTA is expected)  

T - True  

F - False  

[T/F] Optional default = F  

-b ASN.1 database in binary mode  

T - binary  

F - text mode  

[T/F] Optional default = F  

A source ASN.1 database may be represented in two formats - ascii text and binary. The "-b" 
option, if TRUE, specifies that input ASN.1 database is in binary format. The option is ignored in 
case of FASTA input database.  

-e Input is a Seq-entry [T/F]  

Optional  

default = F  

-n Base name for BLAST files [String]  

Optional  

-v Number of sequence bases to be created in the volume [Integer]  

Optional  

default = 0  

-s Create indexes limited only to accessions - sparse [T/F]  

Optional  

default = F  
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-A Create ASN.1 structured deflines [T/F]  

Optional  

default = F  

-L Create an alias file with this name use the gifile arg (below) if set to calculate db size use the 
BLAST db specified with -i (above) [File Out] Optional  

-F Gifile (file containing list of gi's) [File In] Optional  

-B Binary Gifile produced from the Gifile specified above [File Out] Optional 

Test the added database through Beacon Designer. 

1. Launch BLAST search dialog.  

2. Select the Local BLAST search option.  

3. Select the "added database" in the Database dropdown menu.  

4. If "added database" is not visible in Database dropdown menu, refer to Server configuration file 
syntax.  
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Configuration Files for Mac 

 

Server configuration file and log file  

The default configuration file is "blast.rc" and the logfile is "wwwblast.log" are located in the 
installed blast directory. Setting tag WWW_BLAST_TYPE to a specific value may change these 
names. Here is a sample configuration file that comes with this distribution:  

# Number of CPUs to use for a single request  

NumCpuToUse 4  

#  

# Here is list of combination program db1 db2 db3..., that are allowed by BLAST  

# service. Format: ...  

#  

blastn test_na_db  

blastp test_aa_db  

blastx test_aa_db  

tblastn test_na_db  

tblastx test_na_db  

To add your newly formatted db to the local BLAST server, append your db input file name at the 
end of its corresponding program separated by a space.  

For example, if you format file alu.n then append "alu.n" at the end of line  

blastn test_na_db. Now the database alu.n is associated with blastn program.  

The new program/database (s) combination looks like :  

blastn test_na_db alu.n  

blastp test_aa_db  

blastx test_aa_db  

tblastn test_na_db  

tblastx test_na_db  
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System Requirements for Mac 
 

Mac OS X 10.3 Server requirements:  

For Mac OS X 10.3 Required Recommended 

 CPU  IMac Power PC G3 350  IMac Power PC G3 350 

 RAM  256 MB  384 MB 

 Local BLAST Server 
Space   50 MB   50 MB 

 Space for Local 
Databases -  Depends on number of 

databases for Local BLAST 

  

Note : If the input FASTA file is about 500 MB then it needs around 170-200 MB additional hard 
disk space for the translated BLAST database. At least another 100-200 MB should be allowed 
for memory consumption by the actual BLAST program.  
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Troubleshooting for Mac 

 

1. Extract BLAST server  
During untar, the message "UnExpected End of file", indicates that the downloaded file is either 
corrupted or incompletely downloaded. Please download it again.  

2. Main BLAST page  
Check the URL used.  
a) Proper Server IP address.  
b) Make sure "DocumentRoot" directory is the parent directory of blast directory or BLAST server 
has been extracted in the directory which is being used as DocumentRoot.  
c) Address should consists of 3 parts ("http://Server name/blast/blast.html")  
http protocol  
Server name or Server IP address, and  
main page location in the blast directory  

Note: We can use localhost host in place of IP Address if we are using it as a client and server 
both.  

3. BLAST Search  
Request method POST is not allowed for the URL  
While BLASTing, if the message "Request method POST is not allowed for the URL 
blast/blast.cgi" is generated,  
a) "AddHandler cgi-script .cgi" is not uncommented. Find the command and uncomment it in the 
httpd.conf file. Please refer Add Handler  
b) CGI executables scripts of BLAST server does not have executable permissions. Please refer 
to ScriptAlias 

4. Uncompress the compressed database  
If database archive ends with ".Z " then uncompress "blast.Your_Platform.tar.Z" with gunzip 
command.  
For example : gunzip -d blast.Your_Platform.tar.Z  
If database archive ends with ".gz " then uncompress "blast.Your_Platform.tar.gz" with gzip 
commands.  
For example :  
gzip -d blast.Your_Platform.tar.gz  
tar -xvpf blast.Your_Platform.tar  

5. Specify valid Server name/IP address  
Please specify valid Server name/IP address.  
1. If main BLAST page is not accessible through browser. Refer to Main BLAST page 
troubleshooting.  
2. If main BLAST page is accessible through browser and Beacon Designer generates an error, It 
may be due to one of the following reasons:  
a) When you specify the IP address, please exclude "http://" from it.  
b) The BLAST page name is included in the IP address. Please refer to BLAST server path and 
IP address troubleshooting.  
c) BLAST server may not exist in the server's DocumentRoot directory. Please refer to  
BLAST server path and IP address troubleshooting. 

6. BLAST server path and IP address  
Suppose your server IP address or host name is "MyServer".  
1. Default BLAST server path  
If BLAST server is installed in the DocumentRoot directory, then the main BLAST page should be 
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accessible by the following URL  
http://MyServer/blast/blast.html  
or  
http://localhost/blast/blast.html(if using as client server both)  
Beacon Designer expects "MyServer" as Server IP address.  

2. User defined server path  

If BLAST server is not installed in the DocumentRoot directory and main BLAST page is 
accessible by the following URL  

http://MyServer/../blastparent/blast/blast.html  

Beacon Designer expects "MyServer/../blastparent" as Server IP address.  

For example  

If main BLAST page is accessible by the following URL  

http://MyServer/blastparent/blast/blast.html  

Beacon Designer expects "MyServer/blastparent" as the Server IP address.  
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Algorithm and Formulae 
 

Formula for Melting Temperature Calculation 

The Tm for the primer is calculated using the following: 

C - Primer concentration: 0.25 nM (acceptable range 0.1 - 100 nM) 

Mg++: 3.0 mM for beacon and 5.0mM for TaqMan(R) design (acceptable range 0 - 100 mM) 

Monovalent ion concentration: 50 mM (acceptable range 0 - 1000 mM) 

[Na+] Equivalent Algorithm: The sodium equivalent is calculated by: 

[Na+] = Monovalent ion concentration + 4 X (Free Mg2+)1/2 (all in molar concentration) 

dH Calculation:  
The dH is found by adding up all the di-nucleotide pairs values from the table below. If the primer 
begins with a G or a C, then the init G-C correction is added, otherwise the init A-T correction is 
added. The same is done for the base at the end of primer. 

dS Calculation:  
The same method as the dH is used. An addition salt correction term is added where N is the 
number of nucleotide pairs in the primer (primer length - 1): 

dS (salt corrected) = dS (1 M NaCl) + 0.368 * N * ln ([Na+]) 

Tm Algorithm:  
The Tm for a primer is calculated from its H, S, R the gas constant (1.987 cal/kmol), and C the 
primer concentration: 

Tm = dH / (dS + R * ln C) 

Example:  
Here is an example of a Tm calculation using: Salt equiv: 204.92 mM  
 
Primer Sequence:      CAGAAGTCCACTCATTCTCG 

     CA AG GA AA AG GT TC CC CA AC 

dH = - ( 8.5 + 7.8 + 8.2 + 7.9 + 7.8 + 8.4 + 8.2 + 8.0 + 8.5 + 8.4 

CT TC CA AT TT TC CT TC CG 

7.8 + 8.2 + 8.5 + 7.2 + 7.9 + 8.2 + 7.8 + 8.2 + 10.6 ) = -156.1 kcal/mol 

Now we add in init G-C+ init G-C = -156.1kcal/mol + 0.1 kcal/mol + 0.1 kcal/mol = -155.9 
kcals/mol 

     CA AG GA AA AG GT TC CC CA AC 

dS = - (22.7+ 21.0 + 22.2 + 22.2 + 21.0 + 22.4 + 22.2 + 19.9 + 22.7 + 22.4 

CT TC CA AT TT TC CT TC CG 

21.0 + 22.2 + 22.7 + 20.4 + 22.2 + 22.2 + 21.0 + 22.2 + 27.2) = -419.8 cal/K-mol 
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Now we add the init G-C + init G-C =-419.4 cal/kmol + -2.8 + -2.8 = -425.4 cal/K-mol 

Now we add salt correction, 

NaEqiv = Na+ + 4 x sqrt(Mg++) (all concentrations molar) 

     = 0.05 + 4 x sqrt (0.0015)= 0.20492M 

 dS= -425.4 + .368 x N x ln [Na] 

     = -425.4 + .368 x 19 x ln .20492 

     = -425.4 + .368 x 19 x (-1.585) 

     = -436.48 cal/K-mol  

 Tm= H/(S + R ln C) 

     = -155.9 kcal/mol / (-436.48 cal/K-mol + 1.987 cal/kmol * ln(0.25e-9)) 

     = -155.9 kcal/mol / ( -436.48 cal/ K-mol + 1.987 cal/kmol * -22.109) 

     = -155.9 kcal/mol /(-480.41 cal/K-mol) 

     = 324.51 oK  

     = 324.51 - 273.15 = 51.36 oC 

Tm for primer as predicted by Primer Premier using Breslaur values: 52.5 oC 

Dinucleotide Table Values: 

Dinucleotide Sequence H kcal/mol S cal/k mol 

AA OR TT -7.9 -22.2 

AT -7.2 -20.4 

TA -7.2 -21.3 

CA OR TG -8.5 -22.7 

GT OR AC -8.4 -22.4 

CT OR AG -7.8 -21.0 

GA OR TC -8.2 -22.2 

CG -10.6 -27.2 

GC -9.8 -24.4 

GG OR CC -8.0 -19.9 
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Init w G-C 0.1 -2.8 

Init w / term 2.3 4.1 
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Melting Temperature Calculation For LNA(TM) Probes 

 

Formula for Melting Temperature Calculation 

The Tm for the primer is calculated using the following: 

C - Primer concentration: 50 nM (acceptable range 0.1 - 100 nM) 

Mg++:1.8 mM for TaqMan(R) design (acceptable range 0 - 100 mM) 

Monovalent ion concentration: 50 mM (acceptable range 0 - 1000 mM) 

[Na+] Equivalent Algorithm: The sodium equivalent is calculated by: 

[Na+] = Monovalent ion concentration + 4 X (Free Mg2+)1/2 (all in molar concentration) 

dH Calculation:  
The dH is found by adding up the (LNA(TM)/DNA) di-nucleotide pairs values from the table below 
and DNA/DNA dinulceotide pair values from Santa Lucia values. If the primer begins with a G or 
a C, then the init G-C correction is added, otherwise the init A-T correction is added. The same is 
done for the base at the end of primer. 

dS Calculation:  
The same method as the dH is used. An addition salt correction term is added where N is the 
number of nucleotide pairs in the primer (primer length - 1): 

dS (salt corrected) = dS (1 M NaCl) + 0.368 * N * ln ([Na+]) 

Tm Algorithm:  
The Tm for a primer is calculated from its H, S, R the gas constant (1.987 cal/kmol), and C the 
primer concentration: 

Tm = dH / (dS + R * ln C)  
 
Example :  
Here is an example of a Tm calculation using: Salt equiv: 538.18 mM  
tccTcaCgcacggca  
 
tc cc cT Tc ca aC Cg gc ca ac cg gg gc ca  
 
Delta H Calculation :  
 
Delta H = - (8.2 + 8.0 + 7.432 + 7.01 + 8.5 + 7.275 + 11.434 + 9.8 + 8.5 + 8.4 + 10.6 + 8.0 + 9.8 + 
8.5 ) Kcal/mole  
Delta H = - 121.451 Kcal/mole  
 
Now we add in init = 2.3 + 2.3 + (-121.451)  
Delta H = 116.851 Kcal/mole  
 
Delta S Calculation :  
 
Delta S = - (22.2 + 19.9 + 19.214 + 17.576 + 22.7 + 17.48 + 28.051 + 24.4 + 22.7 + 22.4 + 27.2 + 
19.9 + 24.4 + 22.7)  
Delta S = - 310.821cal/mole  
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Now we add in init = 4.1 cal/mole + 4.1cal/mole+ - 310.821cal/mole  
            Delta S = 302.621cal/mole  
 
Now we add salt correction, 

NaEqiv = Na+ + 4 x sqrt(Mg++) (all concentrations molar) 

     = 50 + 4 x sqrt (0.0018)= 0.21971 M  
 
dS= -302.621 + .368 x N x ln [Na] 

     = -302.621 + .368 x 14 x ln 0.21971 

     = -302.621 + .368 x 14 x -1.515  
 
    = -302.621 + -7.808 

     = -310.429 cal/mole  
 
Tm= H/(S + R ln C)  
 
    = 116.851 x 1000 / ( -310.429 + 1.987x (ln 50 x 1exp - 9))  
 
    = 116.851 x 1000 / ( -310.429 + -33.40)  
 
    = 116.851X1000 / -343.833  
 
   = -339.848 o K  
 
   = 334 -273  
 
    = 66.70 oC  
                   
Delta S calculation : 

Delta H and Delta S values : These values are obtained by adding ddH and ddS correction 
values to DeltaH and DeltaS values mentioned in "Sequence-Dependent Thermodynamic 
Parameters for Locked Nucleic Acid (LNA(TM))-DNA Duplex Formation" By Patricia M. 
McTigue,&Raymond J. Peterson,and Jason D. Kahn. 

Delta H values (kcal/mol) 

DNA 
Bases/LNA(TM) 

Base 

a t g c 

A -6.682 -6.123 -8.634 -7.21 

T -5.982 -6.823 -9.334 -7.01 

G -6.982 -7.323 -8.834 -8.61 

C -7.282 -6.723 -11.434 -6.81 
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LNA(TM) 
Base/DNA 

Base 

A T G C 

a -6.775 -6.075 -6.675 -7.275 

t -5.527 -6.227 -6.827 -6.527 

g -8.715 -8.915 -8.515 -10.315 

c -8.132 -7.432 -10.232 -7.632 

 
Delta S values (cal/mol) 

DNA 
Bases/LNA(TM) 

Base 

a t g c 

A -17.474 -16.149 -21.851 -17.776 

T -16.574 -17.949 -23.551 -17.576 

G -17.474 -18.149 -20.751 -19.776 

C -17.974 -16.749 -28.051 -15.276 

LNA(TM) 
Bases/DNA Base 

A T G C 

a -17.28 -15.48 -16.08 -17.48 

t -15.384 -16.284 -16.784 -16.284 

g -22.072 -22.272 -19.772 -24.272 

c -20.914 -19.214 -25.414 -18.114 
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Formula for Calculating TaOpt 
 
Beacon Designer displays calculated optimal annealing temperature Ta Opt for current primer 
pair in the Primer Preperties tab. It is the recommended annealing temperature in the PCR 
reaction and is expected to yield the best PCR product yield with minimal false product 
production.  
We use the following formula1:  
Ta Opt = 0.3 * Primer Tm + 0.7 * Product Tm – 14.9 oC 
where Primer Tm is the melting temperature of the less stable primer and Product Tm is the 
melting temperature of the PCR product in oC. The less stable primer is the primer with lower Tm 
of the two primer Tm's.  
The Ta Opt is generally lower than the Tm of the less stable primer by around 5 oC. For 
templates with high GC content, the calculated Ta Opt may be too high, even higher the Tm of 
the less stable primer. Running the reaction at this high temperature may result in reduced or 
unspecific annealing, and smaller or unspecific product yield may result. The best method to 
avoid these deleterious effects is to increase the concentration of the less stable primer 
with respect to the other in the reaction. We highly recommend following this suggestion. 
1 Rychlik, W., Reference (13) in Appendix D. 
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Formula for Free Energy 

 
Entropy and enthalpy calculations are based upon the thermodynamic library of all 10 Watson-
Crick DNA nearest-neighbor interactions determined by SantaLucia et al. (1). Using this method, 
the free energy of an oligo is calculated from the enthalpies and entropy of each dinucleotide in 
the oligo and the temperature defined in the Reaction Conditions Window. The temperature 
setting on the Reaction Conditions Window should be set to ambient room temperature. The 
experiments are based on a 1M NaCl concentration in the PCR reaction. 

dG = dH - T * dS 

dH is the enthalpy. 

T is the temperature. 

dS is the entropy.  
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Formula for Rating 
In Beacon Designer the sophisticated search algorithm calculates all properties of every possible 
primer and probe within the allowed length and positional boundaries and rates them. Tm is 
calculated based on nearest neighbor thermodynamic theory using SantaLucia values. Beacon 
Designer then calculates the self-dimer and hairpin stability of each primer. To quantify the merit 
of each primer, a rating number is calculated based on a number of parameters; Tm , the stability 
of possible secondary structures and the location of each primer compared to the specified site 
and all of their individual tolerances. The rating determines how well the designed oligo meets the 
search parameters relative to the tolerance limits specified for each parameter. The parameters 
included in arriving at the rating are maximum hairpin dG, maximum self-dimer dG, maximum 
run/repeat length, maximum Cross-dimer dG and Tm mismatch. 

 

From the formula it is evident that if all parameters were exactly on target or summation (S) of all 
the variables is 0, the rating would be 100. On the other hand, if summation of all the variables 
(parameters) is greater than zero then the rating can vary between 100 to 0. It would be 0 when 
the summation of all the variables is equal to 1 or when all parameters were out at their tolerance 
limits. 

Tolerance is a permissible value of variation acceptable by the program for designing oligos from 
a pre-set standard (Default) value. For instance variation of +/- 5°C is the tolerance value 
specified for Target Tm parameter of 55°C. 
The tolerance plays two related but distinct roles. First, it is used to reject primers with 
parameters outside of the specified range. Then, for acceptable primers, the inverse tolerance is 
the rating weight given to each parameter. There are no negative rating values because all 
primers with one or more parameters out of limits are rejected.  

The rating of a given probe, depends on two factors:  

1. how close the probe is to the target value of each parameter. 

2. how tightly the tolerances are specified. 

 

The default tolerances provided in the program are chosen to represent the requirements of 
typical experiments. Highly rated probes have most or all parameters near their ideal values and 
are very likely to work well, but it is important to note that all designed primers and probes meet 
all the specifications, no matter what their rating. 

Target is a specified value for a particular given parameter. For instance if we specify a value for 
Target Tm parameter as 55°C then this value is the Target value. 

For instance one can specify the Tm tolerance, which corresponds to the acceptable range of 
temperature over and below the optimal Tm for which primers are acceptable. Default for the 
temperature tolerance is +/- 5 degrees.  

Thus at a temperature of 55°C, the temperature will range from 50 to 60°C, allowing design of 
more primers that fit into the five degree range. The primers qualifying as per criteria set will be 
designed by the program. In other words, if tolerance increases then chances of primers 
qualifying at majority of parameters increases and so rating also increases. Other parameters are 
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also considered by the program which determines the quality of any oligo for an experiment to be 
a success. 

NOTE: If you change the tolerance to 0, the program will display an error as: “Please enter a 
number between 0.1 and 99.9”. For example, for a temperature selection of 55°C, if you give a 
Tolerance of 0, the above error message is displayed.  

For Beacon/ TaqMan(R) probe and primer search, the quality of the designed probe and primer is 
displayed as Best, Good, Poor or Not Found in the Search Status tab. The probes and primers 
having rating greater than or equal to 75 are termed Best, the probes with rating between 74 and 
50 are termed as Good and those having rating below 50 are termed Poor. If no probe or primer 
meeting the specified criteria is found, a "Not Found" status is displayed.  

The search status appears in RED under Primer / Probe Properties tab. 

For instance : Status: No primer pairs found : 294 rejected ( ProdLen: 188 TmMatch: 106)  

indicates the total number of primer rejected and the parameters they failed on.  

To find a suitable oligo, one may change the search parameters based on the search status 
message. For the above example, one can increase both the product length and Tm to check if 
its possible to design primers. 

The rating assigned is just a facilitator for you to take an informed decision and indicates how 
closely a primer or probe meets all the target values. When setting the tolerance limits, the sole 
criteria should be acceptability. Though counter intuitive, specifying tolerances tightly does not 
assure better results. A low rated probe would not necessarily fail. It may be worthwhile to 
consider its properties relative to your experimental needs and decide whether the probe is 
acceptable or whether the low rating is an artifact of narrow tolerances.  
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Appendix 

Primer Design Guidelines For NASBA(R) 

 In NASBA(R) two primers P1 and P2 are used for amplification of RNA\DNA. 

Common guidelines for P1 and P2 primers. Primers sequences should be chosen in such a 
way that : 

a) The melting temperature (Tm) of the primer should be 55 +/-5 oC.d. 

b) Formation of internal structures/loops in the primers is not favored. 

c) Primer dimerisation should be avoided. 

d) Length of the primer should be 20-30 nucleotides. 

e) Traces of more than 3 of the same nucleotide should be avoided.  
 
f) Should have A as the final nucleotide at the 3' end.  

g) G/C Clamp : Check the total number of Gs and Cs in the last 5 nucleotides at the 3’ end of the 
primer. More than 2 Gs, 2 Cs or 1 GC is not recommended. 

Guidelines for P1 Primer :  

a) The 5'end of the P1 primer should be a T7 RNA polymerase promoter sequence consisting of 
the following 25 nucleotides : 

5'-AATTCTAATACGACTCACTATAGGG 3' 

The T7 RNA polymerase promoter sequence is followed by a stretch of nucleotides that is: 

a) Primer sequence should be complementary to a sequence on the target RNA. 

b) In the first 10 nucleotide following the promoter sequence should be purine rich sequence. 

c) GC content of 40-60% 

d) Stretches of pyrimidine (C or T ) in the first 10-12 nucleotides of the P1 primer sequence 
complementary to the target RNA sequence may cause abortive transcription. If no pyrimidine - 
rich region is available in the target RNA (i.e. C or U residues in the target hybridizing to G or A 
residues in the P1 primer), extra purine residues (for instance (AGA,AGG) can be inserted in the 
P1 primer immediately after the final triplet of G residues in the T7 RNA polymerase sequence. 

Molecular Beacon Design guidelines for NASBA(R) : Same as Molecular Beacon Design 
guidelines for Standard Real Time PCR. 
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Beacon Design Guidelines 
 
The Beacon Designer uses following universal molecular beacon design guidelines to design 
most optimal beacons to successfully monitor PCR reactions. The molecular beacons should be 
designed so that they hybridize to their targets at PCR annealing temperatures, whereas the free 
molecular beacons stay closed and non-fluorescent at these temperatures. According to these 
guidelines: 

The molecular beacon probe region should be 15 to 33 nucleotides long.  

Its melting temperature should be 7-10 oC higher than the PCR annealing temperature. 

The loop sequence must be complementary to the target sequence of the assay. 

It is important to design the molecular beacon in an area where there is minimal secondary 
structure formation of the target. This will help prevent the template from preferentially annealing 
to itself faster than to the molecular beacon.  

It is recommended to design the molecular beacon such that it binds at or near the center of the 
amplicon. 

The distance between the 3' end of the upstream primer and the 5' end of the molecular beacon 
(stem) should be greater than 6 nucleotides. 

The melting temperature of the probe-target hybrid can be predicted using the percent GC rule. 
The prediction should be made for the probe sequence alone before adding the stem sequences.  

After selecting a probe sequence, two complementary arm sequences should be added, one on 
each side of the probe sequence.  

The stem sequences should not be complementary to the target sequence.  

This stem region of the molecular beacon should be 5 to 7 bp long, with the GC content at 70-
80%. 

The length, sequence and GC content of the stem should be chosen such that the melting 
temperature is 7-10 oC higher than the annealing temperature of the PCR primers. 

The melting temperature of stem is calculated using the Zuker hairpin folding formula: it is used to 
estimate the free energy of the formation of the stem hybrid from which its melting temperature 
can be predicted. 

The higher the free energy, the more favorable and stable the structure. Free energy values 
obtained with the Zuker program should usually range between -3 to +0.5 kcal/mole. 

Since the G nucleotide may act as a quencher, it is best to avoid designing your molecular 
beacon with a G directly adjacent to the fluorescent dye (typically at the 5' end of the stem 
sequence). A cytosine at the 5' end of the stem is preferred. 

The sequence of the molecular beacon and PCR primers should be designed so that there are no 
regions of complementarity, which may cause the molecular beacon to bind to primers and 
increase background.  

The primers used during molecular beacon PCR experiments should be designed to produce a 
relatively short amplicon generally less than 150 base pairs. The molecular beacon is an internal 
probe, which must compete with the opposite strand of the amplicon for binding to its 
complementary target. Having a shorter amplicon allows the molecular beacon to compete more 
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efficiently for binding to its target and, therefore, produces better results during molecular beacon 
PCR experiments.  

Presence of any secondary structure other than the hairpin stem can change position of 
fluorophore with reference to quencher causing large background signals. 

Following the above guidelines in the Beacon Designer the default length of probe length is 18 to 
30 nucleotides. The actual implementations show that the beacon having melting temperature 10 
oC higher than PCR annealing temperature have better signal strength. The Beacon Designer by 
default designs beacons that have Tm 9+ 5 oC higher than the PCR annealing temperature, so 
that the melting temperature of resulting beacons is most appropriate. Both the probe and the 
beacon melting temperatures are considered for beacon design. The probe melting temperature 
is calculated using most accurate nearest neighbor thermodynamic calculation using Santa Lucia 
values. And the beacon melting temperature of stem is calculated using the Zuker hairpin folding 
formula at Quikfoldserver. 

The designed beacons bind at or near the center of amplicon. These are checked for any 
secondary structure such as alternate hairpins and dimers which can cause background signals. 
To further reduce background signals, beacons are multiplexed with primers to check for regions 
of complementarity with primers.  

Primer design in the program is optimized for beacon applications; the default amplicon size is 
150 bases, thereby allowing efficient detection of amplicons using molecular beacons. 

Adapted from: "The molecular beacon design guidelines" developed by Dr. Sanjay Tyagi 
(private communication). 
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TaqMan(R) Design Guidelines 

 
The Beacon Designer uses following standard TaqMan(R) design guidelines to design most 
optimal TaqMan(R) assay to successfully monitor PCR reactions. The TaqMan(R) probe is 
designed such that it anneals between the upstream and the downstream primer in PCR. It is 
recommended that the 3' end of the primer that lies on the same strand as the probe, should not 
be not more than 10 bp away from the 5' end of the probe (ABRF design Guidelines). During the 
amplification reaction, the 5' -3' exonuclease activity of the Taq polymerase cleaves the 
fluorophore from the probe leading To emission of fluorescence . According to these guidelines: 

The primer melting temperature (Tm) should be around 58-60 oC, and probes Tm should be 10 oC 
higher than Primer Tm . The Tm of both primers should be equal. 

Primers should be 15-30 bases in length. 

The G+C content should ideally be 30-80%. If a higher G+C content is unavoidable, the use of 
high annealing and melting temperatures, cosolvents such as glycerol, DMSO, or 7-deaza-dGTP 
may be necessary. 

The run of an identical nucleotide should be avoided. This is especially true for G, where runs of 
four or more Gs are not allowed. 

The total number of Gs and Cs in the last five nucleotides at the 3' end of the primer should not 
exceed two. This helps to introduce relative instability to the 3' end of primers to reduce non-
specific priming. The primer conditions are the same for SYBR (R) Green Assays. 

Maximum amplicon size should not exceed 400 bp (ideally 50-150 bases). Smaller amplicons 
give more consistent results because PCR is more efficient and more tolerant of reaction 
conditions (the short length requirement has nothing to do with the efficiency of 5' nuclease 
activity). 

The probes should not have runs of identical nucleotides (especially four or more consecutive 
Gs), G+C content should be 30-80%, there should be more Cs than Gs, and not a G at the 5' 
end. The higher number of Cs produces a higher normalized fluorescence values (DRn). The 
choice of probe should be made first. 

To avoid false-positive results due to amplification of contaminating genomic DNA in the cDNA 
preparation, it is preferable to have primers spanning exon-exon junctions. This way, genomic 
DNA will not be amplified. 

If a TaqMan(R) probe is designed for allelic discrimination, the mismatching nucleotide (the 
polymorphic site) should be in the middle of the probe rather than at the ends. 
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LNA(TM) Substituted TaqMan(R) Design Guidelines 

 
1. Tm of the probe should optimally be 10 °C higher than Tm of the forward primer. In case of 
single mutation detection the Tm-difference should be 7 °C. Maintain Tm with LNA(TM) 
substitutions to match the Tm of the corresponding longer DNA probe.  
 
2. Typical Tm of dual labeled probes: 65-70 °C (i.e. slightly lower than the extension 
temperature). Typical Tm of PCR primers for dual labeled assays: 58-60 °C.  
 
3. Optimal length of LNA(TM) substituted dual labeled probes: 15-18 nucleotides.  
 
4. LNA(TM) should always be substituted in the central segment i.e two bases should be left from 
3' end and 2 bases from 5' end.  
 
5. Usually 4-6 LNA(TM) substitutions are required to obtain a useful Tm.  
 
5. In case of single nucleotide mutations studies,select the probe sequence so that the mutation 
is located centrally in the probe. Make a single LNA(TM) substitution at the position of the single 
nucleotide mutation.  
 
6. Avoid LNA(TM) substitutions participating in formation of secondary structures.  
 
7. Position the dual labeled probe as close as possible to the forward primer. Avoid Guanine (G) 
in the 5’-position next to the fluorophore.  
 
8. Avoid longer stretches of identical nucleotides and especially G’s.  
 
9. GC-content should be between 30-80 %. 
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FRET probe Design Guidelines 

 
The Beacon Designer uses following standard FRET Probes design guidelines to design most 
optimal FRET Probe assay to successfully monitor PCR reactions. 

1. Probe length: Usually probes are 23 - 35 bases in length.  
 
2. Probe position: At annealing temperature, two probes must hybridize close to each other to 
allow proper transfer of energy for FRET to occur. The 3 end of the first probe (donor probe) must 
be within 1-5 bases from the 5' end of the second probe (acceptor probe). Default = 1 base. 

The probe target should be near the 5’ end of the target strand (i.e., as far as possible from the 
5’primer-binding site on the same strand), but not overlapping the primer-binding site on the 
opposite strand.  

3. Probe Tm: The two probes Tm should be at least 5° -10° C above the primer Tm. The probe 
Tm should not be > 10 to 20° C to avoid interference. The optimal T Tm difference between the 
two probes for detection and quantification, should be the same (within 2ºC of each other). For 
mutation detection, the difference between probe Tm is 5–10ºC. The probe with the lowest 
stability should be positioned directly over the mutation to be detected. 

4. Secondary structures: The probes should not contain repeats and runs, self complimentary 
sequences, and clusters of G and C at either end.The probes should not form cross dimers with 
primer.  
 
5. GC %: The G/C content of probe should range between 38 -60%. (A/T rich probes tend to 
hybridize poorly and G/C rich probes may bind too tightly to the target).  

6. Probe modification: The 3' end of the probe must be modified to prevent probe extension. The 
3' end of the acceptor probe is phosphorylated. The 3' end of donor probe is labeled with 
fluorescein and thus cannot extend during PCR.  

7. Probe label: The adjacent ends of the hybridization probes should be labeled with 
fluorophores. Probe 1("donor" or 5’ probe) is labeled at 3’ end with Fluorescein (FITC, 3FL). 
Probe 2 or ("acceptor" or 3’ probe) is labeled at 5’ end.  
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SYBR (R) Green Primer Design Guidelines 

 
Other than the general primer design parameters Beacon Designer uses following standards for 
designing most optimal primers for a SYBR (R) Green assay.  

It is important that the SYBR (R) Green primers specifically anneal to the target and do not form 
dimers. The following are the specific parameters that are to be considered.  

Keep G-C contents in the 30-80% range. Default 50% 

Avoid runs of an identical nucleotide. This is true especially for G and C, where runs of four or 
more Gs & Cs should be avoided. Default 3  

G/C Clamp : Check the total number of Gs and Cs in the last 5 nucleotides at the 3’ end of the 
primer. More than 2 Gs, 2 Cs or 1 GC is not recommended. 

The melting temperature (Tm) of the primer should be 55 +/-5 oC. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 Beacon Designer 5.10 Technical Information 

 166

Glossary 
Alternate Primer - A primer pair that is rated lower than the best primer pair. The best primer pair 
is displayed in the Primer Properies tab 

Amplicon - A PCR amplified segment of DNA. 

Annealing Temperature - The temperature at which pairing of two complementary single-
stranded nucleic acids occurs to form a double-stranded (duplex) nucleic acid. 

Antisense Primer - A primer that primes the sense strand of the DNA sequence. Alternatively 
termed a reverse primer, or sometimes, a downstream primer.  

Background Fluorescence - Refers to the fluorescence inherent in an assay or experiment due 
to inefficient quenching of the reporter dye or spurious side reactions.  

Beacon Assays - A PCR type reaction that uses a probe partially complementary to the same 
area that is being amplified and is labeled with a fluorescent dye on the 5 prime end and contains 
a quencher on the 3 prime end. The probes sequence contains an extended sequence on the 
ends that are complementary to each other. In solution, the ends bind together creating a hair-pin 
structure that brings the dye and quencher very close together. If a complementary section in the 
amplified DNA exists, the center section of the probe hybridizes and breaks apart the hair-pin 
structure which separates the dye and quencher sufficiently for the dye to emit measurable light.  

Beacon Tm - Melting temperature of the beacon hairpin structure, which includes both, the 
beacon probe (loop) and the stem.  

 cDNA - complementary DNA, a DNA molecule generated by reverse transcription from an RNA 
(generally mRNA) template. 

Complementary - Refers to a nucleic acid sequence that matches and binds to another 
sequence.  

Complementary Beacon Sequence - Sequence complementary to the beacon probe sequence 
used for beacon characterization. 

Fluorophore - A class of molecules called reporter dyes that emit or fluoresce light of a particular 
wavelength as a result of being irradiated with light of another particular wavelength that excites 
the molecule. 

Free energy -The relative energy associated with an energetic system. 

FRET - Fluorescence Resonance Energy Transfer. 

Run/repeat maximum length - Numerically, the GC Clamp is the number of Gs and Cs that exist 
within the first five bases of the 3’ end. It imparts strong annealing at 3' end.  

Hairpin - Hairpins are formed within single primer due to internal self complementarity. Hairpin is 
said to be formed when the primer fold backs on itself and forms bonds at any other site. 

Homology - Similarity in DNA or protein sequences between individuals of the same species or 
amongst different species.  

Hybridization - The process of joining two complementary strands of DNA or one each of DNA 
and RNA to form a double-stranded molecule.  

Molecular beacons - Molecular beacons are hairpin shaped molecules with an internally 
quenched fluorophore whose fluorescence is restored when they bind to a target nucleic acid. 
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Multiplex - A sequencing approach that uses several pooled samples, greatly increasing 
sequencing speed.  

Oligonucleotide - a short, usually chemically synthesized polynucleotide. An oligonucleotide is 
typically 10 to 30 bases in size, but may be over 100 bases long. Synthetic oligonucleotides are 
frequently used as primers in Sanger dideoxy sequencing or PCR, or as probes to identify a gene 
sequence of interest. 

Optimal Annealing Temperature (Ta Opt) - The temperature for any given primer pair at which 
the primer pair anneals to the complementary target in the sequence. Use of this temperature in 
the annealing step of the PCR cycle usually results in an optimal PCR product yield with minimum 
false priming. 

Polymerase chain reaction or PCR - A series of reactions that result in the amplification of a 
specific DNA. 

 Primers DNA oligonucleotides that are used in Polymerase Chain Reaction (PCR) amplify the 
chosen fragment from a DNA sequence. 

Primer Melting Temperature (Tm) - The temperature at which one half of the primer-template 
DNA duplex will dissociate and become single stand DNA. The stability of the primer-template 
DNA duplex can be measured by its melting temperature (Tm). OR The melting temperature of a 
primer(Tm) refers to the temperature at which the primer is annealed to 50% of its exact 
complement (template). The melting temperature is calculated by Nearest neighbor 
thermodynamic stability using Santa Lucia or Bresulaur Values  

Product Melting Temperature (Tm) - The temperature at which one half of the amplified DNA 
duplex in PCR reaction will dissociate and become single stranded.  

PCR Extension Step - This step occurs after the DNA strands have been separated by heat and 
after the step where the primers have annealed (hybridized) to the ends of DNA template. In this 
step, a thermal -stable DNA polymerase binds to and extends the ends of the primers using the 
opposite strand as a template until it has made a complementary copy. Thermal-stable 
polymerases are most active within a certain range of temperature. 

Primers - DNA oligonucleotides that are used in Polymerase Chain Reaction (PCR) to determine 
the ends of the amplified DNA fragment the reaction generates in the presence of a polymerase. 

Primer dimer - Artifacts, non- target amplification products, caused by homologies within 
primers.  

Probes - Single-stranded DNA or RNA molecules of specific base sequence that are used to 
detect the complementary base sequence by hybridization.  

Probe Tm - Melting temperature of the beacon probe (loop) sequence that is complementary to 
the target. Calculations do not include the stem of the beacon. 

Quenchers - A class of molecules that can absorb the emission of a fluorescent dye when in 
close proximity; these molecules are often fluorescent themselves. 

Real Time PCR - The ability to monitor the real-time progress of the PCR, without the need for 
post-PCR analysis. A fluorescent reporter is used to monitor the PCR in real time. 

Single Nucleotide Polymorphisms (SNPs) - A single base pair difference in a DNA sequence 
shared among individuals.  

Sense Primer - A primer that primes the antisense strand, alternatively termed a forward primer 
or, an upstream primer. 
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Secondary structures - These form due to intramolecular or intermolecular interactions of 
primers or probe sequence, example: dimers and hairpins. They greatly reduce the availability of 
primer for reaction. 

Sensor and Anchor Probes - When FRET hybridization probes are used to detect mutations, 
the probe detecting the mutation site is known as SENSOR probe, while the other probe 
producing the fluorescent signal is known as ANCHOR probe.  

TaqMan(R) / 5'-nuclease assays - A PCR type reaction that uses a probe complementary to an 
area being amplified and is labeled with a fluorescent dye on the 5 prime end and contains a 
quencher on the 3 prime end. If the probe binds to the DNA being amplified, TAQ polymerase 
cuts off the 5 prime ends containing the fluorescent dye. Now free from the proximity of the 
quencher, the free-dye which is proportional to the amount of amplified DNA, emits measurable 
light.  

5' to 3' orientation -the direction along a polynucleotide molecule as defined by proceeding from 
the 5'-phosphate terminus towards the 3' -hydroxyl terminus or by extending a polynucleotide by 
the addition of residues to the 3'-hydroxyl terminus. 
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System Specifications 
Specifications;  
 

Supported Operating Systems Microsoft’s Windows 98, ME, NT 4.0, 2000 and XP 
Professional. Apple's Mac OS X 10.3.7. 

  

System Requirements: 

For Windows OS Required   Recommended 

CPU Pentium-II 400 MHz Pentium-III 650 MHz 

RAM 128 MB 192 MB 

Hard Disk Drive Space 40 MB 50 MB 

Screen Resolution 800 X 600 > 800 X 600 

For Macintosh OS X Required   Recommended 

CPU IMac Power PC G3 350 IMac Power PC G3 350 

RAM 256 MB 384 MB 

Hard Disk Drive Space 15 MB 25 MB 

Screen Resolution 800 X 600 > 800 X 600 
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Software Limits 
 
Software limits  

Sequence Supported 15 MB 

Sequence format Supported GenBank, FASTA, GenBank Like, dbSNP, 
Text sequence 

Primer Search limits 

Search Range Supported 50,000 bp 

Primer Search Range 25 bp 

Minimum Primer length 10 bp 

Minimum Amplicon length 50 bp 

Maximum Amplicon length 5000 bp 

Maximum Primer length 99 bp 

Maximum Alternate Primer pairs 50 

Beacon Search limits 

Search Range Supported 50,000 bp 

Maximum Sequence for Beacon Search 5 

TaqMan® Search limits 

Search Range Supported 10,000 bp 

Length Range 15 

Minimum length 10 bp 

Maximum length 99 bp 

Minimum Amplicon length 50 bp 

Maximum Amplicon length 5000 bp 

Maximum Alternate Primer pairs and 
TaqMan® Probes 

50 
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Maximum Sequence for TaqMan® Search 4 

 
LNA(TM) Substituted TaqMan Search limits 

Length Range 15 

Minimum length 7 

Maximum length 40 

Minimum No. Of LNA(TM) 1 

Maximum No. Of LNA(TM) 10 

Minimum LNA(TM) Frequency  2 

Maximum LNA(TM) Frequency 10 

Minimum LNA(TM) Phase Off Value 2 

Maximum LNA(TM) Phase Off Value 19 

Multiplex TaqMan® Search limits 

 

Sequence Range Supported 10,000bp 

Length Range 15 

Minimum Length  10bp 

Maximum length  99bp 

Amplicon Length Range difference 50bp 

Minimum Amplicon Length 50bp 

Maximum Ampliconlength  5000bp 

Maximum Alternate Primer pairs and 
TaqMan® Probes 50 

Maximum Sequence for Multiplex 4 
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Search 

Maximum Sequence selected as 
reference gene 

Number of Selected sequence for multiplex search 
-1 

 
  

FRET probe Search limits 

Search Range Supported 10,000 bp  

Length Range 15 

Minimum length 10 bp 

Maximum length 99 bp 

Minimum Amplicon length 50 bp 

Maximum Amplicon length 5000 bp 

Maximum Alternate Primer pairs and FRET 
Probes 

50 

Maximum Sequence for FRET Probe Search 1 

 
SYBR (R) Green Primer Search limits:  

Search Range Supported 50,000 bp 

Primer Search Range 25 

Minimum Primer length 10 bp 

Minimum Amplicon length 50 bp 

Maximum Amplicon length 5000 bp 

Maximum Primer length 99 bp 

Maximum Alternate Primer pairs 50 

Maximum Sequence for SYBR (R) Primer 
Search 

5 
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BLAST limits:  

Number of sequence searched at a time 1 Sequence 

Number of requests sent to NCBI 1 query at a time. 

RID Polling 30 sec for first time and every 60 sec after 
that 

In case of ISA/NTLM proxy 7000 bps 

Other proxy and direct internet connection NO LIMIT 

 
Template Structure limits:  

Number of sequence searched at a time 1 

Number of requests sent to QuikFold 1 query at a time. 

Maximum length of bases 1200BP 

Minimum length of bases 50BP 

Additional Information:  

Multiplex Primer -Primer 5 Sequences 

Multiplex Beacon- Primers 5 Sequences 

Multiplex TaqMan- Primers 4 Sequences 

Multiplex FRET- Primers Not supported 

Multiplexing of SYBR (R) Green Primers Not supported 

Number of SNP selected per sequence 1 

Number of SNP per sequence Unlimited 

SNP format supported /replace="t" 

Number of SNP deleted per sequence All 

Number of Primers evaluated at once 1 
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Number of Beacons evaluated at once 1 

SNP Position No limit 
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Terms of Use 
 
Beacon Designer connects to the Quikfoldserver available at:  

http://www.bioinfo.rpi.edu/applications/mfold/old/rna/form3.cgi  

This server is run by Professor Michael Zuker at Rensselaer Polytechnic Institute. The 
Quikfoldserver uses the mfold software, copyright Washington University, created by Professor 
Zuker.  

PREMIER Biosoft International assumes no liability for unauthorized or illegal use of this server. 
Further information on the server is available at: 
http://www.bioinfo.rpi.edu/applications/mfold/old/dna/form1.cgi 

NCBI's Disclaimer and Copyright notice:  

http://www.ncbi.nlm.nih.gov/About/disclaimer.html 

BLAST Server - Terms of Use 

Beacon Designer connects to the BLAST server at:  

http://www.ncbi.nlm.nih.gov/blast/Blast.cgi 

This server is run by the U.S. Government. The user will be responsible for following the 
guidelines and policies set up by the U.S. Government for using the BLAST server. 

PREMIER Biosoft International assumes no liability for unauthorized or illegal use of this server.  

For your convenience, we urge you to strictly follow these guidelines:- 

- Submit only a few thousand individual requests per day (not more than 2000 per day), 

- Limit all large searches to the off peak hours of 9 PM to 5 AM Eastern Standard Time (USA). 

For further information or queries please visit: 

http://www.ncbi.nlm.nih.gov/BLAST/ 
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Registered Tademarks:  

TaqMan(R): TaqMan is a registered trademark of Roche Molecular Systems, Inc.  

SYBR(R): SYBR(R) is the registered trademark of Molecular Probes INC. 

NASBA®: NASBA® is the registered trademark of bioMérieux. 
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